Please update this package to 1.7.1

Bug #606642 reported by Bhavani Shankar on 2010-07-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ugene (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ugene

There is a new upstream version release and the package in the archive needs an update

Regards

Related branches

Bhavani Shankar (bhavi) on 2010-07-17
Changed in ugene (Ubuntu):
status: New → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Bhavani Shankar (bhavi) wrote :
Changed in ugene (Ubuntu):
status: In Progress → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
Stefano Rivera (stefanor) wrote :

What about:
ERROR: ld.so: object 'libfakeroot-sysv.so' from LD_PRELOAD cannot be preloaded: ignored.
E: ugene: manpage-not-compressed-with-max-compression usr/share/man/man1/ugene.1.gz

Changed in ugene (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → Bhavani Shankar (bhavi)
Stefano Rivera (stefanor) wrote :

err, the libfakeroot complaint can obviously be ignored, I didn't notice it was libfakeroot :)

Bhavani Shankar (bhavi) wrote :

Hello stefano

It should be compressed with gzip I suppose and forwarding the lintian error upstream, until its fixed you can proceed upload I think

regards

Bhavani Shankar (bhavi) on 2010-07-22
Changed in ugene (Ubuntu):
status: Incomplete → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
Stefano Rivera (stefanor) wrote :

I don't see why this is an upstream issue? The package is an Ubuntu one. Right?

Bhavani Shankar (bhavi) wrote :

No stefano, this has a upstream and ubuntu package is a part of it

ref:

http://ugene.unipro.ru/

and the lintian error is due to not compressing the manpage to the required compression so that lintian is satisfied

so its better off reporting to the upstream and wait for them to do a little tweak with their manpage

Ivan: Your comments please

regards

Bhavani Shankar (bhavi) wrote :

and its not an error of such severity which may affect the working of the package so you can upload the package and the error will be fixed in the next release I think

Regards

Stefano Rivera (stefanor) wrote :

Generally speaking we fork /debian and replace it with our own, unless one of the upstream developers is the packager who maintains the package in Ubuntu.

I agree that this isn't severe, but if it were Debian, most sponsors would want the package to be lintian clean.

Stefano Rivera (stefanor) wrote :

BTW: Please inform the upstream taht they should talkt o debian-science about getting this into Debian

Changed in ugene (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ugene - 1.7.1+repack-0ubuntu1

---------------
ugene (1.7.1+repack-0ubuntu1) maverick; urgency=low

  * New upstream release (LP: #606642)
  * Switch to 3.0 (quilt) format
  * Bump standards-version to 3.9.0. No other changes.
  * Add ${misc:Depends} macro to Depends field (W: lintian)
  * Add versioned dependency on debhelper (W: lintian)
  * Casting fix dropped, fixed upstream.
 -- Bhavani Shankar <email address hidden> Sat, 17 Jul 2010 19:31:43 +0530

Changed in ugene (Ubuntu):
status: Fix Committed → Fix Released
Bhavani Shankar (bhavi) wrote :

agreed stefano,

Ivan efremov is one of the upstream developers who is the original debianizer/maintainer of the package in ubuntu So was my above comments

I ve subscribed him to this bug hope he replies to our comments

regards

Ivan Efremov (iefremov) wrote :

Hi Stefano and Bhavani,
surely, the issue with manpage will be fixed in the next release of UGENE, which is planned for august 2010.

Thanks for updating the package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers