[oneiric] ufw ftbfs

Bug #812516 reported by Jamie Strandboge on 2011-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ufw (Ubuntu)
High
Jamie Strandboge
Oneiric
High
Jamie Strandboge

Bug Description

ufw FTBFS with:
Performing tests 'good/reports'
- installing
- result:
Command 'show listening' exited with '1', but expected '0'
    ** FAIL **

Reproducer in a schroot:
$ schroot -c oneiric-amd64 -u root
# apt-get update
# apt-get -y --force-yes dist-upgrade
# apt-get install build-dep ufw
# su jamie
$ apt-get source ufw
$ cd ufw-0.30.1
$ make devel
$ PYTHONPATH=$PYTHONPATH:./tmp/ufw/lib/python fakeroot ./tmp/ufw/usr/sbin/ufw show listening

Changed in ufw (Ubuntu Oneiric):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → High
milestone: none → oneiric-alpha-3
status: New → In Progress
description: updated
description: updated
description: updated
Jamie Strandboge (jdstrand) wrote :

This is the failing line in src/util.py:
for j in os.listdir(fd_path):

It dies with:
Traceback (most recent call last):
  File "./tmp/ufw/usr/sbin/ufw", line 111, in <module>
    res = ui.do_action(pr.action, "", "", pr.force)
  File "/home/jamie/ubuntu/sbuild/ufw/oneiric/test3/ufw-0.30.1/tmp/ufw/lib/python/ufw/frontend.py", line 587, in do_action
    res = self.get_show_listening()
  File "/home/jamie/ubuntu/sbuild/ufw/oneiric/test3/ufw-0.30.1/tmp/ufw/lib/python/ufw/frontend.py", line 271, in get_show_listening
    d = ufw.util.parse_netstat_output(self.backend.use_ipv6())
  File "/home/jamie/ubuntu/sbuild/ufw/oneiric/test3/ufw-0.30.1/tmp/ufw/lib/python/ufw/util.py", line 657, in parse_netstat_output
    netstat_output = get_netstat_output(v6)
  File "/home/jamie/ubuntu/sbuild/ufw/oneiric/test3/ufw-0.30.1/tmp/ufw/lib/python/ufw/util.py", line 875, in get_netstat_output
    inodes = _get_proc_inodes()
  File "/home/jamie/ubuntu/sbuild/ufw/oneiric/test3/ufw-0.30.1/tmp/ufw/lib/python/ufw/util.py", line 786, in _get_proc_inodes
    for j in os.listdir(fd_path):
OSError: [Errno 13] Permission denied: '/proc/1/fd'

Simply wrapping that in a 'try' in enough to fix the bug. I'm guessing this is a result of the following in fakeroot:
fakeroot (1.16-1) unstable; urgency=low

  * Patch from Jonathan Nieder to add access() support.
    closes: #629956.

description: updated
Changed in ufw (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.30.1-2ubuntu1

---------------
ufw (0.30.1-2ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/rules: Don't install the upstream application profiles that are
      shipped with the Debian package.
    - debian/control: use ufw-0.30-oneiric for Vcs-Bzr

ufw (0.30.1-2) unstable; urgency=low

  * debian/control: make lintian clean:
    - update Standards-Version to 3.9.2
    - Build-Depends on python (>= 2.6.6-3~)
  * conf/ufw.defaults:
    - remove IRC connection tracking, which is only required for DCC.
      Cherrypick r741 from trunk
    - allow nf_conntrack_netbios_ns (Samba). Cherrypick r744 from trunk.
      LP: #360975 (Closes: 631737)
  * enable IPv6 by default and fix 'allow to any ipv6' when IPv6 is enabled.
    Cherrypick r742 from trunk.
  * update manpage references to ufw and ufw-framework to include the section.
    Cherrypick r743 from trunk.
  * ACCEPT UPnP (239.255.255.250 for IPv4 and ff02::f for IPv6) for service
    discovery just like we do for mDNS (ie, allow discovery, but not
    connections to the services). LP: #764933
  * debian/ufw.logrotate.debian, debian/ufw.logrotate.ubuntu, debian/rules:
    use 'rotate' option in Debian logrotate file and split out ufw.logrotate
    like we do the initscript since because Ubuntu's rsyslog doesn't have the
    'rotate' option yet. (Closes: 628605)
  * Cherrypick r746 from trunk to update check-requirements to prompt to
    continue with tests that may autoload modules. Add '-f' option to
    check-requirements and update test suite accordingly (LP: #782816)
  * Cherrypick r747 from trunk to not fail when running 'show listening' under
    fakeroot (LP: #812516)
  * debian/postinst:
    - remove some old upgrade transition code for unsupported upgrade paths
    - reload ufw if it is enabled and we are upgrading to this version since
      this is needed after enabling IPv6
  * debian/rules: add build-arch and build-indep targets

ufw (0.30.1-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Rebuild to add Python 2.7 support
 -- Jamie Strandboge <email address hidden> Mon, 18 Jul 2011 17:09:57 -0500

Changed in ufw (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers