show listening report traces back

Bug #624199 reported by Jamie Strandboge on 2010-08-25
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ufw (Ubuntu)
Low
Jamie Strandboge
Lucid
Low
Jamie Strandboge
Maverick
Low
Jamie Strandboge

Bug Description

Binary package hint: ufw

This used to work on Lucid, but fails on Maverick:

$ sudo ufw show listening
Traceback (most recent call last):
  File "/usr/sbin/ufw", line 111, in <module>
    res = ui.do_action(pr.action, "", "", pr.force)
  File "/usr/lib/python2.6/dist-packages/ufw/frontend.py", line 580, in do_action
    res = self.get_show_listening()
  File "/usr/lib/python2.6/dist-packages/ufw/frontend.py", line 297, in get_show_listening
    ifname = ufw.util.get_if_from_ip(addr)
  File "/usr/lib/python2.6/dist-packages/ufw/util.py", line 711, in get_if_from_ip
    raise IOError(errno.ENODEV, "No such device")
IOError: [Errno 19] No such device

Related branches

Changed in ufw (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.30.0-1ubuntu1

---------------
ufw (0.30.0-1ubuntu1) maverick; urgency=low

  * src/frontend.py: display unicode error messages properly. Thanks to
    Serguey Basalaev.
    - upstream commit r700
    - LP: #580032
  * src/backend_iptables.py: fix gettext warning
    - upstream commit r701
  * run debconf-updatepo, but adjust debian/po/de.po and debian/po/es.po to
    add correct "Language:" tag
  * profiles/ufw-mailserver: remove Postfix specific language
    - upstream commit r705

ufw (0.30.0-1) unstable; urgency=low

  * New upstream release. Use 0.30.0 as the version even though upstream uses
    0.30 in order to sync to Ubuntu. Fixes:
    - LP: #568877
    - LP: #611982
    - LP: #606997
    - LP: #624199
    - LP: #625340
    - LP: #521359
    - LP: #436608
  * don't flush chains if ufw is not enabled (LP: #581744)
  * debian/postinst: don't source /usr/share/debconf/confmodule when $1 =
    triggered. Fix thanks to Colin Watson. (LP: #618410)
  * debian/control:
    - drop versioned depends on iptables. This helps with backporting now that
      the test suite can handle it
    - updated Standards-Version
  * debian/rules:
    - pass interpreter to run_tests.sh
    - don't install upstream application profiles for now
  * add rsyslog support
  * add debian/source/format
  * debian/before6.rules.md5sum: updated for ucf
 -- Jamie Strandboge <email address hidden> Mon, 30 Aug 2010 13:20:58 -0500

Changed in ufw (Ubuntu):
status: In Progress → Fix Released
Changed in ufw (Ubuntu Maverick):
status: New → Fix Released
importance: Undecided → Low
Changed in ufw (Ubuntu Lucid):
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Jamie Strandboge (jdstrand)
Changed in ufw (Ubuntu Maverick):
assignee: nobody → Jamie Strandboge (jdstrand)
Changed in ufw (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers