ufw crashed with ValueError in under_ssh()

Bug #424528 reported by Vish on 2009-09-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ufw
Undecided
Jamie Strandboge
ufw (Ubuntu)
Low
Jamie Strandboge

Bug Description

Binary package hint: ufw

Crashed while installing devscripts

ProblemType: Crash
Architecture: i386
Date: Sat Sep 5 00:53:39 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/sbin/ufw
InterpreterPath: /usr/bin/python2.6
Package: ufw 0.29-1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/ufw app update all
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
PythonArgs: ['/usr/sbin/ufw', 'update', 'all']
SourcePackage: ufw
Title: ufw crashed with ValueError in under_ssh()
Uname: Linux 2.6.31-9-generic i686
UserGroups:

Vish (vish) wrote :
tags: removed: need-duplicate-check
Vish (vish) on 2009-09-05
visibility: private → public
Jamie Strandboge (jdstrand) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem. We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

Specifically, we need the specific steps or actions you took that caused you to encounter the problem. Thanks!

Changed in ufw (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
status: New → Incomplete
Vish (vish) wrote :

As I'v mentioned " Crashed while installing devscripts "

To give the whole story ;p

I was following the classroom > https://wiki.ubuntu.com/MeetingLogs/devweek0909/PkgFromScratch
i did a "sudo apt-get install devscripts"
and the apport reported a crash had occurred and it was ufw...

there were no problems with the install , hmm... from what i recall i didnt do anything else...

Jamie Strandboge (jdstrand) wrote :

Ok. It seems that a parent process went away while ufw was running. I'll think about if there is a more graceful way to handle this condition. Thanks

Changed in ufw (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
Changed in ufw (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.29-3

---------------
ufw (0.29-3) unstable; urgency=low

  * use upstart instead of sysv initscript on Ubuntu (LP: #431804)
    - debian/control: Bump build-dependency on debhelper for Upstart-aware
      dh_installinit. Add Build-Dep on lsb-release
    - add debian/ufw.upstart.ubuntu
    - move debian/ufw.init to debian/ufw.init.debian
    - debian/ufw.init: rename to debian/ufw.init.debian and update insserv
      info to reflect reality
    - debian/rules: use upstart if Ubuntu and sysv if Debian
    - debian/postinst and debian/postrm: remove calls to update-rc.d
  * error out when filesystem is read-only. Merge from trunk (LP: #430053)
  * catch exception if can't find parent pid when refreshing application
    profiles. Merge from trunk (LP: #424528)
  * add doc/upstart.example and update README for Debian users who want to
    use upstart

 -- Jamie Strandboge <email address hidden> Fri, 18 Sep 2009 15:35:45 +0100

Changed in ufw (Ubuntu):
status: Fix Committed → Fix Released
Jamie Strandboge (jdstrand) wrote :

Fixed in 0.29.1

Changed in ufw:
assignee: nobody → Jamie Strandboge (jdstrand)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers