ufw should better support preseeding

Bug #307715 reported by Colin Whittaker on 2008-12-13
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ufw (Ubuntu)
Wishlist
Jamie Strandboge

Bug Description

Binary package hint: ufw

I am currently automating ubuntu installs via preseeding and one of the requirements is to enable ufw by default for a newly installed host.

Currently I dothis via a script executed at the end of the install which includes the following:

if [ -x /usr/sbin/ufw ]; then
        ufw allow OpenSSH
        ufw app default DENY
        echo y | ufw enable
fi

It would be nice if "ufw -q enable" worked without needing input.

Related branches

Duane Hinnen (duanedesign) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is a Feature Request to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at [WWW] https://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Jamie Strandboge (jdstrand) wrote :

I plan to add debconf support to ufw which means you'll be able to use preseeding for this instead.

Changed in ufw:
assignee: nobody → jdstrand
importance: Undecided → Wishlist
status: New → Confirmed
Duane Hinnen (duanedesign) wrote :

That sounds great!
Thank you Jamie for all the work you do to make Ubuntu even better.
Colin, keep submitting your bugs and ideas your input is very important.

Colin Whittaker (colin-netech) wrote :

That is just as good.
If there is anything I can do to help or test let me know.

Thanks,

Colin

Changed in ufw:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.26-0ubuntu1

---------------
ufw (0.26-0ubuntu1) jaunty; urgency=low

  * new upstream release, which fixes:
    - formatting of dpkg output incorrect on upgrades (LP: #300726)
    - new REJECT functionality (LP: #197322)
    - ufw shouldn't flush built-in chains by default. New MANAGE_BUILTINS
      configuration option can be used to restore the old (flush) behavior
  * debian/control:
    - Build-Depends-Indep on iptables (required for iptables version check in
      setup.py)
    - add ${misc:Depends} to Depends and bump Standards-Version to 3.8.0
    - update Description
    - move po-debconf to Build-Depends
  * added debian/watch
  * debian/source.lintian-overrides: don't complain about
    no-complete-debconf-translation
  * debian/rules:
    - rename and gzip upstream changelogs
    - rename initscript.ubuntu to ufw.init and use dh_installinit (but
      continue to use /etc/defaults/ufw installed via setup.py for now)
    - cleanup dh_installdirs
    - use dh_installexamples for example files
    - run debconf-updatepo in clean target
  * debian/postinst: remove old ufw.rules check because ufw.rules existed for
    only a short time during the Hardy development cycle, it's ignored by ufw
    and its existence is harmless.
  * debian/config and debian/templates: remove ufw/oldrules
  * provide debconf mechanism for enabling the firewall and setting some basic
    rules (LP: #307715)

 -- Jamie Strandboge <email address hidden> Fri, 16 Jan 2009 08:02:36 -0600

Changed in ufw:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers