formatting of dpkg output incorrect on upgrades

Bug #300726 reported by Jamie Strandboge on 2008-11-21
6
Affects Status Importance Assigned to Milestone
ufw (Ubuntu)
Low
Jamie Strandboge
Intrepid
Undecided
Jamie Strandboge

Bug Description

Binary package hint: ufw

In Jaunty, on upgrade I had:
Processing triggers for ufw ...

Rules updated for profile 'Apache'Firewall reloaded

This should be:
Processing triggers for ufw ...

Rules updated for profile 'Apache'
Firewall reloaded

or similar

Changed in ufw:
assignee: nobody → jdstrand
importance: Undecided → Low
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

This will be fixed in the next version of ufw.

Changed in ufw:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.26-0ubuntu1

---------------
ufw (0.26-0ubuntu1) jaunty; urgency=low

  * new upstream release, which fixes:
    - formatting of dpkg output incorrect on upgrades (LP: #300726)
    - new REJECT functionality (LP: #197322)
    - ufw shouldn't flush built-in chains by default. New MANAGE_BUILTINS
      configuration option can be used to restore the old (flush) behavior
  * debian/control:
    - Build-Depends-Indep on iptables (required for iptables version check in
      setup.py)
    - add ${misc:Depends} to Depends and bump Standards-Version to 3.8.0
    - update Description
    - move po-debconf to Build-Depends
  * added debian/watch
  * debian/source.lintian-overrides: don't complain about
    no-complete-debconf-translation
  * debian/rules:
    - rename and gzip upstream changelogs
    - rename initscript.ubuntu to ufw.init and use dh_installinit (but
      continue to use /etc/defaults/ufw installed via setup.py for now)
    - cleanup dh_installdirs
    - use dh_installexamples for example files
    - run debconf-updatepo in clean target
  * debian/postinst: remove old ufw.rules check because ufw.rules existed for
    only a short time during the Hardy development cycle, it's ignored by ufw
    and its existence is harmless.
  * debian/config and debian/templates: remove ufw/oldrules
  * provide debconf mechanism for enabling the firewall and setting some basic
    rules (LP: #307715)

 -- Jamie Strandboge <email address hidden> Fri, 16 Jan 2009 08:02:36 -0600

Changed in ufw:
status: Fix Committed → Fix Released
Jamie Strandboge (jdstrand) wrote :

Fix committed in bzr. Will prepare an SRU soon.

Changed in ufw:
assignee: nobody → jdstrand
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted ufw into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Jamie Strandboge (jdstrand) wrote :

Fixed in 0.23.3

$ apt-cache policy ufw
ufw:
  Installed: 0.23.3
  Candidate: 0.23.3
  Version table:
 *** 0.23.3 0
        500 http://archive.ubuntu.com intrepid-proposed/main Packages
        100 /var/lib/dpkg/status
     0.23.2 0
        500 http://192.168.122.1 intrepid/main Packages

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ufw - 0.23.3

---------------
ufw (0.23.3) intrepid-proposed; urgency=low

  * debian/postinst: don't stop in runlevels 0 and 6 (LP: #298736)
  * don't do symlink check anymore (LP: #317700)
  * conf/initscript: don't flush rules on stop when not enabled (LP: #311066)
  * formatting of dpkg output incorrect on upgrades (LP: #300726)
  * debian/control: update Vcs information

 -- Jamie Strandboge <email address hidden> Mon, 19 Jan 2009 10:32:03 -0600

Changed in ufw:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers