Ubuntu

Pull new dcraw.c to support Canon Powershot S95

Reported by David R. Hedges on 2011-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ufraw (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ufraw

This is a request to build gimp-ufraw (and perhaps then also ufraw, dcraw, gimp-dcraw) based on a new upstream version of dcraw.c ( http://www.cybercom.net/~dcoffin/dcraw/dcraw.c ), which was updated around 2010-11-28 to provide support for the Canon Powershot S95 (discussed near the end of this thread: http://forums.dpreview.com/forums/readflat.asp?forum=1010&thread=36306379 . The current version in maverick produces very poor results.

Alternatively, add the following line to dcraw.cc just below the line for "PowerShot S70" (though this will exclude any other updates he's made):
    { "Canon PowerShot S95", 0, 0,
 { 13610,-5487,-1268,-1373,9773,1601,-824,1545,3772 } },

David R. Hedges (p14nd4) wrote :
tags: added: patch
David R. Hedges (p14nd4) wrote :

ufraw 0.18 was just packaged by Debian]1][2], which could be used to solve this bug, if an exception to the Debian import freeze was granted for this package.

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583879
[2] http://packages.debian.org/sid/gimp-ufraw

Daniel Holbach (dholbach) wrote :

Hum... comparing your version of dcraw.cc with the one in 0.18 in Debian, I get this:

...
     { "Canon PowerShot S95", 0, 0,
- { 13610,-5487,-1268,-1373,9773,1601,-824,1545,3772 } },
+ { 13440,-5896,-1279,-1236,9598,1931,-180,1001,4651 } },
     { "Canon PowerShot A470", 0, 0, /* DJC */
...

Which entry is correct?

David R. Hedges (p14nd4) wrote :

Compiling the package with the S95 line inserted to try it was on my to-do list for last night, but fell victim to errands and packing for my trip departure tomorrow morning. I'll try to give this a shot today, and run through tests both ways, but I'm inclined to go with the 0.18 version rather than the version I'd pasted (which came from a first attempt at S95 support, prior to even being added to the dcraw.c RCS). If you just want to get this done, go with the 'new' line, not my line (so as to stay consistent with upstream); sorry about that:
    { "Canon PowerShot S95", 0, 0,
    { 13440,-5896,-1279,-1236,9598,1931,-180,1001,4651 } },

David R. Hedges (p14nd4) wrote :

I'm not particularly well-equipped to diagnose exactly what the cause is, but neither version of the proposed dcraw.cc change appeared to solved the problem (or, for that matter, produce any noticeable difference). Building 0.18 [from the sid deb-src] did resolve the problem. So it appears this either demands further investigation on a more extensive back-port patch to support the S95, or can be solved by pulling ufraw 0.18.

P.S. I followed the directions here[1] with just ubuntu sources first, modified ufraw-0.16/dcraw.cc, and then ran dch -i, debuild, and dpkg -i for the resulting file (e.g. gimp-ufraw_0.16-3ubuntu1_i386.deb). If this method blows away local source modifications using the source tar or diff at debuild time or is otherwise an unsuitable build method, please let me know.

[1] http://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_porting_a_package_to_the_stable_system

Fixed in Natty beta with UFRaw 0.18.

Daniel Holbach (dholbach) wrote :

Thanks a lot for the feedback. Closing.

Changed in ufraw (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.