Ufraw does not process Canon EOS 450D RAW files correctly.

Bug #228623 reported by Ruben Vermeersch on 2008-05-09
This bug affects 5 people
Affects Status Importance Assigned to Milestone
dcraw (Debian)
Fix Released
dcraw (Ubuntu)
libkdcraw (Ubuntu)
ufraw (Ubuntu)

Bug Description

Ufraw currently gives a very pink result when processing Canon EOS 450D files. This is because there is not support for this camera yet. A simple patch could fix this.

Patch can be found here: http://const.deribin.com/ufraw_and_Canon_450D
Screenshot & sample files showing the problem: http://files.savanne.be/linux/raw/

This happens with ufraw 0.13-1build1

Jean-Baptiste Lallement (jibel) wrote :

confirmed and affecting to the right package.

Jean-Baptiste Lallement (jibel) wrote :

Right package is dcraw not ufraw.

Version 8.86 of dcraw solves this issue.

  Installed: 8.80-1
  Candidate: 8.80-1

Ruben Vermeersch (ruben) wrote :

Also affects ufraw. While ufraw uses dcraw code, it does not do so by a dependency (which due to the design of dcraw is impossible).

It should be fixed in both packages, not solely in dcraw.

Jean-Baptiste Lallement (jibel) wrote :

Yes, you're right.

confirming the ufraw issue too. Thanks.

Changed in ufraw:
status: New → Confirmed

Version: (using KDE 3.5.9)
Installed from: Gentoo Packages

New version of dcraw 8.86 adds compatibility to newer canons DSLR's using the digic III chip, including the new EOS Digital Rebel XSi / 450D. Without the newer version, raw decode has a very pink cast in digikam and other applications that rely on dcraw. Further problem description with patch for dcraw prior to 8.86 found here: http://const.deribin.com/ufraw_and_Canon_450D However, the 8.86 release fixes the problem.

silicoid (ubuntuuniverse) wrote :

digikam/libkdcraw has the same problem.

Jean-Baptiste Lallement (jibel) wrote :

It affect digikam by a dependency on libkdcraw.
* task digikam => removed
* task libkdcraw => added

Changed in digikam:
status: New → Invalid
Jean-Baptiste Lallement (jibel) wrote :

Confirming task libkdcraw. libkdcraw in Intrepid is 0.1.4-2 based on dcraw 8.83 but this issue is solved in dcraw 8.86.

Changed in libkdcraw:
status: New → Confirmed
Changed in dcraw:
status: Unknown → New
Jean-Baptiste Lallement (jibel) wrote :

Solved upstream in 8.86. Need upgrade.

Changed in dcraw:
status: Confirmed → Fix Committed
Changed in libkdcraw:
status: Unknown → New
David Lewis (lewisharwood) wrote :


Just bought the EOS 450, is there a package available for Hardy?


Actual ufraw in cvs use dcraw 8.83.

Dcraw support Canon 450D since 8.84 so be patient :)

I think Ubuntu can use the fix to build an fixed version of UFRaw (and the rest) to get this bug fixed and not wait till UFRaw releases a new version.
The EOS 450D is a popular camera (or better the Canon series are popular) and I guess that's why Ubuntu should support it as soon as possible.

Ask about ufraw bug here is cool, but report directly the bug upstream is nicer ;)


noone is asking ufraw author to add 450D support, why ?

As far as I read they are discussing a lot about the use of dcraw or a library like libopenraw, libkdcraw and libraw. Using such a library would solve this problem is my opinion, but it seems UFRaw development team likes it the way thy do it now and it would imply a lot of changes to UFRaw..
The next version of UFRaw will include at least 8.86 because that is the version in CVS. So then this problem would be solved. So bring this bug upstream is not really useful.
BTW I don't see why dcraw couldn't be updated, because there is no dependency between UFraw and dcraw, UFRaw includes their own version of dcraw. In my opinion this bug (the ufraw one) doesn't affect th other libs and dcraw.

Just saw that the bugreportstarter made a PPA (https://launchpad.net/~ruben/+archive) with a patched version of UFRaw.

Great. Can someone with this issue with the Canon 450D test this PPA. We'll then go through the sponsoring process.


Changed in dcraw:
status: New → Fix Released

I have a Canon EOS 450D, and my PPA backport sorts the issue.

This file is fixed using new libkdcraw release based on libraw (KDE3) and (KDE4)

Gilles Caulier

Changed in libkdcraw:
status: New → Fix Released
Casey Link (unnamedrambler) wrote :

I just installed digikam 0.9.4 today with libkdcraw3 0.1.4-2ubuntu1 and i still have this issue. Any updates?

Pascal de Bruijn (pmjdebruijn) wrote :

Jaunty will have UFRaw 0.14.1 which should have this fixed!

Jaunty is months away. I've got thousands of vacation photos, and soon
holiday season photos I need to process. Is there any chance of an
update release for intrepid, or a package in some dev's PPA?

Dylan McCall (dylanmccall) wrote :

I am running an up to date UFRaw (0.14.1) from GetDeb, and it has so
far worked fine. Here is a link:

Casey Link (unnamedrambler) wrote :

Digikam doesn't use the ufraw package, though it is affected by the
same bug. Digikam uses libkdcraw, which hasn't been updated yet and is
not available from getdeb :(

I have the fixed dcraw package in my PPA, I might get on to libkdcraw tomorrow.

Akkana Peck (akkzilla) wrote :

Any chance of getting a fix in Hardy? It's a pretty common camera and Hardy is a LTS release.

Casey Link (unnamedrambler) wrote :

Any updates on getting libkdcraw fixed?

takamori (dt02472) wrote :

For those having problems and using Hardy: UFRaw 0.15 from getdeb with the standard dcraw 8.80 in the Hardy repos works well with a Canon EOS 450D. The ufraw 0.13 version from the Hardy repos does not. Note I have not tested UFRaw 0.14 or Intrepid.

Jonathan Thomas (echidnaman) wrote :

The libkdcraw shipped with KDE4 is fixed, according to upstream.

Changed in libkdcraw (Ubuntu):
status: Confirmed → Fix Released
faultygearbox (faultygearbox) wrote :

The same problem still exists for EOS 500D, atleast, with UFRaw 0.15 and dcraw 8.86.

Lauri Uotinen (lauri-uotinen) wrote :

Confirmed bug exists in
Intrepid Ibex (8.10) 64-bit
dcraw 8.80
ufraw 0.13

Installing ufraw 0.15 => problem remains
Installing dcraw 8.86 => problem fixed (atleast for Canon EOS 450D / .cr2)

PS. You can get dcraw 8.86 here:

This patch updates dcraw.cc and dcraw.h to the latest version. This will fix the problem. A better fix will be to update the ufraw package to the current UFRaw cvs code base which fixes other problems as well.

JGJones (jgjones) wrote :

ufraw doesn't support Canon 500D on Karmic Koala (although software that use dcraw such as RawTherapee doesn't have an issue). There is an updated version of ufraw in a PPA that does support 500D available here - https://launchpad.net/~pmjdebruijn/+archive/ppa

It would be good if ufraw can be updated to support 500D before it's released.


Both ufraw and dcraw can read Canon EOS 450D files in Karmic.

Changed in dcraw (Ubuntu):
status: Fix Committed → Fix Released
Changed in ufraw (Ubuntu):
status: Confirmed → Fix Released
Changed in libkdcraw:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.