Error mounting.... system call failed:Structure needs cleaning (ext4)

Bug #1859618 reported by painfeel on 2020-01-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
Undecided
Unassigned

Bug Description

yesterday i made two NTFS partition then i decided to make it ext4 i copied all files from NTFS to desktop then made the partition ext4 and then i transferred all the files copy pasting, it worked fine but now this morning when i try to open the drives it says:

Unable to acess location
Error mounting/dev/sdX at/media/myusernam/D:
mount(2) system call failed: Structure needs cleaning

all my important files are in there what should i do? i switched from windows finally i also installed windows after ubuntu and windows was making its files in the NTFS partitions thats i made the NTFS to ext4 so windows can't find it

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: udisks2 2.7.6-3ubuntu0.2
ProcVersionSignature: Ubuntu 5.0.0-37.40~18.04.1-generic 5.0.21
Uname: Linux 5.0.0-37-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.9
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
CustomUdevRuleFiles: 70-snap.vlc.rules 70-snap.core.rules 70-snap.canonical-livepatch.rules
Date: Tue Jan 14 17:26:01 2020
InstallationDate: Installed on 2020-01-05 (8 days ago)
InstallationMedia: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 (20190805)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
 Bus 001 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: System manufacturer System Product Name
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-37-generic root=UUID=5d77a6cd-d220-47f1-81cb-3c859989a6b8 ro quiet splash vt.handoff=1
SourcePackage: udisks2
Symptom: storage
Title: No permission to access files on storage device
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1205
dmi.board.asset.tag: Default string
dmi.board.name: PRIME B250M-A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1205:bd05/11/2018:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEB250M-A:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

painfeel (suretrust2018) wrote :
painfeel (suretrust2018) wrote :

i ran the disk app from the launcher and used the file "Repair Filesystem..." it gave me this error

Error reparing filesystem on /dev/sdX: reported exit code... (udisj-error-quark, 0)

but the drives are mounting and i can access the files

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers