Mouting a disk or iso image asks for sudo password

Bug #1779238 reported by Laurent Dinclaux on 2018-06-29
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Disks
Expired
Medium
gnome-disk-utility (Ubuntu)
Undecided
Unassigned
udisks2 (Ubuntu)
Fix Released
Unknown
Bionic
Undecided
Unassigned

Bug Description

* Impact
Users are prompted for an admin password to mount iso or disk images

* Test case
- right click an iso image and select "Open with disk image mounter" (or double click as it is the default action)

-> the image should be mounted

* Regression potential
Make sure disks and images handling in the desktop still works

-------------------------

This issue is simple to reproduce on a fresh 18.04 install:

- right click an iso image and select "Open with disk image mounter" (or double click as it is the default action)

and/or:

- issue the command `gnome-disk-image-mounter image.iso`

The resulting is a dialog asking for the user's password and the message "Authentification is required to modify the loop device /dev/loop22"

It is a show stopper for me as I use gnome-disk-image-mounter in an automated way.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-disk-utility 3.28.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Jun 29 10:51:31 2018
InstallationDate: Installed on 2018-06-28 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: gnome-disk-utility
UpgradeStatus: No upgrade log present (probably fresh install)

Laurent Dinclaux (dreadlox) wrote :
Changed in gnome-disk-utility:
importance: Unknown → Medium
status: Unknown → Expired
Laurent Dinclaux (dreadlox) wrote :

This has been fixed upstream, see this patch https://github.com/storaged-project/udisks/commit/b025f2bb2b148451417ae64a8c878ea4e6442a02 and this thread https://github.com/storaged-project/udisks/issues/546

It seems that it is now up to the Ubuntu's package maintainer to apply it to Ubuntu.

affects: udisks → udisks2 (Ubuntu)
tags: added: has-patch
tags: added: fixed-upstream
tags: added: regression-release
removed: fixed-upstream has-patch
Changed in udisks2 (Ubuntu):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

I'm upload that fix to cosmic and as a SRU to bionic

Changed in udisks2 (Ubuntu):
importance: Unknown → Undecided
status: New → Fix Committed
importance: Undecided → Low
description: updated
Sebastien Bacher (seb128) wrote :

(upload->uploading)

Changed in udisks2 (Ubuntu):
importance: Low → Unknown
status: Fix Committed → New
Changed in udisks2 (Ubuntu):
status: New → Fix Released

Hello Laurent, or anyone else affected,

Accepted udisks2 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/udisks2/2.7.6-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in udisks2 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

I have re-uploaded it with a different version number. Wasn't really anything bad, it's just that we generally prefer to reserve the ~<series_number>.1 versioning notation for cases where the usual scheme doesn't quite work (or some special direct backports of new upstream versions). For single uploads like this it's just enough to use the regular SRU versioning.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.