udisksd crashed with SIGSEGV in g_mutex_lock()

Bug #1707451 reported by Jaroslav Svoboda on 2017-07-29
758
This bug affects 163 people
Affects Status Importance Assigned to Milestone
udisks
New
Unknown
glib2.0 (Ubuntu)
Undecided
Unassigned
udisks2 (Ubuntu)
High
Andrea Azzarone

Bug Description

Showed up after login

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: udisks2 2.6.5-2ubuntu1
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.6-0ubuntu4
Architecture: amd64
Date: Sun Jul 30 00:35:31 2017
ExecutablePath: /usr/lib/udisks2/udisksd
InstallationDate: Installed on 2017-06-22 (37 days ago)
InstallationMedia: Ubuntu-GNOME 17.10 "Artful Aardvark" - Alpha amd64 (20170622)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdline: /usr/lib/udisks2/udisksd
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.11.0-10-generic.efi.signed root=UUID=44b31662-d2ab-443b-9546-86d022d8de0d ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f4900fb5c65 <g_mutex_lock+5>: lock xadd %eax,(%rdi)
 PC (0x7f4900fb5c65) ok
 source "%eax" ok
 destination "(%rdi)" (0x3a9d80e262617474) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: udisks2
StacktraceTop:
 g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 main ()
Title: udisksd crashed with SIGSEGV in g_mutex_lock()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/12/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P3.40
dmi.board.name: Z87 Extreme4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP3.40:bd04/12/2016:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ87Extreme4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Jaroslav Svoboda (multi-flexi) wrote :

StacktraceSource:
 #0 0x00007f4900fb5c65 in g_mutex_lock () from /tmp/apport_sandbox_2MqiJx/lib/x86_64-linux-gnu/libglib-2.0.so.0
 #1 0x00007f4900f6cf30 in g_source_destroy_internal () from /tmp/apport_sandbox_2MqiJx/lib/x86_64-linux-gnu/libglib-2.0.so.0
 #2 0x000055d37a2c5605 in main ()
StacktraceTop:
 g_mutex_lock () from /tmp/apport_sandbox_2MqiJx/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_source_destroy_internal () from /tmp/apport_sandbox_2MqiJx/lib/x86_64-linux-gnu/libglib-2.0.so.0
 main ()

Changed in udisks2 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in udisks2 (Ubuntu):
importance: Medium → High
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks2 (Ubuntu):
status: New → Confirmed
Joel Van Boxtel (jeol13) wrote :

this also affects 32bit systems

edgar (rafaelepuente) wrote :

no comment

veter (admi0n) wrote :

I also have this error

Niels Erik Jensen (nej-f) wrote :

?

Bernard Banko (beernarrd) wrote :

Don't know if this is related, but I had phone plugged in usb and than set it to charge only.

Alexander Browne (elcste) wrote :

I'm not sure if it's related, but I've also had issues with Disks (gnome-disks), specifically it stalls at 0.0% when I try the "Restore Disk Image" option. This worked fine before I upgraded to Artful.

Changed in udisks2 (Ubuntu):
status: Confirmed → Triaged
Changed in udisks:
status: Unknown → New
Changed in udisks2 (Ubuntu):
assignee: nobody → Felipe Pereira Costa (felipecosta99)
status: Triaged → Confirmed
Roman Brodylo (roman-brodylo) wrote :

Right after logging in. Notebook is upgraded from ubuntu-gnome 17.04 to ubuntu 17.10, Gnome X session. Nothing special - usb flash drive is attached, and a usb transmitter for a trackball.

Changed in udisks2 (Ubuntu):
status: Confirmed → Triaged
assignee: Felipe Pereira Costa (felipecosta99) → nobody
Nick Rapoport (nrapopor) wrote :

Same thing after 17.04 upgrade to 17.10: no usb flash (ssd drives in the system), but with Logitech usb transmitter and a 3dconnection SpacePilot Pro (no driver installed yet for SpacePilot) plugged in to USB

Changed in udisks2 (Ubuntu):
assignee: nobody → Amar Hasan Tawfiq (amarht)
Scott Seufert (scott-seufert) wrote :

On Xubuntu

Upgraded from 17.04 to 17.10 via do-release-upgrade

Have 8TB USB ext drive continuously attached. USB mouse/kb and USB2 microSD/SD/MMC card adapter were also plugged in during and post upgrade.

Error appears just after login.

Thanks.

David (roastedtoast) wrote :

Clean install of 17.10, no USB drive plugged in, error shows up after login.

Changed in udisks2 (Ubuntu):
assignee: Amar Hasan Tawfiq (amarht) → nobody
Changed in udisks2 (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Released
Changed in udisks2 (Ubuntu):
assignee: nobody → Philippe Frager (philippe05)
Changed in udisks2 (Ubuntu):
status: Fix Released → Triaged
assignee: Philippe Frager (philippe05) → nobody
Sudhir Reddy (t-sudhirkumar) wrote :

Is there fix for this bug? Please let me know how to proceed for the same. Thanks!

Sebastien Bacher (seb128) wrote :

Do you hit the bug often? Could you describe what steps you take to do so?

sirianni (eric-sirianni) wrote :

Same problem for me as reported above:
- Crash right after login
- No USB drives attached
- Logitech USB transmitter

When I turned on my notebook just now, it already had a wireless dell (for wireless keyboard) connector.

As soon as I turned on the computer, I ran Synaptic to make updates.

While synaptic was performing the updates that were found today, I ran Virtualbox. I had left a problem of sharing folders with a windows 10 virtual machine to solve today. I checked the virtual machine settings to see if the folder sharing was ok and I started the virtual machine ...

Then I plugged my cell phone into the second USB port to charge it.

I was unable to pinpoint the exact moment and cause of the crash but the context was this.

I should add that I still had to stick a pen drive (with encrypted file system) on the third and last USB port of my notebook, but I believe this was only after my Browser (google chrome) was popped up on the screen by Apport.

This bug popped up in Ubuntu 18.04 (fully updated). This is running in a virtualized ESXi 6.5 server under a Debian Sid host (kernel 4.14

vmc (vmclark) wrote :

I just got this bug today, Jan 25th, while just booting up:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu Bionic Beaver (development branch)"

ubuntu-mate

tags: added: bionic

Same issue on daily 19/02/2018 of Ubuntu 18.04 (fresh install)

dino99 (9d9) wrote :

As a github comment suggest a possible glibc relationship, a new version has been upgraded recently (2 days ago)
glib2.0 (2.55.2-1ubuntu1) bionic; urgency=medium

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib (Ubuntu):
status: New → Confirmed

Crash happened right after a reboot.
- Intel NUC
- No HDD
- Single SSD
- Logitech Unifying Receiver dongle was attached
- No other USB devices or dongles
- HDMI Out to a monitor

Forgot to mention installation details

- Xubuntu 17.10 x64 fresh install (no upgrade)

bionic it has happened more than once shows after a reboot. i'v uploaded libudisk2-dev so a trace might occur if this is the correct package. i do have a usb seagate drive, usb mouse dongle, plus several blue tooth devices. i'm on the last alpha bionic updated constantly

Willem Hobers (whobers) wrote :

After fresh boot. Testing xubuntu 18.04.
Linux Xubuntu-18-04 4.15.0-12-generic #13-Ubuntu SMP Thu Mar 8 06:24:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

tags: added: bugpattern-needed
Andrea Azzarone (azzar1) wrote :
Changed in udisks2 (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: Triaged → In Progress

Got this crash here after dist-upgrade today

Changed in udisks2 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 2.7.6-2ubuntu6

---------------
udisks2 (2.7.6-2ubuntu6) bionic; urgency=medium

  * debian/patches/remove_sigint_source.patch:
    - backport a segfault fix from an upstream PR, thanks andyrock!
      (lp: #1707451)

 -- Sebastien Bacher <email address hidden> Wed, 04 Apr 2018 09:39:45 +0200

Changed in udisks2 (Ubuntu):
status: Fix Committed → Fix Released
affects: glib (Ubuntu) → glib2.0 (Ubuntu)
Si Dedman (si-dedman) wrote :

Thanks for fixing this guys & apologies for being dumb, but how does one install the latest stable on a *buntu system?
1. Download & unpack udisks2_2.7.6.orig.tar.bz2
2. Readme says Udisks has several dependencies listed in `packaging/udisks2.spec`. If you run rpm based distro, install the dependencies by: # dnf builddep -y packaging/udisks2.spec,
But there doesn't appear to be that file in the folder and what if you're not running an rpm system?
3. To configure and install the Udisks, perform following tasks: ./autogen.sh
Doesn't work on *buntu. sh ./autogen.sh says can't open; there is no autogen.sh file.
4. make: there is no target.

Same problem using tarball from https://github.com/storaged-project/udisks/releases

Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.