DVDs with restricted permissions are unreadable for normal user (regression?)

Bug #1674164 reported by mikbini
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
Triaged
Low
Unassigned

Bug Description

I'm using 16.10. I have a DVD with strange permissions for the root folder:

michele@cassandra:~$ ls -l /media/michele
total 2
d--x--x--- 3 michele michele 88 gen 1 2004 SONY_DVD_RECORDER_VOLUME

The DVD is readable e.g. on windows but with ubuntu while I can access it as root:

root@cassandra:~# ls -l /media/michele/SONY_DVD_RECORDER_VOLUME/
total 4
dr-xr-xr-x 2 michele michele 3628 gen 1 2004 VIDEO_TS

I cannot as the non-root user that is logged in when I insert the disk:

michele@cassandra:~$ ls -l /media/michele/SONY_DVD_RECORDER_VOLUME
ls: cannot open directory '/media/michele/SONY_DVD_RECORDER_VOLUME': Permission denied

Looking at the mount options it seems to me that this is a regression for bug #10550. The options used by udisks2 are:

root@cassandra:~# mount |grep SONY
/dev/sr0 on /media/michele/SONY_DVD_RECORDER_VOLUME type udf (ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,uhelper=udisks2)

while my understanding from bug #10550 is that I should have also mode=0777 and dmode=0777

And indeed this works:

root@cassandra:~# mount -t udf -o ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,uhelper=udisks2,mode=0777,dmode=0777 /dev/sr0 ~michele/z

michele@cassandra:~$ ls -l ~michele/z
total 4
drwxrwxrwx 2 michele michele 3628 gen 1 2004 VIDEO_TS

Revision history for this message
Phillip Susi (psusi) wrote :

This is correct; if the disc specifies permissions, they are used. You appear to have a brain dead recorder that specifies the wrong permissions. As you noted, you will need to override the permissions to work around this, but it is not intended that permissions never be used by default.

Changed in util-linux (Ubuntu):
status: New → Invalid
Revision history for this message
mikbini (mikbini) wrote :

In my view this is not invalid: "differently correct" recorders and also printed DVDs are common in the wild and they work on Windows, osX and "dumb" readers. And as the average user is not able to figure out a workaround, he will assume that ubuntu is broken and switch to something else.

The same argument ("we are applying the permissions") was made in 2009 for bug #10550 and ubuntu decision back then was to change the mount options (possibly only to CDs/DVDs/Blueray, this is not clear from the bug).

And let me stress again that this is indeed a regression: people used to be able to play their braindead DVDs and now they cannot.

Revision history for this message
Phillip Susi (psusi) wrote :

"differently correct" is no less a lie than "alternative facts". Your recorder is broken, period. Complain to the manufacturer to fix their firmware or see if they already have an update. Printed DVDs use the correct permissions. UDF also goes on rewritable media, optical or flash or otherwise, and the correct permissions need to be retained or you end up with either files that are never executable or always executable, and no ability to write protect files.

That said, it might be a reasonable workaround to detect the somewhat silly situation of the root directory not being readable by anyone and then override the permissions, only under that condition. Or perhaps there is a unique device string in the UDF header that identifies this particular broken burner that can key on it. What does blkid -p /dev/sr0 have to say about this disc?

affects: util-linux (Ubuntu) → udisks2 (Ubuntu)
Changed in udisks2 (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Revision history for this message
mikbini (mikbini) wrote :

"differently correct" was meant to be a joke :)

Unfortunately, I don't have the DVDs at hand: my mother in law dug out those old family video DVDs, brought them with her when he came to visit us.

I'll try and recover them from her but it will take 2 or 3 months.

Apologies for all the details above but I think they make an important part of the use-case: "I need to play some crappy DVDs and I have no control to how they were created years ago".

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers