SD card not recognized on M10 with ubuntu-touch/staging/ubuntu

Bug #1649313 reported by Victor gonzalez on 2016-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
mediascanner2 (Ubuntu)
Undecided
Unassigned
udisks2 (Ubuntu)
Undecided
Unassigned

Bug Description

Story: looks like this is a well known bug but there wasn't a bug report yet so I'm opening it. Sdcards detection doesn't work in frieza_arm64.

Environment:

current build number: 99
device name: frieza_arm64
channel: ubuntu-touch/staging/ubuntu
last update: 2016-12-12 12:21:18
version version: 99
version ubuntu: 20161210
version device: 20161014.0
version custom: 20161210

Steps:

1º Put some media files(songs,videos) on a sdcard
2º Install the sdcard in frieza
3º Open music app or music/video scopes

Current result: music app reports no songs were found and music/video scopes don't show the media files either

Expected result: all files from sdcard or other external devices should be detected

summary: - mediascanner not working
+ Mediascanner is not working
affects: mediascanner (Ubuntu) → mediascanner2 (Ubuntu)

I don't have access to this device, so it is a bit difficult to tell what is going on. The following would be helpful in debugging the problem:

1. could you attach the log file (~/.cache/upstart/mediascanner-2.0.log).

2. If you run "restart mediascanner-2.0" from the terminal or an "adb shell" session, does anything show up? If so, it might be an issue of detecting when new volumes are mounted at runtime, as opposed to volumes already mounted when the service starts.

Hi @jamesh

1. Here is the content of mediascanner log after installing my sdcard: https://pastebin.canonical.com/173543/

2. From adb shell I get mediascanner-2.0 start/running, process 8728

James Henstridge (jamesh) wrote :

Okay, so according to the log the only mounted volumes are "/", "/android/protect_f", "/android/data" and "/android/cache". It hasn't detected any mounts like "/media/phablet/something", which is where the SD card should be mounted.

The fact that it listed some volumes indicates that it is successfully talking to the udisks2 daemon. So either (a) udisks2 has missed the SD card volume, or (b) it is being presented in a way that mediascanner2 ignores.

To help debug this, could you provide the output of "udisksctl dump" from the device with the SD card inserted? That should help identify which is the case.

Michi Henning (michihenning) wrote :

I tried it with build 191 from ubuntu-touch/rc-proposed/bq-aquaris-pd.en.
After inserting an SD card with a few music and image files, the music scope shows the tracks, and gallery app shows all the images on the card.

I'm about to try with OTA 14. But I expect to see the same results.

Can you install the file manager app from the store and check if you can see the card contents with that? If not, mediascanner is innocent; it can't see the card if it isn't mounted.

Thanks @jamesh! Please find below the output of udisksctl dump with the card installed:

https://pastebin.canonical.com/173676/

Michi Henning (michihenning) wrote :

It could be just that the card slot is dirty or some such. I would also try a reboot. Possibly, some other low-level piece of machinery got stuck. At any rate, I don't think this is a mediascanner problem. If the card isn't mounted, mediascanner can't possibly see it.

@michihenning, yes indeed, it should work fine in all Vivid images, this bug only targets xenial for M10 though. If you want to reproduce it you can flash frieza using the channel in the bug description.

This image comes with file manager and external devices pre-installed, however they're currently broken. I filed it against mediascanner because I though it could be related.

description: updated
description: updated
Michi Henning (michihenning) wrote :

I just tried with OTA-14, and it works fine there too. However, the first time I inserted the card, it wasn't recognized. It was only after I ejected and re-inserted it that it was mounted.

This may just be dodgy connectors in the card slot.

I'll also try with image you linked to.

James Henstridge (jamesh) wrote :

Victor: Looking over the output, I can't see any entry that would correspond to the SD card (all the mmcblk0p* entries are the internal flash.

Is the SD card actually mounted and visible under /media/phablet?

Michi Henning (michihenning) wrote :

I downloaded the latest image from ubuntu-touch/staging/ubuntu

"OS Build Details" in system settings reports r85, 20161215

Unfortunately, I can't provide the output from system-image-cli because, since flashing this image, USB is broken. I can no longer get my desktop to recognize the USB port. It's as if the USB port is dead (lsusb doesn't find the device). Developer mode is on, and when I plug my Aquaris E5 into the same port using the same cable, it's recognized just fine.

Anyway, after installing this image, the SD card is no longer recognized at all, no matter how many times I insert it. (The same card works fine in the E5.)

I guess the problem is with the image from ubuntu-touch/staging/ubuntu

summary: - Mediascanner is not working
+ frieza_arm64, staging #99: SD card not mounted
summary: - frieza_arm64, staging #99: SD card not mounted
+ SD card not recognized on M10 with ubuntu-touch/staging/ubuntu
Changed in mediascanner2 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers