udisksctl crashed with SIGSEGV in g_option_context_get_help()

Bug #1478369 reported by Martin Pitt on 2015-07-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
High
Martin Pitt

Bug Description

Just "udisksctl help" triggers this in current wily. This sounds like a glib regression or some other ABI change, as this command still worked on the last udisks upload.

ProblemType: Crash
DistroRelease: Ubuntu 15.10
Package: udisks2 2.1.6-1
ProcVersionSignature: Ubuntu 4.1.0-2.2-generic 4.1.3
Uname: Linux 4.1.0-2-generic x86_64
ApportVersion: 2.18-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jul 26 19:08:41 2015
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/udisksctl
MachineType: LENOVO 2324CTO
ProcCmdline: udisksctl help
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-4.1.0-2-generic.efi.signed root=UUID=f86539b0-3a1b-4372-83b0-acdd029ade68 ro rootflags=subvol=@ quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f0b74594606 <g_option_context_get_help+214>: mov 0x50(%rax),%esi
 PC (0x7f0b74594606) ok
 source "0x50(%rax)" (0x00000050) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: udisks2
StacktraceTop:
 g_option_context_get_help (context=0xd36590, main_help=0, group=0x0) at /build/glib2.0-oVi7VK/glib2.0-2.45.3/./glib/goption.c:858
 ()
 ()
 __libc_start_main (main=0x403780, argc=2, argv=0x7ffd5db98bf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd5db98be8) at libc-start.c:289
 ()
Title: udisksctl crashed with SIGSEGV in g_option_context_get_help()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sbuild sudo
dmi.bios.date: 07/09/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: G2ET95WW (2.55 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2324CTO
dmi.board.vendor: LENOVO
dmi.board.version: 0B98401 Pro
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG2ET95WW(2.55):bd07/09/2013:svnLENOVO:pn2324CTO:pvrThinkPadX230:rvnLENOVO:rn2324CTO:rvr0B98401Pro:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2324CTO
dmi.product.version: ThinkPad X230
dmi.sys.vendor: LENOVO

Martin Pitt (pitti) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks2 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2015-07-26
Changed in udisks2 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
milestone: none → ubuntu-15.07
assignee: nobody → Martin Pitt (pitti)

StacktraceTop:
 g_option_context_get_help (context=context@entry=0xd36590, main_help=main_help@entry=0, group=group@entry=0x0) at /build/glib2.0-oVi7VK/glib2.0-2.45.3/./glib/goption.c:858
 usage (argc=<optimized out>, argv=<optimized out>, use_stdout=1) at udisksctl.c:3101
 main (argc=2, argv=0x7ffd5db98bf8) at udisksctl.c:3244

tags: removed: need-amd64-retrace
Dave Gilbert (ubuntu-treblig) wrote :

Hi Martin,
  Yes, there was something screwy about apport as well; it did bring up a dialog saying that something had gone wrong and I told it to report it, but didn't manage to make it through to launchpad (it brought up a web page saying I was already logged in and I couldn't get it further).

Martin Pitt (pitti) on 2015-07-28
Changed in udisks2 (Ubuntu):
status: Triaged → Won't Fix
status: Won't Fix → In Progress
Martin Pitt (pitti) wrote :

This works fine under vivid with glib 2.44.1. Merely upgrading to wily's glib2.0 on vivid introduces this crash.

Martin Pitt (pitti) wrote :
Changed in udisks2 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 2.1.6-2

---------------
udisks2 (2.1.6-2) unstable; urgency=medium

  * Fix udisksctl help crash with glib 2.45. (LP: #1478369)

 -- Martin Pitt <email address hidden> Tue, 28 Jul 2015 07:48:20 +0200

Changed in udisks2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers