[SRU] Removable media is being mounted randomly in multiseat systems

Bug #1319870 reported by Laércio de Sousa on 2014-05-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
High
Unassigned
Trusty
Low
Unassigned

Bug Description

[Impact]

Due to lack of full systemd-logind integration in current "udisks2" package, automounting of removable media in multiseat setups is not respecting seat hierarchy. All seats try to mount it at the same time, resulting in a race condition. However, the expected behaviour is that only the right seat (i.e. the seat whose USB port the removable media is plugged in) should be able to mount it.

To solve this problem, just rebuild package "udisks2" with additional build-dependencies "libsystemd-login-dev" and "libsystemd-daemon-dev".

[Test case]

* Set up a multiseat system and try to mount a removable medium in one seat
  or another. Repeat this procedure several times.
* Before rebuilding udisks2 with full logind support, all seats will try to
  mount this medium at the same time, so it will be shown in one seat or
  another, randomly.
* After rebuilding udisks2 with full logind support, only one seat will
  succeed to mount the medium in all times it's plugged in.

[Regression Potential]

Medium. This rebuilt package was well tested in ppa:ubuntu-multiseat/ppa.
It may happen that only one seat will be able to mount removable media, regardless which seat owns the USB port the medium is plugged (due to lack of systemd as PID 1), but at least there will be no race condition between seats. But verification should include thorough testing that removable media is still mounted correctly on non-multiseat systems, with multiple user sessions.

Related branches

summary: - Rebuild udisks2 with additional build-dependencies "libsystemd-login-
- dev" and "libsystemd-daemon-dev"
+ Removable media is being mounted randomly in multiseat systems
tags: added: multiseat

FTR, I've just enabled logind support in the debian package

Martin Pitt (pitti) wrote :

This is fixed in utopic, udisks2 uses logind now.

Changed in udisks2 (Ubuntu):
status: New → Fix Released
summary: - Removable media is being mounted randomly in multiseat systems
+ [SRU] Removable media is being mounted randomly in multiseat systems
description: updated
Laércio de Sousa (lbssousa) wrote :

Any progress about this SRU request?

Sebastien Bacher (seb128) wrote :

not sure that's still worth SRUing in trusty since that's neither a LTS nor the current stable

Changed in udisks2 (Ubuntu):
importance: Undecided → High
Changed in udisks2 (Ubuntu Trusty):
importance: Undecided → Low
Phillip Susi (psusi) wrote :

I think you need to drink your morning coffee there Sebastien... Trusty = 14.04 LTS.

Laércio de Sousa (lbssousa) wrote :

Any progress about this bug? It's the last package which still needs to be forked in Ubuntu Multiseat PPA for a more complete multiseat experience in Ubuntu 14.04 LTS.

Martin Pitt (pitti) on 2015-06-12
description: updated
Martin Pitt (pitti) wrote :

I uploaded this trusty SRU. The regression potential is nontrivial, so this needs thorough testing.

Changed in udisks2 (Ubuntu Trusty):
status: New → In Progress

Hello Laércio, or anyone else affected,

Accepted udisks2 into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/udisks2/2.1.3-1ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in udisks2 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

The udisks2 2.1.3-1ubuntu0.2 is failing its autopkgtests, as can be seen here: https://jenkins.qa.ubuntu.com/job/trusty-adt-udisks2/

I am marking this SRU verification-failed and removing the package in question from trusty-proposed, so that we can get valid test results for other dependencies of udisks2 that are currently in the SRU queue.

tags: added: verification-failed
removed: verification-needed
Changed in udisks2 (Ubuntu Trusty):
status: Fix Committed → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers