shoulds Recommends gdisk since it uses sgdisk commands

Bug #1080745 reported by Curtis Lee Bolin on 2012-11-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
Low
Martin Pitt

Bug Description

The package gnome-disk-utility depends on the package gdisk for many of its gpt functions, but gdisk isn't listed as a dependency.

Error message:
Error setting partition flags on /dev/sdb1: Error spawning command-line `sgdisk --typecode 1:"c12a7328-f81f-11d2-ba4b-00a0c93ec93b" "/dev/sdb"': Failed to execute child process "sgdisk" (No such file or directory) (g-exec-error-quark, 8) (udisks-error-quark, 0)

sgdisk is in the gdisk package.

Thank You For Your Time

tags: added: gnome-disk-utility
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, it seems like those calls are coming from udisks2, it should probably Recommends/Depends on it

affects: gnome-disk-utility (Ubuntu) → udisks2 (Ubuntu)
Changed in udisks2 (Ubuntu):
importance: Undecided → Low
summary: - gnome-disk-utility: gdisk dependency problem
+ shoulds Recommends gdisk since it uses sgdisk commands
Changed in udisks2 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Fixed in Debian packaging git.

Changed in udisks2 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 2.1.2-1

---------------
udisks2 (2.1.2-1) unstable; urgency=low

  [ Martin Pitt ]
  * New upstream release:
    - Add exfat support (Closes: #720695)
    - Fix crash when waiting for loop device (LP: #1128275)
    - Use dosfstools instead of mtools
    - Add polkit authorization variables for removable media
    - Hide more rescue partitions
  * Drop dosfslabel.patch, fixed upstream.
  * Add Recommends: gdisk, as we need it for manipulating GPT partition tables
    through sgdisk. (LP: #1080745)
  * Bump Standards-Version to 3.9.5. No changes necessary.

  [ Colin Watson ]
  * Use dh-autoreconf to update libtool macros for new ports.
    (Closes: #732287)

  [ Andreas Henriksson ]
  * Add parted dependency. (Closes: #720491)

 -- Martin Pitt <email address hidden> Tue, 14 Jan 2014 10:04:52 +0100

Changed in udisks2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers