Ubuntu

Tries to automount floppy drives

Reported by SlugiusRex on 2012-09-22
156
This bug affects 31 people
Affects Status Importance Assigned to Milestone
udisks2 (Arch Linux)
New
Undecided
Unassigned
udisks2 (Ubuntu)
Low
Martin Pitt

Bug Description

Quantal system attempts to display non-existent Floppy Drive. See attached screenshot (https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1054414/+attachment/3330112/+files/Screenshot%20from%202012-09-21%2018%3A52%3A01.png)

1) The Home folder displays a floppy drive and none exists. Clicking on the image results in a message box"
       "Error mounting system-managed device /dev/fd0: Command-line `mount "/media/floppy0"' exited with
       non-zero exit status 32: mount: /dev/fd0 is not a valid block device"

2) The Unity Launcher displays a floppy drive. Clicking on image causes nothing to happen. Image canot be closed or unlocked from launcher.

BTW - Running on VMWare with Open-VM-Tools

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gvfs-backends 1.13.9-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Fri Sep 21 18:43:01 2012
ExecutablePath: /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120615)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: gvfs
UpgradeStatus: No upgrade log present (probably fresh install)

SlugiusRex (slugiusrex) wrote :
SlugiusRex (slugiusrex) on 2012-09-22
description: updated
Jeremy Bicha (jbicha) wrote :

I'm pretty sure this is because you have your virtual machine configured to have a virtual floppy drive but without a virtual floppy image in the drive.

Closing since I don't believe this is a Ubuntu bug.

Changed in gvfs (Ubuntu):
status: New → Invalid
SlugiusRex (slugiusrex) wrote :

Should I will reclassify this as affecting OpenVMTools instead ??

SlugiusRex (slugiusrex) wrote :

Actually, the machine was not configured to have a virtually floppy drive - (see attached screenshot 'No Virtual Drive').

The VM was configured to have a CD and USB - but, as we see in the lower right corner - neither of them was connected.

Im thinking of removing open-vm-tools and using actual vmware VM-tools to see what happens.

SlugiusRex (slugiusrex) wrote :

Sorry no image uploaded -

I'm experiencing the same problem on a quantal installation on a physical system without floppy drive (it has never had one). Since some recent update, I think, because the launcher icon was there only after me booting my machine this morning. (European time).

Ian (ian-gitlin) wrote :

Just to confirm, I also have a floppy icon in the launcher and in nautilus on a physical machine after upgrade from 12.04 to 12.10. There never has been a floppy on this machine.

SlugiusRex (slugiusrex) wrote :

For me the floppy appeared after the upgrade to Quantal Beta1 - There was no floppy visible before.

On VMware - was observed with both Open-VM-Tools & VMWare's vmtools (VMwareTools-8.8.4-743747)

SlugiusRex (slugiusrex) wrote :

I think I should set this back to "Confirmed" now that multiple people have reported the on "physical system without floppy drives" instead of just VMs.

Changed in gvfs (Ubuntu):
status: Invalid → Confirmed
SlugiusRex (slugiusrex) wrote :

The 'unlocked from launcher' issue now seems to have been fixed. The launched Icon can be removed - and it stays removed even after reboot.

However, the phantom floppy drive sill appears in the devices list even though no floppy drive exists whenever you click on the HOME directory icon.

Since it is now possible to remove the icon from the launcher - I think this is a low priority . Somebody should feel free to classify it as such.

Allo (allo) wrote :

having this problem too, but the kernel log even says something about i/o errors on the floppy drive.
The machine actually HAS a floppy drive, but its empty and not used for a looong time. Ubuntu should not try to mount it, until it's told so.

Allo (allo) wrote :

and the physical floppy drive does NOT make any sound, so i do not think it actually tries to read a floppy.

Alexander Ivanov (dr.stein) wrote :

I got same problem yesterday. Additionaly compiz gets 100% CPU and desktop freezes. Logging in to gnome removes freeze but log records still coming:
...
[ 2135.100500] end_request: I/O error, dev fd0, sector 0
[ 2135.100508] Buffer I/O error on device fd0, logical block 0
[ 2147.268505] end_request: I/O error, dev fd0, sector 0
[ 2147.268512] Buffer I/O error on device fd0, logical block 0
...

Sergi (snavas) wrote :

I got the same problem after update to Quantal from 12.04

---
[ 871.923526] end_request: I/O error, dev fd0, sector 0
[ 871.923534] Buffer I/O error on device fd0, logical block 0
[ 894.603576] end_request: I/O error, dev fd0, sector 0
[ 894.603583] Buffer I/O error on device fd0, logical block 0
---

And the i/o waiting time of the machine is always 30-40% and the machine load is 2-3 !!!

Pankaj (pkscwc) wrote :

I got the same problem after fresh install of quantal.

affects: gvfs (Ubuntu) → udisks2 (Ubuntu)
Changed in udisks2 (Ubuntu):
importance: Undecided → Low
Martin Pitt (pitti) wrote :

Did you configure your VM to expose a floppy? Can you please do

  dmesg > /tmp/dmesg.txt
  udevadm info --export-db > /tmp/udev.txt

and attach /tmp/dmesg.txt and /tmp/udev.txt here?

affects: udisks2 (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
affects: linux (Ubuntu) → udisks2 (Ubuntu)
SlugiusRex (slugiusrex) wrote :

Per comment #4 (https://bugs.launchpad.net/ubuntu/+source/udisks2/+bug/1054414/comments/4)

      Actually, the machine was not configured to have a virtually floppy drive - (see attached screenshot 'No Virtual Drive').

      The VM was configured to have a CD and USB - but, as we see in the lower right corner - neither of them was connected.

       Im thinking of removing open-vm-tools and using actual vmware VM-tools to see what happens.

So - you want me to add a floppy drive to my VM - and then what ??

Martin Pitt (pitti) wrote :

> So - you want me to add a floppy drive to my VM - and then what ??

No, no need to. I just need the command outputs from comment 16.

Vince (thehappytrucker) wrote :

 I also have a floppy icon in the launcher on a physical machine after a fresh install from 12.04 to 12.10. There never has been a floppy on this machine. I am not very experienced in retrieving information from the system.If more info is required?Please email me through Launchpad with instruction and I will be happy to provide what is needed,
Thanks.

SlugiusRex (slugiusrex) wrote :

Ok - had some coffee - now I think I know what you need.
I ran
    dmesg > /tmp/dmesg.txt
    udevadm info --export-db > /tmp/udev.txt

then I added a blank virtual floppy drive image and ran them both again. Is that waht you wanted?

Se

SlugiusRex (slugiusrex) wrote :
SlugiusRex (slugiusrex) wrote :
SlugiusRex (slugiusrex) wrote :
SlugiusRex (slugiusrex) wrote :
Martin Pitt (pitti) wrote :

But even in the log without a floppy drive, the kernel detects one:

[ 2.266143] Floppy drive(s): fd0 is 1.44M

There are some differences between the "dmesg without" (-) and "dmesg with" (+) logs:

-end_request: I/O error, dev fd0, sector 0
+EXT3-fs (fd0): error: can't find ext3 filesystem on dev fd0.
+EXT4-fs (fd0): VFS: Can't find ext4 filesystem
+FAT-fs (fd0): bogus number of reserved sectors
+FAT-fs (fd0): Can't find a valid FAT filesystem

Which mostly confirm that the floppy isn't working properly in the first case.

udev sees *exactly* the same devices in both cases:

$ diff -u <(grep -v USEC_INITIALIZED export_without.txt) <(grep -v USEC_INITIALIZED export_with.txt)

is empty.

P: /devices/platform/floppy.0/block/fd0
N: fd0
E: DEVNAME=/dev/fd0
E: DEVPATH=/devices/platform/floppy.0/block/fd0
E: DEVTYPE=disk
E: ID_DRIVE_FLOPPY=1
E: MAJOR=2
E: MINOR=0
E: SUBSYSTEM=block
E: UDEV_LOG=3
E: UDISKS_PRESENTATION_NOPOLICY=1
E: USEC_INITIALIZED=27196738

So this seems to be mostly a VMWare bug that even if you configure without a floppy drive, it still emulates a floppy controller without any drive attached. Unfortunately there is very little that we can do in userspace to work around this; floppies come from an age where detailled automatic hardware detection was still not existant :( As soon as you try to probe a floppy in this case, you will get 30 second uninterruptible kernel hangs, so we must not try to touch floppies unless the user explicitly tries to mount one.

summary: - Quantal Attempts To Mount Non-Existent Floppy Drive
+ VMWare exports a floppy controller, resulting in a phantom floppy drive.
Changed in udisks2 (Ubuntu):
status: Incomplete → Invalid

I opened a discussion thread on the VMWare site (http://communities.vmware.com/thread/426323) so that the developers on that end can look at the issue.

I don't believe this is a VMWare related bug. I have the same issue on a physical machine.
I have floppy disk support enabled in the BIOS setup, but don't have a floppy drive installed. The reason for this is that disabling the floppy support makes grub take longer to start.
The bug goes away if I disable the floppy in the BIOS configuration.
I never had any problem with this configuration until I upgraded to 12.10.

SlugiusRex (slugiusrex) wrote :

OK - I agree
1) For me the floppy appeared after the upgrade to Quantal Beta1 - There was no floppy visible before even
     on VMWare - but I was willing to accept that believe that it might have been an issue with an update to either
     Open-VM-Tools or VMWare's vmtools (VMwareTools-8.8.4-743747)
2) The 'unlocked from launcher' issue now seems to have been fixed after some updates to Ubuntu not VMWare. At
       first, the launcher Icon couldn't be removed, then in later Ubuntu builds it could be removed and stayed removed
      even after reboot.

@RafaelKellerTesser I suggest you change the status back to 'Confirmed' -

SlugiusRex (slugiusrex) wrote :

More @RafaelKellerTesser

What if you also ran
    dmesg > ~/Desktop/dmesg_physical.txt
    udevadm info --export-db > ~/Desktop/udev_physical.txt

and then uploaded those file from your desktop as attachments.
- thx

SlugiusRex (slugiusrex) wrote :

OK - so Based on Rafael Keller Tesser's excellent comments (along with some hints from VMWare folks ) - I went into the VM machine's BIOS and [Disabled] the reference to the FLOPPY. Then re-ran

    dmesg > ~/Desktop/dmesg_removed_from_BIOS.txt
    udevadm info --export-db > ~/Desktop/udev_removed_from_BIOS.txt

The results are attached...

SlugiusRex (slugiusrex) wrote :
SlugiusRex (slugiusrex) wrote :
Changed in udisks2 (Ubuntu):
status: Invalid → Confirmed

Since this is appearing on purely physical machines (not just VMWare) - it seems to be an issue with the way Ubuntu deals with what appears in the BIOS.

I went into the VM machine's BIOS and [Disabled] the reference to the [Disabled] the Floppy A. Now a Floppy no longer appears in the list of Linux Devices.

Could it appear that somewhere during the upgrade from 12.04 to 12.10 the code was modified to enhance performance of the boot up process. Maybe somewhere in there Ubuntu now accepts that there is actually a floppy hardware device there just cause BIOS says so - without actually testing to see if there is one ?

That's my best guess, anyway -

SLUG

summary: - VMWare exports a floppy controller, resulting in a phantom floppy drive.
+ Quantal Attempts To Mount Non-Existent Floppy Drive (if BIOS indicates
+ there might be one)

Rafael Keller Tesser [2012-11-20 20:33 -0000]:
> I don't believe this is a VMWare related bug. I have the same issue on a physical machine.
> I have floppy disk support enabled in the BIOS setup, but don't have a floppy drive installed.

Right, that unfortunately happens rather often, and is the reason why
we can never probe floppies automatically. (And lead to basically
unfixable bugs like bug 441835)

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

SlugiusRex [2012-11-21 0:09 -0000]:
> Could it appear that somewhere during the upgrade from 12.04 to 12.10
> the code was modified to enhance performance of the boot up process.

Not quite, but we switched from udisks to udisks2 which cleaned up the
device detection logic. udisks 1.x broke floppies entirely (bug
441835
), and udisks2 fixes that.

I'm afraid we can't simultaneously break floppies (as requested in
this bug) and make floppies work (as very vocally requested in bug
441835
). By and large I think it's correct as it is now -- after all,
when the BIOS tells us that there is a floppy controller, the kernel
detects it, and the desktop will show it.

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Good morning.I read in a earlier post that someone disabled the floppy in their BIOS and Quantal stopped trying to mount the floppy.I just did this and Quantal stopped trying to mount the floppy.

Martin Pitt (pitti) wrote :

This is the direct consequence for fixing floppies in the first place (bug 441835). We have absolutely no way of poking the floppy controller whether there is actually a floppy behind it, as this causes hard freezes of about 20 seconds if there is none. Thus, we can either skip floppies entirely (but see the very vocal arguments on bug 441835), or show floppies if the BIOS tells us there is one.

Between a rock and a hard place, and I think the current behaviour is better.

Changed in udisks2 (Ubuntu):
status: Confirmed → Won't Fix
summary: - Quantal Attempts To Mount Non-Existent Floppy Drive (if BIOS indicates
- there might be one)
+ Quantal shows non-existent Floppy Drive (if BIOS indicates there might
+ be one)

This has been an informative discussion that has helped me fix the problem on my system.

Surley this is issue is "Not a bug".

If a note to check the BIOS could be added to the error message, that would go a long way to neutralising the problem. After all, we can see that it has flummoxed a lot of quite experienced people.

Eugene Crosser (crosser) wrote :

I have real physical floppy on a real machine. Since upgrade to quantal, every time I log in, the floppy produces unpleasant noise and the login process is delayed by several seconds. I believe that this is an unwanted ("wrong") behaviour. I think that the previous strategy of never trying to mount floppies automatically (and only doing it when the user clicked on the floppy icon) was more appropriate. Can it be reverted?

Martin Pitt (pitti) wrote :

> I have real physical floppy on a real machine. Since upgrade to quantal, every time I log in, the floppy produces unpleasant noise and the login process is delayed by several seconds.

This could be due to the attempt to automount a floppy. This isn't what the original bug description says, but that was fixed upstream yesterday: http://cgit.freedesktop.org/udisks/commit/?id=32b6f233e0aba71

I'll reopen the bug and retitle it for this issue.

summary: - Quantal shows non-existent Floppy Drive (if BIOS indicates there might
- be one)
+ Quantal tries to automount floppy drives
Changed in udisks2 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Won't Fix → In Progress
summary: - Quantal tries to automount floppy drives
+ Tries to automount floppy drives

The following code fro within the Ubuntu 12.10 VM (or Linux Mint 14 for that matter) is:

echo "blacklist floppy" | sudo tee /etc/modprobe.d/blacklist-floppy.conf
sudo rmmod floppy
sudo update-initramfs -u

This immediately (don't need a reboot)removes the bogus floppy icon from the launcher and also /dev/fd0. You may also sudo rm -fr /media/floppy* if you wish.

See discussion

http://communities.vmware.com/thread/426323?tstart=0

Thanks! But.I disabled the floppy in my BIOS and the system no longer tries to mount the non-existent floppy. However,I can see a definite advantage for those who's BIOS do not provide such an option.

________________________________
 From: martyfelker <email address hidden>
To: <email address hidden>
Sent: Saturday, November 24, 2012 2:59 PM
Subject: [Bug 1054414] Re: Tries to automount floppy drives

The following code fro within the Ubuntu 12.10 VM (or Linux Mint 14 for
that matter) is:

echo "blacklist floppy" | sudo tee /etc/modprobe.d/blacklist-floppy.conf
sudo rmmod floppy
sudo update-initramfs -u

This immediately (don't need a reboot)removes the bogus floppy icon from
the launcher and also /dev/fd0.  You may also sudo rm -fr /media/floppy*
if you wish.

See discussion

http://communities.vmware.com/thread/426323?tstart=0

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1054414

Title:
  Tries to automount floppy drives

Status in “udisks2” package in Ubuntu:
  In Progress

Bug description:
  Quantal system attempts to display non-existent Floppy Drive.  See
  attached screenshot
  (https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1054414/+attachment/3330112/+files/Screenshot%20from%202012-09-21%2018%3A52%3A01.png)

  1) The Home folder displays a floppy drive and none exists.  Clicking on the image results in a message box"
         "Error mounting system-managed device /dev/fd0: Command-line `mount "/media/floppy0"' exited with
         non-zero exit status 32: mount: /dev/fd0 is not a valid block device"

  2) The Unity Launcher displays a floppy drive.  Clicking on image
  causes nothing to happen.  Image canot be closed or unlocked from
  launcher.

  BTW - Running on VMWare with Open-VM-Tools

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: gvfs-backends 1.13.9-0ubuntu1
  ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
  Uname: Linux 3.5.0-15-generic x86_64
  ApportVersion: 2.5.2-0ubuntu4
  Architecture: amd64
  Date: Fri Sep 21 18:43:01 2012
  ExecutablePath: /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120615)
  ProcEnviron:
   SHELL=/bin/bash
   PATH=(custom, no user)
   LANG=en_US.UTF-8
  SourcePackage: gvfs
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/udisks2/+bug/1054414/+subscriptions

I also have been getting this message, and I **DO** have a working, physical floppy in the system. I would like the opportunity to use it on occasion if I happen to need it; presuming I need to leave it disabled 99% of teh time, what would be the procedure for temporarily re-enabling it when I need to use it?

Martin Pitt (pitti) wrote :
Changed in udisks2 (Ubuntu):
status: In Progress → Fix Released
Narcis Garcia (narcisgarcia) wrote :

Today I have made a fresh installation of Ubuntu GNU/Linux 12.10 (Quantal) in a physical computer with an 1.44 floppy drive. All the packages are nou updated. I've changed to Mate desktop, but the problem persists: error message on desktop session opening.

I prefer to no blacklist floppy, because sometime I would use it.

Adam Funk (a-funk) wrote :

I get this error in a box that pops up whenever I log in (GNOME Classic) since I upgraded to Quantal. My (non-virtual) machine does have a floppy drive, which I occasionally use.

bert07 (marien.bert) wrote :

@ Adam Funk

That is caused by the new udisks used in Quantal, and has nothing to do whether you have a floppy or not.
It is told here that it will be fixed in the next Ubuntu 13.04 release.
All Ubuntu Quantal derivatives or distro's using the same udisks have the same problem.
We just have to be patient for some more months.
Till than: try to blacklist your floppy; perhaps that stops it.
Otherwise: downgrade to Precise until the 13.04 arrives.

chris (ign-christian) wrote :

I'm sorry if my comment not directly related to this bug. But I'm experiencing this bug within Kubuntu 12.04 with KDE 4.11.1 (from Kubuntu backports PPA).

Device notifier always shown floppy disk which is not exist. I can't do workaround by disabling floppy in bios since bios doesn't provide option to disable floppy.

To post a comment you must log in.