udisks2-inhibit crashes if udisks2 is not running

Bug #1048211 reported by Fabio Marconi
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
Fix Released
Critical
Martin Pitt

Bug Description

Hallo
Ubuntu amd64 Desktop 20120908
Start the iso and before ubiquity-dm appear it crash.
Thanks
Fabio

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.11.31
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
CasperVersion: 1.322
Date: Sun Sep 9 12:30:42 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120908)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :
description: updated
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1048211

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

Martin: Could you please s/mkdir/mkdir -p/ in udisks2-inhibit? That will fix this bug. (Note that udisks2 isn't running in an only-ubiquity session, and we have no reason to want to run it.)

affects: ubiquity (Ubuntu) → udisks2 (Ubuntu)
Changed in udisks2 (Ubuntu):
status: Confirmed → New
status: New → Triaged
importance: Undecided → Critical
summary: - ubiquity-dm crash
+ udisks2-inhibit crashes if udisks2 is not running
Martin Pitt (pitti)
Changed in udisks2 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 1.99.0-4git1

---------------
udisks2 (1.99.0-4git1) quantal; urgency=low

  Upload current Debian git head, this bug breaks installation images.

  * debian/local/udisks2-inhibit: Fix crash when /run/udisks2 does not exist
    yet. (LP: #1048211)
 -- Martin Pitt <email address hidden> Mon, 10 Sep 2012 11:25:31 +0200

Changed in udisks2 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Robin Catling (robinc) wrote :

Getting this also in Quantal daily updated at midday BST today;

Message as per #1048211; "Installation failed. The installer encountered an unrecoverable error. A desktop session will now be run so that you may investgiate the problem or try installing again."

Desktop installer works perfectly, however. RC

Revision history for this message
Victor Zhou (victor.zhou) wrote :

verified ok in the latest build.

tags: added: verification-done
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers