Ubuntu

"umount" for udisks2 mounted devices does not work

Reported by Steve Langasek on 2012-06-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
udisks2 (Ubuntu)
Medium
Martin Pitt

Bug Description

With udisks in quantal, when inserting a USB disk I see the following mount:

/dev/sdb1 on /run/media/vorlon/BB3E-80C3 type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,uhelper=udisks2)

Quite aside from the questionability of these mounts being under /run/media when that's precisely what /media exists for per the FHS, the disk is mounted without the 'user=vorlon' option. As a result, I can't run 'umount /run/media/vorlon/<tab>' as a non-root user. It seems that the only way to unmount it as a user is to use the special 'udisksctl unmount' helper.

Dropping compatibility with the historical commandline interfaces is unwarranted. Please fix the missing mount option so that 'umount' still works.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: udisks 1.0.4-6
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic x86_64
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
CheckboxSubmission: 017452a27eca3c8b498abbfa5ef91db9
CheckboxSystem: ecaaad6fa1e0799a0aa1126bf620f39e
CustomUdevRuleFiles: 70-ssd-scheduler.rules 70-kvm-perms.rules
Date: Sat Jun 30 12:42:57 2012
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MachineType: LENOVO 3249CTO
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-1-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
SourcePackage: udisks
UpgradeStatus: Upgraded to quantal on 2012-06-11 (19 days ago)
dmi.bios.date: 08/23/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET52WW (1.22 )
dmi.board.name: 3249CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET52WW(1.22):bd08/23/2010:svnLENOVO:pn3249CTO:pvrThinkPadX201:rvnLENOVO:rn3249CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3249CTO
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO

Steve Langasek (vorlon) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks2 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-09-07
Changed in udisks2 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

udisks1 did not use the "user=" option either. It's supposed to call /usr/sbin/umount.udisks2, similar to /usr/sbin/umount.udisks from udisks 1, through the "uhelper=udisks2" option. Explicitly calling "umount.udisks2 /dev/..." works fine. I'll investigate this.

summary: - udisks in quantal mounts disks without 'user=' option, prevents user
- unmounting
+ "umount" for udisks2 mounted devices does not work
Martin Pitt (pitti) wrote :

Aah, easy: umount.c does

                sprintf(umountprog, "/sbin/umount.%s", type);

but umount.udisks2 is installed into /usr/sbin/. I'll fix this.

Martin Pitt (pitti) wrote :

Fixed in Debian packaging git.

Changed in udisks2 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 1.99.0+git20120919-1

---------------
udisks2 (1.99.0+git20120919-1) experimental; urgency=low

  * Update to current upstream git head:
    - configure.ac: raise gudev dependency
    - Update list of recovery/system partitions
    - Add support for creating exFAT filesystems and changing exFAT labels
    - Add textual descriptions for IMSM Raid members
    - Use all-caps for RAID in descriptions
    - Lots of test suite robustifications and added tests
    - Enable large file support (LP: #1039022)
    - Mount vfat with "flush" option
  * Drop 00git_dev_t_annotation.patch, 00git_testsuite.patch.
  * debian/control: Bump libgudev-1.0-dev build dependency as per upstream
    configure.ac.
  * debian/udisks2.install: Install umount.udisks2 into /sbin; our old
    util-linux version does not yet find it in /usr/sbin/. (LP: #1019651)
 -- Martin Pitt <email address hidden> Thu, 20 Sep 2012 12:04:46 +0200

Changed in udisks2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers