udisks-daemon assertion failure: Failed to send polled devices

Bug #948663 reported by Werner Kuballa on 2012-03-07
210
This bug affects 41 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
High
Martin Pitt
udisks (Ubuntu)
Low
Unassigned

Bug Description

This error happened when I removed a USB stick (the filesystem was not mounted); may be coincidence though...

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: udisks 1.0.4-3
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94-0ubuntu2
Architecture: amd64
Date: Tue Mar 6 19:26:03 2012
ExecutablePath: /usr/lib/udisks/udisks-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111130.1)
MachineType: Hewlett-Packard HP EliteBook 8760w
ProcCmdline: /usr/lib/udisks/udisks-daemon
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-18-generic root=/dev/mapper/Cors256-U1204 ro quiet splash vt.handoff=7
Signal: 5
SourcePackage: udisks
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: udisks-daemon crashed with signal 5 in g_closure_invoke()
UpgradeStatus: Upgraded to precise on 2012-02-24 (12 days ago)
UserGroups:

dmi.bios.date: 10/24/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68SAD Ver. F.21
dmi.board.name: 1630
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 01.38
dmi.chassis.asset.tag: CNU1255DRY
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68SADVer.F.21:bd10/24/2011:svnHewlett-Packard:pnHPEliteBook8760w:pvrA0000C02:rvnHewlett-Packard:rn1630:rvrKBCVersion01.38:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 8760w
dmi.product.version: A0000C02
dmi.sys.vendor: Hewlett-Packard

Werner Kuballa (wkuballa) wrote :

StacktraceTop:
 poller_set_devices (devices=<optimized out>) at poller.c:400
 daemon_local_update_poller (daemon=<optimized out>) at daemon.c:2096
 block_device_remove (d=<optimized out>, daemon=0x2357040) at daemon.c:1576
 device_remove (daemon=0x2357040, d=<optimized out>) at daemon.c:1589
 g_closure_invoke (closure=0x2359d00, return_value=0x0, n_param_values=3, param_values=0x2362f20, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:777

Changed in udisks (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in udisks (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
David Sommen (davidsommen) wrote :

To me this happened in Precise Pangolin up-to-date in Vmware fusion on my macbook.

Martin Pitt (pitti) wrote :

To fix this I actually need the full error message, which is unfortunately not part of the stack trace. If you are able to reproduce this crash, please open a terminal, run

  sudo /usr/lib/udisks/udisks-daemon --replace 2>&1 | tee /tmp/udisks.log

and then add/remove/whatever your USB stick or other devices until it crashes with something like "Failed to send polled devices: ...". Once it does, please describe which particular action you did and attach /tmp/udisks.log here.

summary: - udisks-daemon crashed with signal 5 in g_closure_invoke()
+ udisks-daemon assertion failure: Failed to send polled devices
Changed in udisks (Ubuntu):
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

That being said, udisks is not actually supposed to poll any more in the first place, this should be done by the kernel these days. Adding an udev task to fix the polling.

Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Martin Pitt (pitti) on 2012-03-28
Changed in udev (Ubuntu):
status: In Progress → Fix Committed
importance: Undecided → High
Changed in udisks (Ubuntu):
importance: Medium → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 175-0ubuntu7

---------------
udev (175-0ubuntu7) precise; urgency=low

  * builtin-block-polling.patch: Fix default attribute comparison for CD
    drives, the default value of events_poll_msecs is -1, not 0. This really
    makes in-kernel polling work for those.
  * builtin-block-polling.patch: Apply to all drives with removable media, not
    just CD drives. (LP: #948663)
  * 00git-keymaps.patch: Update to the latest keymaps from upstream:
    - Dell XPS (LP: #910911)
    - HP Presario CQ60 (LP: #935804)
  * debian/rules: Drop prep and tarball targets. We want to use the upstream
    released tarballs.
  * debian/rules: Use dh_autoreconf. Add build dependency.
 -- Martin Pitt <email address hidden> Wed, 28 Mar 2012 12:23:10 +0200

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2012-04-02
Changed in udisks (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
To post a comment you must log in.