SD Card mounts first time but will not remount

Bug #751644 reported by Carla Sella on 2011-04-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
udisks (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udisks

While testing the internal data card reader for Natty Beta 1, I found out that the mini SD is mounted the first time you insert it in the card reader, but after unmounting it, if you take it out and re-insert it in the card reader it does not mount anymore.
It looks like bug 743303.
I also have an HP laptop: G62 Notebook PC.
I have the same card reader as in bug 743303: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader.
I'm attaching file lsusb.txt.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: udisks 1.0.2-4
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Tue Apr 5 16:36:24 2011
HotplugNewDevices: /dev/sdc1
HotplugNewMounts: /dev/sdc1 /media/12D3-F29E vfat rw,nosuid,nodev,relatime,uid=999,gid=999,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro 0 0
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
MachineType: Hewlett-Packard HP G62 Notebook PC
ProcEnviron:
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: udisks
Symptom: storage
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/25/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1425
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 54.12
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.06:bd01/25/2010:svnHewlett-Packard:pnHPG62NotebookPC:pvr049D100000202710000020000:rvnHewlett-Packard:rn1425:rvr54.12:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP G62 Notebook PC
dmi.product.version: 049D100000202710000020000
dmi.sys.vendor: Hewlett-Packard

Carla Sella (carla-sella) wrote :
MBybee (mike-bybee) wrote :

Same behavior here - here's what my dmesg shows on card insertion:

[ 86.537936] sd 4:0:0:0: [sdc] 31457280 512-byte logical blocks: (16.1 GB/15.0 GiB)
[ 86.539926] sd 4:0:0:0: [sdc] No Caching mode page present
[ 86.539931] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 86.543804] sd 4:0:0:0: [sdc] No Caching mode page present
[ 86.543812] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 86.544743] sdc: sdc1

Then nothing. The card worked on the Alpha, and it worked in 10.10 (and even in the beta over the weekend, prior to updates).
This is on an Acer 5742, via the integrated reader.

Plugging the same card into a USB reader it pops right up.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks (Ubuntu):
status: New → Confirmed
apinunt (apinunt) wrote :

When you right click on the cards icon you should have 2 choices, I'm running Linux Mint and don't know if the choices are labeled the same in Ubuntu, but in Mint the choices are 'Eject' and 'Safely Remove Drive'. The internal card reader is 'mounted' and all you want to do is 'Eject' the media from it, not unmount the internal card reader. When you plug an external card reader into a USB slot, the reader is mounted and if it contains a card or one is inserted the card is made accessable, and I believe if you unmount the external card reader it also will not be able to access another card plugged into it until it is unplugged from the USB slot and plugged in again which would remount it. The internal card reader is hard wired so you would have to reboot to remount it, or remount it manually with a terminal command.

palimmo (palimmo) wrote :

It doesn't work both with "Eject" and "Safely remove drive".
Ubuntu 11.10 e Ubuntu 12.04 beta2 64 bit.
Packard Bell Easynote TJ65.

palimmo (palimmo) wrote :

After 5 attempts (insert-eject) it works!

apinunt (apinunt) wrote :

It failed on the first 4 attempts and worked on the 5th?

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/751644

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers