displays a media player as a standard disk

Bug #540235 reported by Sebastien Bacher on 2010-03-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
Medium
Martin Pitt
udisks (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: udisks

Current lucid displays an ipod nano 5g has a normal disk, it should use the multimedia-player-apple-ipod icon rather!

ProblemType: Bug
Architecture: i386
Date: Wed Mar 17 14:07:40 2010
DistroRelease: Ubuntu 10.04
HotplugNewDevices: /dev/sdb /dev/sdb1
HotplugNewMounts: /dev/sdb1 /media/IPOD\040(SEB) vfat rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,flush,errors=remount-ro 0 0
MachineType: Dell Inc. Latitude D630
Package: udisks 1.0.0~git20100305.fa313b2-1ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=f5f37d65-fb1f-44ed-ae41-db66575a81de ro quiet splash locale=fr_FR
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_US
 PATH=(custom, user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: udisks
Symptom: storage
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 07/23/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0KU184
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd07/23/2007:svnDellInc.:pnLatitudeD630:pvr:rvnDellInc.:rn0KU184:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D630
dmi.sys.vendor: Dell Inc.

Related branches

Sebastien Bacher (seb128) wrote :
Martin Pitt (pitti) on 2010-03-17
Changed in udisks (Ubuntu):
importance: Undecided → Low
Martin Pitt (pitti) wrote :

Let's get through this from bottom to top. The first odd thing is

UDISKS_PRESENTATION_ICON_NAME=multimedia-player
DKD_PRESENTATION_ICON_NAME=multimedia-player-apple-ipod-nano-white

For the DKD_* part, do you have devicekit-disks installed still? Can you please uninstall it?

You don't have a more specific UDISKS_PRESENTATION_NAME here because our rule says

SUBSYSTEMS=="usb", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="1209", ENV{UDISKS_PRESENTATION_ICON_NAME}="multimedia-player-ipod-white"

but your device's product ID is 1265. I figure we should probably change that rule from a specific vendor/product to ENV{ID_MEDIA_PLAYER}=="apple-ipod". But I wonder why you got multimedia-player-apple-ipod-nano-white in dk-disks. Did you perhaps edit 95-devkit-disks.rules to have your product ID? The "1209" hasn't changed since then.

Changed in udisks (Ubuntu):
status: New → Incomplete
Martin Pitt (pitti) wrote :

Hm, we also don't seem to have an "ipod-white" icon:

$ locate multimedia-player
/usr/share/icons/Humanity/devices/24/multimedia-player-ipod.svg
/usr/share/icons/Humanity/devices/24/multimedia-player.svg
/usr/share/icons/Humanity/devices/48/multimedia-player-ipod.svg
/usr/share/icons/Humanity/devices/48/multimedia-player.svg
/usr/share/icons/gnome/16x16/devices/multimedia-player.png
/usr/share/icons/gnome/22x22/devices/multimedia-player.png
/usr/share/icons/gnome/24x24/devices/multimedia-player.png
/usr/share/icons/gnome/32x32/devices/multimedia-player.png
/usr/share/icons/gnome/scalable/devices/multimedia-player.svg

I'll ask David where he got the ipod-white from, and perhaps patch it to "multimedia-player-ipod".

Martin Pitt (pitti) wrote :

Seb, can you please apply this locally?

--- /lib/udev/rules.d/80-udisks.rules
+++ /lib/udev/rules.d/80-udisks.rules
@@ -149,6 +149,7 @@ SUBSYSTEMS=="usb", ATTRS{idVendor}=="05e3", ATTRS{idProduct}=="070e", ENV{ID_INS
 # Generic music player
 #
 SUBSYSTEMS=="usb", ENV{ID_MEDIA_PLAYER}=="?*", ENV{UDISKS_PRESENTATION_ICON_NAME}="multimedia-player"
+SUBSYSTEMS=="usb", ENV{ID_MEDIA_PLAYER}=="apple-ipod", ENV{UDISKS_PRESENTATION_ICON_NAME}="multimedia-player-i

 # Apple iPod Video
 #

and then replug the device and verify in udisks --dump that it now says multimedia-player-ipod?

Martin Pitt (pitti) wrote :
Changed in udisks (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Incomplete → Fix Committed
Sebastien Bacher (seb128) wrote :

adding "SUBSYSTEMS=="usb", ENV{ID_MEDIA_PLAYER}=="apple-ipod", ENV{UDISKS_PRESENTATION_ICON_NAME}="multimedia-player-ipod-white"" makes the icon be correct in udisks --dump, I've no local devicekit-disks config no

the icon naming spec assure fallback to multimedia-player-ipod which is in the icon theme too

Martin Pitt (pitti) wrote :

I can reproduce the icon problem with my wife's Samsung U5. It might be in nautilus or gdu, but gvfs will do for now.

Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) on 2010-03-18
summary: - displays an ipod nano as a standard disk
+ displays a media player as a standard disk
Martin Pitt (pitti) wrote :

This is fixed in gdu 2.30.

affects: gvfs (Ubuntu) → gnome-disk-utility (Ubuntu)
Changed in gnome-disk-utility (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

synced g-d-u 2.30.0-1 into lucid.

Changed in gnome-disk-utility (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks - 1.0.0+git20100319-0git1

---------------
udisks (1.0.0+git20100319-0git1) lucid; urgency=low

  Upload current Debian packaging git head (Debian uploads do not work right
  now)

  [ Michael Biebl ]
  * Build against parted 2.2. (Closes: #574908)
  * debian/control
    - Add dependency on dbus.

  [ Martin Pitt ]
  * Update to current git head, which fixes three small issues:
    - umount.udisks: Exit with return code 0 if the unmount succeeded.
      (LP: #541740)
    - Allow other rules (such as media-player-info) to set a more specific
      presentation icon.
    - Set multimedia-player-ipod icon for iPod media players. (LP: #540235)
 -- Martin Pitt <email address hidden> Fri, 26 Mar 2010 12:15:23 +0100

Changed in udisks (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers