udisks does not support Realtek rts5229 SD/MMC card readers.

Bug #1022497 reported by Ayan George on 2012-07-09
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udisks (Ubuntu)
High
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
udisks2 (Ubuntu)
Medium
Martin Pitt

Bug Description

SRU Justification
-----------------

Impact:

This bug prevents MS and MS Pro media cards from being automounted by nautilus.

Fix:

Add a rule to 80-udisks.rules that sets the the ENV{ID_DRIVE_FLASH_SD} property to "1" on rts5229 based cards so they are properly presented and automounted. Currently, this only impacts yet to be released hardware in the enablement/certification queue.

Patch:

The required udisks rule has been applied to the git master branch:

   http://cgit.freedesktop.org/udisks/commit/?id=3fbd4dc4

Regression Potential:

There should be very little potential for regression.

TEST CASE:

* Insert an MS or MSPro card in a machine with an rts5229 based card reader.
  - An icon should appear on the unity launcher.
  - The volume should be auto-mounted.
  - A nautilus window should open.

Ayan George (ayan) wrote :
Changed in udisks (Ubuntu):
milestone: none → oneiric-updates
assignee: nobody → Ayan George (ayan)
importance: Undecided → High
status: New → Triaged
Ayan George (ayan) wrote :
Changed in udisks (Ubuntu):
milestone: oneiric-updates → none
Marc Deslauriers (mdeslaur) wrote :

Your two attachments are not debdiffs, they are changes files.

Please attach debdiffs. Thanks!

Changed in udisks (Ubuntu Oneiric):
status: New → Incomplete
Changed in udisks (Ubuntu Precise):
status: New → Incomplete
Ayan George (ayan) wrote :
Ayan George (ayan) wrote :

The debdiff in comment #4 is for Oneiric. The debdiff in #5 is for Precise.

Changed in udisks (Ubuntu Oneiric):
status: Incomplete → New
Changed in udisks (Ubuntu Precise):
status: Incomplete → New
Michael Terry (mterry) wrote :

Uploading to precise-proposed and oneiric-proposed. Note that when you make a changelog entry:

 * Try not to make it so long (wrap it)
 * Include the bug number like LP: #1022497
 * Use SRU versioning (if previous number was 1.0.4-1, use 1.0.4-1ubuntu0.1; if previous number was 1.0.4-5ubuntu2, use 1.0.4-5ubuntu2.1)
 * Use the right targets (oneiric-proposed and precise-proposed instead of unstable or precise)

Thanks for the patches! I'm assuming pitti will upload a fixed udisks to quantal.

Hello Ayan, or anyone else affected,

Accepted udisks into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/udisks/1.0.4-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in udisks (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Ayan, or anyone else affected,

Accepted udisks into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/udisks/1.0.4-5ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in udisks (Ubuntu Precise):
status: New → Fix Committed
Changed in udisks (Ubuntu):
assignee: Ayan George (ayan) → Martin Pitt (pitti)

Assigning the development release task to pitti, as it's not clear to me if this has been fixed in Debian or Quantal.

Martin Pitt (pitti) wrote :

udisks 1.x is obsolete in Quantal, we are using udisks2 now. Adjusting tasks. The fix is committed upstream, but not yet in a new upstream release, so this is not yet fixed in Quantal.

no longer affects: udisks2 (Ubuntu Oneiric)
no longer affects: udisks2 (Ubuntu Precise)
Changed in udisks2 (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Changed in udisks (Ubuntu):
status: Triaged → Invalid
assignee: Martin Pitt (pitti) → nobody
Ayan George (ayan) wrote :

I apologize: I mistyped the card reader model in the title and description. It is in fact rts5229 (not rts5992). This doesn't change the debdiffs as I got the name right in them.

summary: - udisks does not support Realtek rts5992 SD/MMC card readers.
+ udisks does not support Realtek rts5229 SD/MMC card readers.
description: updated
Sebastien Bacher (seb128) wrote :

@Ayan: did you test the update?

Ayan George (ayan) wrote :

Sebastien, no -- I haven't yet. I'll try to get it done today.

Sebastien Bacher (seb128) wrote :

the update could to to -updates if it was verified, is there anyone interested in that fix to test it?

Chris Gagnon (chris.gagnon) wrote :

This udisk is fixed in precise-proposed

after a installing a dkms package for realtek 5229 card reader and using update manager to install the updates from precise-proposed nautilus opened with the card contents like it should when a media card is inserted in to the card reader.

Steps:
1. install dkms package for realtek 5229 card reader in a fresh install of 12.04
2. install all updates in -proposed
3. sudo modprobe rts5229
4. insert sd card in card reader

Expected results:
Nautilus opens with card data showing

Actual results:
Nautilus opens with card data showing

Martin Pitt (pitti) on 2012-07-25
tags: added: verification-done
removed: verification-needed
tags: added: verification-done-precise verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks - 1.0.4-5ubuntu2.1

---------------
udisks (1.0.4-5ubuntu2.1) precise-proposed; urgency=low

  * Add 13-mark-rts5229-as-flash.patch: Mark rts5229 devices as SD
    card readers. (LP: #1022497)
 -- Ayan George <email address hidden> Mon, 09 Jul 2012 04:20:57 -0400

Changed in udisks (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks2 - 1.99.0-1

---------------
udisks2 (1.99.0-1) experimental; urgency=low

  * New upstream release (LP: #1030268)
    - Support Realtek rts5229 SD/MMC card readers. (LP: #1022497)
  * Drop 00git_no_polkit_fallback.patch, upstream now.
  * Drop debian/local/integration-test, shipped in upstream tarball now.
  * debian/tests/upstream-system: Run test suite from upstream source.
  * debian/tests/control: Simplify Depends: line using "@".
  * debian/tests/control: Drop undefined "no-build-needed" feature.
 -- Martin Pitt <email address hidden> Sat, 28 Jul 2012 13:35:04 +0200

Changed in udisks2 (Ubuntu):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Looks like this still needs testing on oneiric.

tags: removed: verification-done
Ayan George (ayan) wrote :

Scott -- okay, I'll see if I can get this verified under Oneiric ASAP. Hopefully tomorrow but realistically, by the end of the week.

The fix for this bug has been awaiting testing feedback in the -proposed repository for oneiric for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Brian Murray (brian-murray) wrote :

The version of udisks in oneiric-proposed has been removed as this bug report was not verified in a timely fashion.

Changed in udisks (Ubuntu Oneiric):
status: Fix Committed → Triaged
tags: removed: verification-needed
tags: removed: removal-candidate
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in udisks (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers