keyboard shortcut for eject dvd/cd doesn't work on Samsung 700Z3A

Bug #902798 reported by Alexander Adam on 2011-12-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

I have a fresh installation of Ubuntu 11.10.
When I hit Fn+Del I expect ejecting the DVD or CD but nothing happens.

In dmesg appears:
atkbd serio0: Unknown key released (translated set 2, code 0xba on isa0060/serio0)
atkbd serio0: Use 'setkeycodes e03a <keycode>' to make it known.

If I type eject in terminal ejecting works.
---
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 700Z3A/700Z4A/700Z5A/700Z5B
NonfreeKernelModules: wl fglrx
Package: udev 173-0ubuntu4
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=79cceb60-82a8-4f3e-ac45-da81d8a34455 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Tags: oneiric
Uname: Linux 3.0.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/02/2011
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 09FD
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 700Z3A/700Z4A/700Z5A/700Z5B
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr09FD:bd11/02/2011:svnSAMSUNGELECTRONICSCO.,LTD.:pn700Z3A/700Z4A/700Z5A/700Z5B:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn700Z3A/700Z4A/700Z5A/700Z5B:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 700Z3A/700Z4A/700Z5A/700Z5B
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

apport information

tags: added: apport-collected oneiric
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udev (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

Fixed in upstream trunk. Thanks!

Changed in udev (Ubuntu):
status: Confirmed → Fix Committed
Alexander Adam (7ql6) wrote :

Phantastic! Works flawlessly. Thank you very much!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 175-0ubuntu4

---------------
udev (175-0ubuntu4) precise; urgency=low

  * Add builtin-block-polling.patch: Set default polling interval on CD drives
    as well. The events_dfl_poll_msecs will not trigger if "block" is not a
    module, but built in. This will avoid udisks etc. having to poll from
    userspace, and provide proper ejection when the hardware eject button is
    pressed. (LP: #890592)
  * Add 00git-keymaps.patch: Backport keymaps from current git master.
    (LP: #901513, #902332, #902798, #914838, #922405)
  * Add 00git-persistent-net-xen.patch: 75-persistent-net-generator.rules: Add
    Xen. (LP: #897789)
 -- Martin Pitt <email address hidden> Mon, 06 Feb 2012 09:17:28 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers