Hotkeys for adjust the keyboard-backlight don't work on Samsung 700Z3A

Bug #902332 reported by Alexander Adam on 2011-12-09
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

What I expected to happen: using these shortcuts should change the keyboard backlight on Samsung 700Z3A (and possibly more models of this series).

What happened instead: nothing.

Keycodes are 0x97 and 0x96 so I think it should be something like this:

0x97 keyboardbrightnessdown # Fn+F9
0x96 keyboardbrightnessup # Fn+F10

$ cat /sys/class/dmi/id/sys_vendor
SAMSUNG ELECTRONICS CO., LTD.
$ cat /sys/class/dmi/id/product_name
700Z3A/700Z4A/700Z5A/700Z5B

Ubuntu version is…
Description: Ubuntu 11.10
Release: 11.10

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: udev 173-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Dec 9 21:36:32 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 700Z3A/700Z4A/700Z5A/700Z5B
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=79cceb60-82a8-4f3e-ac45-da81d8a34455 ro quiet splash vt.handoff=7
SourcePackage: udev
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/02/2011
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 09FD
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 700Z3A/700Z4A/700Z5A/700Z5B
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr09FD:bd11/02/2011:svnSAMSUNGELECTRONICSCO.,LTD.:pn700Z3A/700Z4A/700Z5A/700Z5B:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn700Z3A/700Z4A/700Z5A/700Z5B:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 700Z3A/700Z4A/700Z5A/700Z5B
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Alexander Adam (7ql6) wrote :
Alexander Adam (7ql6) wrote :

I just tested a recent kernel build (3.2-rc4) and the bug still exists there.

tags: added: kernel-bug-exists-upstream
Alexander Adam (7ql6) wrote :

If I press these keys, in dmesg appears…

atkbd serio0: Unknown key pressed (translated set 2, code 0x97 on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e017 <keycode>' to make it known.
atkbd serio0: Unknown key pressed (translated set 2, code 0x96 on isa0060/serio0).
atkbd serio0: Use 'setkeycodes e016 <keycode>' to make it known.

Alexander Adam (7ql6) wrote :

As I read on a website this problem also exists on 700Z5A ( http://schibum.blogspot.com/2011/11/ubuntu-oneiric-on-samsung-series-7.html ).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udev (Ubuntu):
status: New → Confirmed
AdrianOlek (adrianolek) wrote :

I can confirm this issue on 700Z5A, Ubuntu 11.10 3.0.0-14 kernel
700Z5A & 700Z3A models use the same key codes:
0x97 - decrease backlight
0x96 - increase backlight

AdrianOlek (adrianolek) wrote :

People are able to use keyboard backlight keys on Samsung Series 9 laptops: http://jablonskis.org/2011/fedora-16-linux-on-samsung-series-9-np900x3a/
However I couldn't make it work on Series 7 although the keycodes are the same.

Martin Pitt (pitti) wrote :

Fixed in upstream trunk. Thanks!

Changed in udev (Ubuntu):
status: Confirmed → Fix Committed
AdrianOlek (adrianolek) wrote :

@pitti do you have a link to the commit?

AdrianOlek (adrianolek) wrote :

Shouldn't the codes be kbdillumup / kbdillumdown ?

Alexander Adam (7ql6) wrote :

Does it rely on something newer as in Ubuntu 11.10?
While the eject hotkey (902798) works now the keyboard backlight does not change. :-(

AdrianOlek (adrianolek) wrote :

In 11.10, the samsung-laptop module doesn't load, so controlling backlight won't work just by mapping keycodes. If you follow the guide from #7 comment you will have working kbd_backlight device in /sys/devices/platform/samsung/leds/samsung::kbd_backlight/brightness. However after you map kbdillumup / kbdillumdown keys, you still won't be able to control backlight. There's some conflict when pressing kbdillumup/down keys - keyboard input is broken after pressing. One thing I've noticed is that if you switch to terminal (ctrl+alt+f1) after pressing the key, then switch back to desktop, keyboard input is restored, the osd notification about keyboard backlight appears and sometimes even keyboard brightness level changes (+/- 1 step). If someone has an idea how to debug this situation (led device works properly, keys are mapped in udev), please let me know.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 175-0ubuntu4

---------------
udev (175-0ubuntu4) precise; urgency=low

  * Add builtin-block-polling.patch: Set default polling interval on CD drives
    as well. The events_dfl_poll_msecs will not trigger if "block" is not a
    module, but built in. This will avoid udisks etc. having to poll from
    userspace, and provide proper ejection when the hardware eject button is
    pressed. (LP: #890592)
  * Add 00git-keymaps.patch: Backport keymaps from current git master.
    (LP: #901513, #902332, #902798, #914838, #922405)
  * Add 00git-persistent-net-xen.patch: 75-persistent-net-generator.rules: Add
    Xen. (LP: #897789)
 -- Martin Pitt <email address hidden> Mon, 06 Feb 2012 09:17:28 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released

Hmm, I have udev 175-0ubuntu6, but the hotkeys for the keyboard backlight don't work.

I have built samsung-laptop module, and I'm able to control the backlight by setting different values in /sys/devices/platform/samsung/leds/samsung\:\:kbd_backlight.

AdrianOlek (adrianolek) wrote :

@tomasz Check the posts on http://jablonskis.org/tag/samsung/ blog

Alexander Adam (7ql6) wrote :

Should it work in 12.03 / linux 3.2?
For me changing the keyboard backlight does also work by changing the value in the mentioned file but not by hotkey.

Also observed on Samsung 900X3A. It's really a shame it takes so long to get support for the keys, especially since my laptop has been adjusting the keyboard backlight *automatically* based on the ambient light for some time now (unclear how long, just discovered it a few days ago). If there's a dummy guide to getting such things done and committed I'd be more than happy to give it a go - I already fixed a similar issue for another keyboard <https://github.com/l0b0/logitech-access-keyboard-bindings/blob/master/rc.local> but I've no idea where to submit such files.

Steven Wagner (stevenwagner) wrote :

This bug is still present on a Samsung 900X3A (Series 9) using Ubuntu 12.04.2 LTS Desktop

brian baker (brian-m-baker) wrote :

this bug is also present on the Samsung 900X3D series 9 using the 3.8 and 3.9 kernels on ubuntu 13.04

mmalmeida (mmalmeida) wrote :

This also affects Samsung Series 9 900X4C. I can't change the status of this bug. Adrian, Benjamin, R3gis, should we report a new bug?

modolo (modolo) wrote :

I have the same problem, no back-light
Samsung series 5

# sudo dmidecode -s system-product-name
Q470C/500P4C

I update /lib/udev/keymaps/samsung-other and put:
0x96 kbdillumup # F10 kbl+
0x97 kbdillumdown # F9 kbl-
0xD5 wlan # F12 wifi on/off

And update /lib/udev/keymaps/force-release/samsung-other to:
0x96 # kbdillumup # F10 kbl+
0x97 # kbdillumdown # F9 kbl-
0xD5 # wlan # F12 wifi on/off

But always can not change keyboard lighst.

Thanks,
Marcelo Módolo

Francisco Reverbel (reverbel) wrote :

This bug shows up on a Samsung Series 9 model NP900X4B running Ubuntu 14.04 (Trusty Tahr).

Workaround:

sudo setkeycodes e017 229
sudo setkeycodes e016 230

For more details, see the answer I posted in http://askubuntu.com/questions/233312/how-to-make-keyboard-backlight-fn-buttons-work-in-samsung-series-9.

Martin Pitt (pitti) wrote :

Francisco: Fixed upstream in http://cgit.freedesktop.org/systemd/systemd/commit/?id=e512e8 . This bug is closed already, so that fix can't be tracked in ubuntu, but it'll be fixed in 14.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers