Comment 3 for bug 889226

Bryce Harrington (bryce) wrote :

Hi Steve,

In the Xorg.1.log file I'm seeing:

[ 99307.560] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse1)
[ 99307.560] (II) No input driver/identifier specified (ignoring)
[ 99307.560] (II) config/udev: Adding input device USB KVM (/dev/input/event10)
[ 99307.560] (**) USB KVM: Applying InputClass "evdev keyboard catchall"
[ 99307.560] (II) Using input driver 'evdev' for 'USB KVM'
[ 99307.560] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 99307.560] (**) USB KVM: always reports core events
[ 99307.560] (**) USB KVM: Device: "/dev/input/event10"
[ 99307.561] (--) USB KVM: Found keys
[ 99307.561] (II) USB KVM: Configuring as keyboard
[ 99307.561] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2.4/1-1.2.4:1.0/input/input18/event10"
[ 99307.561] (II) XINPUT: Adding extended input device "USB KVM" (type: KEYBOARD)

and

[ 99307.632] (II) config/udev: Adding input device USB KVM (/dev/input/event11)
[ 99307.632] (**) USB KVM: Applying InputClass "evdev pointer catchall"
[ 99307.632] (**) USB KVM: Applying InputClass "evdev keyboard catchall"
[ 99307.632] (II) Using input driver 'evdev' for 'USB KVM'
[ 99307.632] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 99307.633] (**) USB KVM: always reports core events
[ 99307.633] (**) USB KVM: Device: "/dev/input/event11"
[ 99307.633] (--) USB KVM: Found 9 mouse buttons
[ 99307.633] (--) USB KVM: Found scroll wheel(s)
[ 99307.633] (--) USB KVM: Found relative axes
[ 99307.633] (--) USB KVM: Found x and y relative axes
[ 99307.633] (--) USB KVM: Found absolute axes
[ 99307.714] (II) evdev-grail: failed to open grail, no gesture support
[ 99307.714] (--) USB KVM: Found keys
[ 99307.714] (II) USB KVM: Configuring as mouse
[ 99307.714] (II) USB KVM: Configuring as keyboard
[ 99307.714] (II) USB KVM: Adding scrollwheel support
[ 99307.714] (**) USB KVM: YAxisMapping: buttons 4 and 5
[ 99307.714] (**) USB KVM: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 99307.714] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2.4/1-1.2.4:1.1/input/input19/event11"

A HID and keyboard appear to be getting mapped to event13 and event14. A PS/2 USB mouse is on event9.

Later there's this error:

[267355.695] (EE) Unable to open evdev device "/dev/input/event13".
[267355.716] [dix] couldn't enable device 16
[267355.716] (EE) Unable to open evdev device "/dev/input/event14".
[267355.716] [dix] couldn't enable device 18

What are the brand/model of mouse being plugged into the KVM? Is the keyboard plugged into the KVM a Microsoft Natural Ergonomic Keyboard 4000? Also, what's the brand/model of the USB KVM itself?

I'm interpreting from your wording that this is a regression and the laptop with the KVM worked properly in Ubuntu at some point in the past? What has changed on your system since that time? kernel 3.0 vs. 3.1 maybe? I'd be curious to know what is diff between the dmesg and Xorg.*.log's here compared with a live iso boot of oneiric (assuming that was working properly).