Comment 0 for bug 873584

Wookey (wookey) wrote :

udev fails to cross-build due to xdeb failing to install cross-dependencies:

Considering source package udev
sudo apt-get -y --allow-unauthenticated -o Dir::State::Lists=/home/wookey/testing/build/build/xdeb/lists.apt -o Dir::Cache::pkgcache=/home/wookey/testing/build/build/xdeb/pkgcache.bin -o Dir::Cache::srcpkgcache=/home/wookey/testing/build/build/xdeb/srcpkgcache.bin -o Dir::Etc::sourcelist=/home/wookey/testing/build/build/xdeb/sources.list --no-install-recommends install gir1.2-glib-2.0-armel-cross libgirepository1.0-dev-armel-cross libglib2.0-dev-armel-cross libselinux1-dev-armel-cross libsepol1-dev-armel-cross libusb-dev-armel-cross
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gir1.2-glib-2.0-armel-cross : Depends: libgirepository-1.0-1-armel-cross (>= 0.10.2) but it is not going to be installed
                               Depends: libglib2.0-0-armel-cross (>= 2.28.0) but it is not going to be installed
 libgirepository1.0-dev-armel-cross : Depends: libgirepository-1.0-1-armel-cross (= 0.10.7-0ubuntu1) but it is not going to be installed
 libglib2.0-dev-armel-cross : Depends: libglib2.0-0-armel-cross (= 2.28.6-0ubuntu1) but it is not going to be installed
                              Depends: libpcre3-armel-cross (>= 8.10) but it is not installable

This may be an issue of unclean build chroot rather than xdeb doing it wrong.