ubuntu 11.10-12.10: Logitech MX5500 keyboard/mouse combo not recognized.

Bug #870227 reported by Makis-k on 2011-10-07
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

I just downloaded the daily build of Ubuntu 11.10 today (October 7 2011) and tested the live CD. When the live CD boots and I'm presented with the graphical environment I cannot use neither my keyboard nor my mouse (model: Logitech MX5500 keyboard/mouse combo). They both freeze! I tried to reconnect them by resetting the bluetooth receiver but still no luck! Worth to mention that I never had any problems with this keyboard/mouse combo before (at least in the 2 previous Ubuntu versions 10.10 and 11.04 - both worked fine!)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Brett (belgarth) wrote :

Is there anything needed to move forward on this bug? It is extremely annoying.

Makis-k (makis-k) wrote :

@Brett:
I sincerely don't have a clue. Another user and I have filed the bug (as a matter of fact I noticed that the other user has already filed this as a bug since mid September!!!) but still no responses and no luck... It's such a pity there's such a bug in this release given the fact (as I've already mentioned) that this problem didn't exist in the previous 2 ubuntu releases...

Johan Ferner (johan-ferner) wrote :

I think it's fixed by something :) I had this problem before, upgraded yesterday, rebooted and tried to reconnect my keyboard and it worked! So try the same and report if fixed.

jatoo (wainwright-alex) wrote :

I'm currently on the live CD of the release and can't get my Logitech mouse to connect.

CParker (c-parker) wrote :

Attached a ps/2 keyboard along with the the MX5500. Logged in and a dialog box popped up asking if wanted to grant access to MX5500 but quickly disappeared before I could tab to "Grant". I have tried the upgrade route and fresh install and neither recognize the MX5500. Ubuntu 11.04 found the MX5500 and there was never a problem.

Vesper (p-r-north) wrote :

Mine worked when i switched off Ubuntu Bluetooth. I had the 'grant access' dialogue recently and it would never work, but as soon as I switched off Bluethooth it just started working!

Alex (alexandre-stpierre) wrote :

Same here: Combo mouse/keyboard MX5500 with bluetooth receiver.

I also got the dialog box asking me to grant access:
Device 'Logitech MX5500 Keyboard' (00:07:61:B5:67:C9) wants access to the service '00001124-0000-1000-8000-00805f9b34fb'.

I had time to click on "Grant" but it didn't do anything, my keyboard still doesn't work.

Alex (alexandre-stpierre) wrote :

I succeeded to make both my mouse and keyboard works by following the advice found in this forum: http://ubuntuforums.org/showthread.php?t=1466806

or more exactly by commenting out this line in /lib/udev/rules.d/62-bluez-hid2hci.rules
# Logitech devices
#KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
# RUN+="hid2hci --method=logitech-hid --devpath=%p"

Unplug-plug the BT receiver and my mouse and keyboard work now perfectly!

Peter Zagar (peter-zagar-q) wrote :

Indeed commenting those two lines in /lib/udev/rules.d/62-bluez-hid2hci.rules worked for me too.
Thanks Alex

Makis-k (makis-k) wrote :

I can also confirm that indeed, after commenting out these 2 lines does the work! But beware!

Today Ubuntu had a few updates coming out. Among them there was some updates about bluez bluetooth and stuff like that - and what a surprise! After installing them I've found out that once again the same problem occured. On checking the file: /lib/udev/rules.d/62-bluez-hid2hci.rules I discovered that it was back to its original state. So I had to comment out the same 2 lines once again.

Other than that, everything is OK now. I just wish there was an automated fix so that we didn't have to connect other keyboard/mouse in order to comment out the stupid lines...

Jay Deiman (jay-splitstreams) wrote :

Just to add my name to the list here. Same problem and Alex's fix works.

bob dole (mike12345678900) wrote :

I'm having the same problem w/my mx 5500. how can i edit the file? i don't have permission

bob dole (mike12345678900) wrote :

nvm figured it out. after commenting out those lines, my keyboard/mouse work again! thanks!

Tim (utimcraig) wrote :

I'd like to note that this problem prevents anyone from using ubuntu 11.10 if they have one of these fairly popular bluetooth keyboard/mouse combos.

I used the WUBI installer today 1/15/2012, and neither the mouse nor the keyboard work. I'll have to find a wired keyboard from somewhere, maybe a museum, to comment out those lines.

Alex (alexandre-stpierre) wrote :

Had the exact same problem after my upgrade from 11.10 to 12.04. This time the file I had to edit to make my MX5500 to work is /lib/udev/rules.d/97-bluetooth-hid2hci.rules

Johan Ferner (johan-ferner) wrote :

Just upgraded from 11.10 to 12.04 and my only problem so far is this bug. Fix from Comment #16 works. If installing from scratch I would use an old wired keyboard/mouse during install. This bug isn't exactly impressive for LTS release if you have this hardware....

moresun (markus-bader) wrote :

Number #16 worked for me as well
Thanks Max

AlexTiff (pattern-principle) wrote :

I have Ubuntu 11.10 and #11 worked for me.

Johan Ferner (johan-ferner) wrote :

And it keeps on through the dists. Ubuntu 12.10 beta 2 affected. Fix works.

Jacek Królikowski (nietaki) wrote :

I've got a repro on Ubuntu 12.04.1 with Logitech Wireless COmbo mk520, and the fix listed before worked.

sirlancelot (sirlancelot) wrote :

Breaks during 12.10 upgrade. Commenting out the lines in /lib/udev/rules.d/97-bluetooth-hid2hci.rules fixed the problem. I can't use the receiver as a regular Bluetooth device (it doesn't show up in settings) but at least my keyboard and mouse work.

summary: - ubuntu 11.10: Logitech MX5500 keyboard/mouse combo not recognized.
+ ubuntu 11.10-12.10: Logitech MX5500 keyboard/mouse combo not recognized.
tags: added: mouse
sirlancelot (sirlancelot) wrote :

I found an alternative method which looks promising. I haven't tried it yet but I will when I get home: http://stuffivelearned.org/doku.php?id=os:linux:ubuntu:mx5500

sirlancelot (sirlancelot) wrote :

Tried using the method I linked previously and it couldn't find the bluetooth stick when I ran `hcitool dev` so that option is out :(

Strelok (who-) on 2013-03-10
affects: ubuntu → udev (Ubuntu)
Noel Bowland (noel-m) on 2013-03-20
Changed in udev (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Anthony (darkeskye) wrote :

easiest fix i found was if u have bluetooth, press the connect button on the kb, right click on the bluetooth icon and click on setup new device and it should see the kb, worked for me!!! :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers