/run/udev not writable error message

Bug #784216 reported by Bryce Harrington on 2011-05-17
172
This bug affects 31 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Low
Canonical Foundations Team

Bug Description

Binary package hint: udev

I upgraded from natty to oneiric, rebooted a couple times, and noticed this error message:

  udevd[79]: error: runtime directory '/run/udev' not writable, for now falling back to '/dev/.udev'

I booted with a natty kernel and still saw the error, so am guessing it's not being printed by the kernel.

Although some people in the comments are having boot problems, I think this error message isn't related to boot failures, it's just that it's the only thing you see, so you assume it must relate to the failure. But I see it with successful live environment boots as well.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: udev 168-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Tue May 17 11:38:27 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 0d3d:0001 Tangtop Technology Co., Ltd HID Keyboard
MachineType: Intel Corporation SandyBridge Platform
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=86eed8d1-9bba-4674-b9b9-a0857eb3b5bc ro quiet splash vt.handoff=7
SourcePackage: udev
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/23/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: ASNBCPT1.86C.0043.B00.1009231140
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Emerald Lake
dmi.board.vendor: Intel Corporation
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 9
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrASNBCPT1.86C.0043.B00.1009231140:bd09/23/2010:svnIntelCorporation:pnSandyBridgePlatform:pvrTobefilledbyO.E.M.:rvnIntelCorporation:rnEmeraldLake:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct9:cvrToBeFilledByO.E.M.:
dmi.product.name: SandyBridge Platform
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Intel Corporation

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :

This might be a separate problem, as I saw it only on the oneiric kernel, not on the natty kernel (well, not yet anyway). On reboot the console was filled with many screens of spewed timeout errors trying to kill modprobe.

Alex Bell (ubuntu-upb) wrote :

I have this too.
And there is one more issue I'm not sure if they are connected, but when I'm powering down or try to restart my laptop sometimes it looks like shutting down normally, but then systems goes to black screen and stays like that. Not responding any commands and not doing anything. I've tried to wait but it can stay for hours like that.
All my logs with syslog are published in here: https://bugs.launchpad.net/ubuntu/+source/udev/+bug/794266

Joshua R. Poulson (jrp) wrote :

I see this on the oneiric kernel on my pandaboard running the Alpha 1 image on clean shutdowns and boots. However, it does not fail, it comes up fine.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

This was introduced by this commit:

udev (167-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Drop v4l1 code, as current kernels don't ship that any more.
    - Lots of bug fixes.
    - Lots of changes to systemd integration (does not affect Ubuntu package).
    - Use /run/udev/ if possible and fall back to /dev/.udev/ (does not affect
      current Ubuntu, as we don't have a /run directory).
    - Some keymap updates for Acer and MSI laptops. (LP: #637695)
  * debian/libudev0.symbols: Add two new symbols from new version.

Setting to low because it seems more cosmetic than a functional failure.

Changed in udev (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Christopher (soft-kristal) wrote :

I don't know about low. I can't boot into 2.6.38.2 with that error.

Christopher (soft-kristal) wrote :

Sorry - make that 2.6.39-3 that won't boot. I get a terminal with a syslog error and a login option but no LightDM or GDM.

Gustaf (g-rantila) wrote :

+1 on this, 2.6.38 works fine but not 2.6.39 or 3.0, the grub configs for them are identical (except for the kernel version).

Filip Dominec (fdominec) wrote :

+1 on this (Lubuntu 11.10 alpha 1, kernel 3.0-0-generic). I observed that creating the /run/udev directory prevented the system from boot.

blues (blues1961) wrote :

Same error here. +1

UbuntuFlo (ubuntuflo) wrote :

I don't think this problem/bug is solved. It ist still persistent. I tried booting with a Live-Image (2011-06-21) which failed because of the udev error-message.
What I did to be able to boot into Oneiric was to remove /var/run from the Oneiric-partition. This allows me to boot into Oneiric again, if one skips [s] the "/var/run is missing" error-message while booting.

Bryce Harrington (bryce) wrote :

For the record, I don't think that the error message *causes* the boot failures. It is just that your boot failed, and this was the most noticeable error message you saw.

I *think* that the message is innocuous, and just needs to be quelled. There has been some work in oneiric to transition stuff from /var/run to this new /run directory, and my guess is that this message is just some left over sharp corner that needs sanded down.

Many boot failures don't print error messages of their own, in which case the only thing you'd see would be this (unrelated) error message. Don't assume the error message is the cause of the boot failure though.

For debugging boot problems, look in your dmesg and the tail end of other logs in /var/log for other error messages.

description: updated
ubuntu center (ahmedyassin89) wrote :

same error +1>>>>> any solution

Chris S (cgseif323) wrote :

I received this error after downloading the alternate ISO (daily) for Oneiric. I tried installing the normal desktop version of the ISO and it was fixed, so it could have been a corrupt daily build?

tags: added: iso-testing

ISO TESTING: Confirmed, freshly installed 20110531.1/Desktop i386 (20110531.1) on real machine.

after the installation was completed, everytime it boots up I got this "underv[65]:error:runtime directory 'run/udev' not writeable, for now falling back up'/dev/.udev/ " before the splash screen.

Martin Pitt (pitti) wrote :

udev's warning is actually correct. The initramfs is supposed to create a /run directory, and preserve that after initramfs as well. I think implementing this was a foundations plan for oneiric anyway, thus assigning the bug.

affects: udev (Ubuntu) → initramfs-tools (Ubuntu)
Changed in initramfs-tools (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Jan Klesnil (klesnil) wrote :

Low importance? This bug completely breaks input in xserver!! The gdm and lightdm does not react to anything except the power button.

I have worked around the bug by creating /run/udev a symlink to /dev/.udev and the X server started to work fine.

Martin Pitt (pitti) wrote :

This warning message in udev is justified and harmless. The actual breakage of having a /run/ vs. /dev/.udev is now being tracked in bug 807306, thus this bug can be closed.

affects: initramfs-tools (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

The warning message is gone in current oneiric, as udev is using /run/ now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers