Pressing Fn-Fx multimedia keys causes system to repeat the pressed key infinitely (play/pause/rew/ff/Vol+/Vol-/VolMute) on Gigabyte i1520M

Bug #770680 reported by Lukáš Mojžíš on 2011-04-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: udev

Pressing Fn-Fx multimedia keys causes system to repeat the pressed key infinitely (play/pause/rew/ff/Vol+/Vol-/VolMute)

Patch is to add model name to /lib/udev/rules.d/95-keyboard-force-release.rules

[diff patch included]

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: udev 167-0ubuntu3 [modified: lib/udev/rules.d/95-keyboard-force-release.rules]
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Tue Apr 26 07:28:16 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
MachineType: GIGABYTE i1520M
ProcEnviron:
 LANGUAGE=cs_CZ:en
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=6118117d-1935-4975-851d-fcc23addbd48 ro quiet splash vt.handoff=7
SourcePackage: udev
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/09/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: Spring Peak 151D 0900
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: To be filled by O.E.M.
dmi.board.vendor: To be filled by O.E.M.
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrSpringPeak151D0900:bd07/09/2010:svnGIGABYTE:pni1520M:pvrTobefilledbyO.E.M.:rvnTobefilledbyO.E.M.:rnTobefilledbyO.E.M.:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: i1520M
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: GIGABYTE

Related branches

Lukáš Mojžíš (lmojzis) wrote :
tags: added: patch
Marius B. Kotsbak (mariusko) wrote :

Hmm, are you sure this is only for the volume keys, not all keys like bug #769103?

Lukáš Mojžíš (lmojzis) wrote :

Nope, no other keys are repeating, nor other fn+x keys work (except for sleep, it works properly) :) (no control for wireless, brightness, LVDS/VGA switcher, 3G (no installed adapter, though), bluetooth or Camera App Launch are working), but no, no other keys are repeating. Nooooo prrrrrobleeemms likeeeeee tthisss.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udev (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

committed upstream, thanks!

Changed in udev (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 175-0ubuntu1

---------------
udev (175-0ubuntu1) precise; urgency=low

  [ Loïc Minier ]
  * Update Vcs fields for precise.

  [ Steve Langasek ]
  * debian/udev.initramfs-hook: we aren't using pkill anymore, so don't put
    it in the initramfs.

  [ Martin Pitt ]
  * Unapply patches, they are not meant to be applied in the bzr branch.
  * New upstream releases 174 and 175:
    - Daemon moved to /lib/udev/udevd
    - path_id, usb_id, input_id tools are built-in commands now
    - fusectl filesystem is no longer mounted directly from udev
    - The long deprecated keys: SYSFS=, ID=, BUS= have been removed
    - The udev control socket is now created in /run/udev/control
    - The rules to create persistent network interface and cdrom link
      rules automatically in /etc/udev/rules.d/ have been disabled by
      default.
    - Support for 'udevadm trigger --type=failed, and the
      RUN{fail_event_on_error} attribute was removed.
    - Various keymap fixes (LP: #606599, #637695, #696671, #763525, #770680,
      LP: #795694)
    - Unbreak findkeyboards (LP: #881158)
    - Lots of bug fixes.
  * debian/rules: Explicitly enable persistent net/cdrom rule generator by
    default. Upstream default changed, but this seems too much a change for
    12.04 LTS.
  * Drop move-input_id-to-default-rules.patch, race-condition-on-exit: Applied
    upstream.
  * jack-detection.patch: Port to new upstream version.
  * load-fbcon.patch, use_run_tmpfs: Unfuzz.
  * debian/udev.install, debian/udev-udeb.install, debian/udev.initramfs-hook,
    debian/udev.initramfs-top, debian/udev.installer-startup,
    debian/udev.udev-finish.init, debian/udev.upstart: Update to changed
    location of udevd (/sbin → /lib/udev) and the three now builtin _id
    helpers.
  * debian/libudev0.symbols: Add new symbol from this release.
 -- Martin Pitt <email address hidden> Thu, 10 Nov 2011 08:49:07 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers