Do not create persistent name rules for eucalyptus interfaces

Bug #719418 reported by Tom Ellis on 2011-02-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: udev

udev creates persistent rules in /etc/udev/rules.d/70-persistent-net.rules for eucalyptus network interfaces.

In a UEC cloud, you can try a few methods to create persistent EBS based system images, when these work you can boot instances that are persistent. If the eucalyptus MAC's are not ignored, your instance will start with the network on eth1 and be inaccessible.

Eucalyptus uses the MAC prefix: d0:0d

This problem is much like: https://bugs.launchpad.net/ubuntu/+source/udev/+bug/341006 where vmware/qemu/kvm interfaces needed to be ignored otherwise problems are created whilst cloning images.

Scott Moser (smoser) wrote :
Changed in udev (Ubuntu):
assignee: nobody → Scott Moser (smoser)
importance: Undecided → Medium
status: New → Triaged
assignee: Scott Moser (smoser) → nobody
Changed in udev (Ubuntu):
status: Triaged → Confirmed
importance: Medium → Wishlist
Martin Pitt (pitti) wrote :

Unfortunately this can't go upstream, as this isn't an officially registered MAC prefix. So we'll need to keep it as Ubuntu specific delta for now.

Martin Pitt (pitti) wrote :

Thanks! I committed that to the udev packaging branch. I don't upload it right now because of the a3 freeze.

Changed in udev (Ubuntu):
status: Confirmed → Fix Committed
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 166-0ubuntu4

---------------
udev (166-0ubuntu4) natty; urgency=low

  [ Scott Moser ]
  * do not create persistent net rules for Eucalyuptus addresses (LP: #719418)

  [ Andy Whitcroft ]
  * debian/udev.udev-fallback-graphics.upstart: add a new fallback graphics
    phase (LP: #702090)
 -- Colin Watson <email address hidden> Fri, 18 Mar 2011 22:32:14 +0000

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers