Ubuntu

constant kernel errors about unknown multimedia keys

Reported by Mikel Ward on 2006-11-05
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: console-data

My /var/log/kern.log and output of dmesg are full of noise like this:
[17236124.064000] atkbd.c: Unknown key released (translated set 2, code 0x81 on isa0060/serio0).
[17236124.064000] atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.
[17236127.616000] atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
[17236127.616000] atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
[17236140.676000] atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
[17236140.676000] atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
[17236162.472000] atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
[17236162.472000] atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
[17236168.856000] atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
[17236168.856000] atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
[17236172.636000] atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
[17236172.636000] atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.

This makes it annoying to diagnose real kernel errors, since the real errors are obscured by these unnecessary messages.

It's been an issue known for a long time (I think since Linux 2.6), but it's still not fixed!

Last I looked at this problem, it was due to my Microsoft wireless keyboard sending power status messages. There is a similar issue reported in Fedora's Bugzilla, and the problem has been mentioned several times in the Ubuntu forums.

Sun Wukong (sunwukong) wrote :

The bug is still there

Sun Wukong (sunwukong) wrote :

Still in Hardy apha 5

Michele Mangili (mangilimic) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I couldn't reproduce your bug using Ubuntu 8.10, while I remember that I had the same issue with Hardy.

Do you still experience this problem?

Best Regards.

Mikel Ward (mikelward) wrote :

I don't have that computer anymore.

To reproduce, you'd need a Microsoft wireless multimedia keyboard.

Michele Mangili (mangilimic) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in console-data:
status: New → Invalid

I noticiced this error on my messages too.

Sep 5 14:50:55 fcavarretta-desktop kernel: [ 583.092401] atkbd.c: Unknown key released (translated set 2, code 0x81 on isa0060/serio0).
Sep 5 14:50:55 fcavarretta-desktop kernel: [ 583.092407] atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.
Sep 5 14:50:56 fcavarretta-desktop kernel: [ 583.236810] ACPI: Unable to turn cooling device [f6c2af18] 'on'

I do have a Microsoft wiereless keyboard.
I' using ubuntu 9.04

Changed in console-data (Ubuntu):
status: Invalid → New
Colin Watson (cjwatson) wrote :

This can't possibly be a console-data bug, because we no longer use console-data. However, I'm not sure where it should be fixed.

affects: console-data (Ubuntu) → ubuntu
Colin Watson (cjwatson) wrote :

Steve Langasek tells me that, nowadays (in 9.10 or later, which is where this would be getting fixed if it's still broken), this is handled by udev. The exception is if the key in question is something like a "power status message" that shouldn't register as a key at all, in which case this is a kernel bug.

affects: ubuntu → udev (Ubuntu)
Mikel Ward (mikelward) wrote :

Last time I looked at it, the key presses were happening even without me pressing anything on the keyboard, so I believe they were power status messages.

(As I said, I don't have that keyboard now, so I can't check.)

Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → Confirmed
Martin Pitt (pitti) wrote :

Please exercise the steps at https://wiki.ubuntu.com/Hotkeys/Troubleshooting to determine at which level your hotkey problems occur, and attach the collected information. In particular, it is important to figure out through which particular input device these events come, if they don't come from the "normal" keyboard.

Thanks!

Changed in udev (Ubuntu):
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in udev (Ubuntu):
status: Incomplete → Invalid
Andrew Walker (walker-aj325) wrote :

I can confirm that this problem persists in lucid and is related to the battery status updates from my Microsoft Wireless Comfort Keyboard 1.0A. The bug affects multiple Linux distros and is quite annoying because it fills up my log very quickly. Will post a new bug report concerning this.

Ubfan (ubfan1) wrote :

Running Maverick
Linux Maverick 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:36:48 UTC 2010 i686 GNU/Linux
on an Compaq Presario v3000 lsptop, I saw this message in my dmesg output:
[ 12.793811] ppdev: user-space parallel port driver
[ 34.742043] atkbd serio0: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
[ 34.742049] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
[ 34.742716] atkbd serio0: Unknown key released (translated set 2, code 0xd9 on isa0060/serio0).
[ 34.742719] atkbd serio0: Use 'setkeycodes e059 <keycode>' to make it known.
[ 63.928333] wlan0: authenticate with 00:0c:41:81:ce:9f (try 1)
[ 63.943628] wlan0: authenticated
..
The message appeared once, and I have been running Maverick a couple of days without noticing
any problems.

Martin Pitt (pitti) wrote :

Please file new reports, since you have different hardware. Thanks!

Hello!
I am Julia, I am 27 y.o.
I search for boy-friend.
My photos and new message for you here:

http://hotbrides.ru

Casey James Baker (cjbaker) wrote :

Here's a workaround I came across:

http://ubuntuforums.org/showthread.php?t=898303

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers