Hotkeys (Fn) don't work correctly - Samsung QX410 notebook

Bug #694630 reported by Daniel Manrique on 2010-12-26
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

Ubuntu 10.10, udev 162-2.2

On the Samsung QX410 notebook, the Fn+function and cursor hotkeys don't all work correctly.

What works: volume (fn+left/right), num lock (fn+F11), scroll lock (fn+F12), mute (fn+f6)
What doesn't work: brightness (fn+up/down), battery status (fn+f2), euro (fn+f3), switch display (fn+f4), disable backlight (fn+f5), problem solver (fn+f7), quiet mode (fn+f8), disable wireless (fn+f9), disable touchpad (fn+f10).

Expected behavior: The specified action for each key should be performed upon pressing; or, at least, a key event should be registered.

Actual behavior: Upon pressing the keys that don't work, the keyboard starts behaving strangely, sending incorrect keypresses, sometimes gets stuck, and in particular the brightness controls send the brightness either all the way up or down.

Steps to reproduce: 1) Install Ubuntu 10.10. 2) Upon logging in, press any of the misbehaving keys.

How to fix: Add the product name to /lib/udev/rules.d/95-keyboard-force-release.rules, it already contains a rule to enable handling the misbehaving keys, which appear to be common to several Samsung computers, but it has no knowledge of the QX410 and related models such as the QX310 and QX510.

With this fix applied:
1- The brightness up/down, disable keypad, battery status and mute keys work as expected with no further configuration needed.
2- The remaining keys (euro, switch display, disable backlight, problem solver, quiet mode, disable wireless) at least generate key events that can be assigned to specific actions in keyboard shortcuts, they no longer make the keyboard get stuck.

Contents of /sys/class/dmi/id/product_name:
QX310/QX410/QX510/SF310/SF410/SF510

Contents of /sys/class/dmi/id/sys_vendor:
SAMSUNG ELECTRONICS CO., LTD.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: udev 162-2.2
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Sun Dec 26 18:10:18 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: SAMSUNG ELECTRONICS CO., LTD. QX310/QX410/QX510/SF310/SF410/SF510
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-24-generic root=UUID=c89d033b-b088-428d-886e-651bd4bf43f5 ro quiet splash
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: udev
dmi.bios.date: 09/14/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 02MX.M003.20100914.SCY
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: QX310/QX410/QX510/SF310/SF410/SF510
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: 02MX
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr02MX.M003.20100914.SCY:bd09/14/2010:svnSAMSUNGELECTRONICSCO.,LTD.:pnQX310/QX410/QX510/SF310/SF410/SF510:pvr02MX:rvnSAMSUNGELECTRONICSCO.,LTD.:rnQX310/QX410/QX510/SF310/SF410/SF510:rvr02MX:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: QX310/QX410/QX510/SF310/SF410/SF510
dmi.product.version: 02MX
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Daniel Manrique (roadmr) wrote :
Stanislav (shisoik) wrote :

Same fix worked for Samsung SF310. Looks like whole product line QX410/QX510/SF310/SF410/SF510 has the same issue.

Changed in udev (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

This was fixed a while ago, the rule now covers all Samsungs:

ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", RUN+="keyboard-force-release.sh $devpath samsung-other"

Changed in udev (Ubuntu):
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/694630

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers