Can't print in Maverick : docs stay forever in printing queue

Bug #662313 reported by Laurent on 2010-10-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu version : Maverick 10.10
uname -a output : Linux galactica 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:24:00 UTC 2010 i686 GNU/Linux

I can't print in Ubuntu Maverick 10.10 (All worked fine in 10.04)

When I print a document from any app, the document appears in the printing queue, but stays in "waiting" state ("en attente" in french). Even if I wait for a long long long time, it never prints, the printer doesn't react at all.

I tried to send a test print from the Ubuntu printer property window, the test appears in the queue as another doc, but never prints too.

My printer is a USB HP Photosmart C4280.
It seems to be detected since it shows up in printers window. I can read this in /var/log/lpr.log :

Oct 17 18:21:48 galactica udev-configure-printer: add /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.1
Oct 17 18:21:48 galactica udev-configure-printer: add /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.1/usb/lp0

It doesn't seem to be a cups problem, since I can read in /var/log/cups/access_log :

localhost - - [17/Oct/2010:20:17:16 +0200] "POST /printers/Photosmart-C4200-series HTTP/1.1" 200 292 Create-Job successful-ok
localhost - - [17/Oct/2010:20:17:16 +0200] "POST /printers/Photosmart-C4200-series HTTP/1.1" 200 108439 Send-Document successful-ok

There's nothing special to read about in /var/log/cups/error_log

In dmesg, i can read :
[ 11.368424] usblp0: USB Bidirectional printer dev 3 if 1 alt 0 proto 2 vid 0x03F0 pid 0x5C11

Al the HP stuff are installed (hplip, hpijs ...).

Since apport (ubuntu-bug) doesn't work on my system (takes forever collecting info), please ask me for files to attach.

affects: ubuntu → hplip (Ubuntu)
Till Kamppeter (till-kamppeter) wrote :

Can you follow the instructions on https://wiki.ubuntu.com/DebuggingPrintingProblems especially following the sections "USB printer" "CUPS error_log", and "Capturing print job data". Thanks.

Changed in hplip (Ubuntu):
status: New → Incomplete
Laurent (laurent-q) wrote :

Here are the output for the "USB Printer section"

lsusb hangs and doesn't output anything, ctrl-c has no effect.

Laurent (laurent-q) wrote :

Here are the outputs for "Capturing print job" section. The file I tried printing is the text file "usb_printer.txt" I previously attached here. The printout file follows and seems to be OK.

Laurent (laurent-q) wrote :
Laurent (laurent-q) wrote :

My /var/log/cups/error_log file remains empty.

If I'm right, I had nothing special to do in Maverick to get cups errors being logged.

Till Kamppeter (till-kamppeter) wrote :

Laurent, can you attch your /etc/cups/cupsd.conf?

Your usb_printer.txt file shows that the permissions of your printer's USB device files do not get set. For me it looks like a problem of UDEV.

affects: hplip (Ubuntu) → udev (Ubuntu)
Laurent (laurent-q) wrote :

Till, here is my /etc/cups/cupsd.conf.

Thanks for the time you spend on my problem ;)

Laurent (laurent-q) wrote :

Till, I have some great news : after tonight bunch of updates, it prints again. Here are the list of updated packages, in them is the one that caused the problem ;) :

2010-10-19 23:26:07 status installed man-db 2.5.7-4
2010-10-19 23:26:08 status installed libc-bin 2.12.1-0ubuntu7
2010-10-19 23:26:15 status installed libc6 2.12.1-0ubuntu7
2010-10-19 23:26:15 status installed libc-bin 2.12.1-0ubuntu7
2010-10-19 23:27:18 status installed desktop-file-utils 0.16-0ubuntu4
2010-10-19 23:27:19 status installed python-gmenu 2.30.4-0ubuntu1
2010-10-19 23:27:20 status installed menu 2.1.44ubuntu1
2010-10-19 23:27:21 status installed man-db 2.5.7-4
2010-10-19 23:27:21 status installed ureadahead 0.100.0-8
2010-10-19 23:27:22 status installed hicolor-icon-theme 0.11-1
2010-10-19 23:27:23 status installed python-support 1.0.9ubuntu1
2010-10-19 23:27:24 status installed libc-dev-bin 2.12.1-0ubuntu7
2010-10-19 23:27:24 status installed linux-libc-dev 2.6.35-1022.35
2010-10-19 23:27:24 status installed libc6-dev 2.12.1-0ubuntu7
2010-10-19 23:27:25 status installed gconf2-common 2.31.91-0ubuntu3.1
2010-10-19 23:27:25 status installed libgconf2-4 2.31.91-0ubuntu3.1
2010-10-19 23:27:28 status installed google-chrome-unstable 8.0.552.5-r62886
2010-10-19 23:27:46 status installed linux-image-2.6.35-22-generic 2.6.35-22.35
2010-10-19 23:27:46 status installed libudev0 162-2.1
2010-10-19 23:27:48 status installed udev 162-2.1
2010-10-19 23:27:50 status installed dkms 2.1.1.2-3ubuntu1.1
2010-10-19 23:27:50 status installed gconf-defaults-service 2.31.91-0ubuntu3.1
2010-10-19 23:27:54 status installed gconf2 2.31.91-0ubuntu3.1
2010-10-19 23:27:54 status installed gdm-guest-session 0.17
2010-10-19 23:27:55 status installed jockey-common 0.5.10-0ubuntu5.1
2010-10-19 23:27:56 status installed libgpod4 0.7.95-1
2010-10-19 23:27:56 status installed libgpod-common 0.7.95-1
2010-10-19 23:27:56 status installed libgudev-1.0-0 1:162-2.1
2010-10-19 23:27:56 status installed libpoppler7 0.14.3-0ubuntu1.1
2010-10-19 23:27:57 status installed libpoppler-glib5 0.14.3-0ubuntu1.1
2010-10-19 23:27:57 status installed libutouch-grail1 1.0.15-0ubuntu1
2010-10-19 23:27:57 status installed libwebkit-1.0-common 1.2.5-0ubuntu0.10.10.1
2010-10-19 23:27:58 status installed libwebkit-1.0-2 1.2.5-0ubuntu0.10.10.1
2010-10-19 23:27:58 status installed linux-headers-2.6.35-22 2.6.35-22.35
2010-10-19 23:27:59 status installed linux-headers-2.6.35-22-generic 2.6.35-22.35
2010-10-19 23:27:59 status installed poppler-utils 0.14.3-0ubuntu1.1
2010-10-19 23:27:59 status installed gnome-settings-daemon 2.32.0-0ubuntu3
2010-10-19 23:28:00 status installed jockey-common 0.5.10-0ubuntu5.1
2010-10-19 23:28:00 status installed python-central 0.6.15ubuntu2
2010-10-19 23:28:00 status installed jockey-gtk 0.5.10-0ubuntu5.1
2010-10-19 23:28:00 status installed libc-bin 2.12.1-0ubuntu7
2010-10-19 23:28:01 status installed menu 2.1.44ubuntu1
2010-10-19 23:28:09 status installed initramfs-tools 0.98.1ubuntu6

Udev has been updated, so I think that you were right ;)

Thanks again for the time you spent.

Laurent (laurent-q) wrote :

Well finally that was to early to rejoice : I managed to print a file only one time after the update reboot. But I rebooted once and now, I can't print anymore.

It's even worse : the printer doesn't appear immediatly in the printers list when I try to print just after the reboot.
If I reboot with a print job pending, after the reboot, the printer status icon in the notification area takes a long time to appear.

Changed in udev (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Incomplete
status: Incomplete → New
Jack (marcocunhasj) wrote :

I don't know if i have the same problem, but the symptoms look similar. Yesterday (10.04) everything worked fine, but after the upgrade (10.10) i can't print anymore.

I'm using a Hp Laserjet P2015n and a Ricoh Aficio 1022 both with a samba connection.

I get this error message: "Error writing spool: Server packet had invalid SMB signature!"

thanks.

Jack, your problem is not the one described here, but a problem of the "smb" CUPS backend which is a part of Samba. Please report a new bug on the Samba package.

Jack (marcocunhasj) wrote :

I'm also getting this error message: "Session setup failed: NT_STATUS_NO_SUCH_FILE" (this one appears when I try to "print self test page")

Jack, your problem is not the one described here, but a problem of the "smb" CUPS backend which is a part of Samba. Please report a new bug on the Samba package.

Sorry for the duplicate comment. The page was hanging on the first one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers