Ubuntu

Errors (non-fatal) occuring when udev upgraded (to v151-12.3) in TKL-Core v11.x (Lucid based)

Reported by Jeremy Davis on 2010-10-02
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
TurnKey Linux
Fix Released
Medium
Unassigned
11.x
Fix Committed
Medium
Unassigned
12.x
Fix Released
Medium
Unassigned
udev (Ubuntu)
Undecided
Unassigned

Bug Description

This seems to be non-fatal (as I'm yet to have any issues other than the error messages). When upgrading the udev package (to version 151-12.3 which is supplied by Ubuntu lucid-updates repo) my system (under a VM - both in VBox v3.2.0_OSE Ubuntu Lucid and KVM-PVE v1.5) reports these errors:

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.32-22-generic
.: 13: Can't open /scripts/casper-functions
.: 6: Can't open /scripts/casper-functions

When I first upgraded udev (as part of a full apt-get upgrade) my system froze requiring reboot and apt did not work any more after reboot (complained about udev not installed properly and froze again when I tried). But I am not sure whether this is related at all as on subsequent attempts (on a clean install), I only upgraded the udev package alone.

For full details of my experience with this please find a thread here: http://www.turnkeylinux.org/forum/support/20100928/tkl-lucid-core-apt-get-upgrade-freeze-installing-udev-151-121

[update] I have updated this bug as it still affects the current (v11.1) Lucid based release when upgrading to the latest version of udev (udev 151-12.3). It has also been confirmed on hardware (not just in VM - see the TKL forum thread as noted above). It has also been noted as an upstream (Ubuntu) bug, see here: https://bugs.launchpad.net/ubuntu/+source/udev/+bug/674704

Jeremy Davis (jedmeister) wrote :

This bug now invalid due to release of TKL v11.0RC which includes updated version of udev

Changed in turnkeylinux:
status: New → Invalid
Max (xamilien) wrote :

I get the same problem with TKL v11.0RC when setting up udev (151-12.2).

Jeremy Davis (jedmeister) wrote :

Changed the status of this bug to confirmed as further discussion on the TKL forums (http://www.turnkeylinux.org/forum/support/20100928/tkl-lucid-core-apt-get-upgrade-freeze-installing-udev-151-121) confirms that is still an issue for many.

My experience of this bug has only been in virtual environments: KVM (as supplied by ProxmoxVE v1.6 & v1.7) and VirtualBox (as supplied by Ubuntu Lucid - think its v3.2.0?). But one user has stated that they have experienced it on 3 different hardware systems. As I noted in a post the problem doesn't occur in a chroot, even on a system where the base install experiences it.

This bug also affects udev 1.52 (as supplied with TKL v11.0RC)

Changed in turnkeylinux:
status: Invalid → Confirmed
Jeremy Davis (jedmeister) wrote :

This bug is still occurring as of release of stable v11.0 - confirmed after apt-get upgrade on Core-Lucid where udev is upgraded to udev151-12.3. The workaround on the TKL forums is still relevant. I have reposted them for clarity here: http://www.turnkeylinux.org/forum/support/20100928/tkl-lucid-core-apt-get-upgrade-freeze-installing-udev-151-121#comment-6331

Alon Swartz (alonswartz) wrote :

Jedmeister, thanks for following up on this bug.

If someone has time to reproduce this issue on a vanilla Lucid install, then we can post it upstream and hopefully get it fixed. If it's not reproducible on vanilla Lucid, then we can at least narrow it down.

Jeremy Davis (jedmeister) wrote :

John has kindly pointed out an Ubuntu Bug report where it sounds like someone is suffering the same problem with 2 headless servers.

From the Bug report: "I can only reproduce the problem on servers (with sshd, apache2, mysql, ... no dbus). On desktop installations the restart command works fine. I first saw the problem on lucid but it still occurs on maverick."

Bug report: https://bugs.launchpad.net/ubuntu/+source/udev/+bug/674704

John's post on TKL forums: http://www.turnkeylinux.org/forum/support/20100928/tkl-lucid-core-apt-get-upgrade-freeze-installing-udev-151-121#new

Emp.Bob (emp-bob) wrote :

I had the same problem. My System Info: PowerEdge R710 (2.4g Xeon E5530 Dual Processors) with 24GB Ram) running vSphere 4.1 Standard.

starting from a blank VM, using either the ISO or the VMDK version turnkey-core-11.1-lucid-x86.iso and turnkey-core-11.1-lucid-x86-vmdk (both have crashed for me).

'apt-get update', then 'apt-get upgrade' works fine, when I go to do 'apt-get dist-upgrade' includes the udev modules and it hangs during install. I can reproduce this on my setup every time. Sometimes the results are different, and I'm not sure if they're all related or not. Initially I had built a VM and added dhcp3-server to it, but when I used the Webmin interface, it seemed a little flaky, randomly giving me time-outs. flattened VM, and started over. the next time when I went to reboot it after it got hung up, it wouldn't finish booting and crashed on the fs check.

After that I did some reading and someone recomended using aptitude and putting udev on hold, then doing the dist-upgrade. so far, that seems to be working, but I'm not that familiar with ubuntu yet, (just enough to be dangerous) so I'm not sure whats in udev, or if it's something that's going to come back to bite me later on...

-Mike

Diego Xirinachs (fishbone.beat) wrote :

confirming this bug also, I downloaded a new TKL Wordpress appliance and bug exists there also. Workaround does work

Jeremy Davis (jedmeister) wrote :

@Mike, you should be ok to hold udev (I am yet to encounter any issues with it). At this point the updates do not involve any security issues and if it works ok now then it's probably unlikely that it will be a problem in the future. Also you do not need to install aptitude to hold a package (although aptitude is a pretty cool commandline package manager). You can hold udev like this:

echo udev hold | dpkg --set-selections

summary: - Errors (non-fatal) occuring when udev upgraded (to v151-12.1) in TKL-
+ Errors (non-fatal) occuring when udev upgraded (to v151-12.3) in TKL-
Core-Lucid beta
summary: Errors (non-fatal) occuring when udev upgraded (to v151-12.3) in TKL-
- Core-Lucid beta
+ Core v11.x (Lucid based)
description: updated
Changed in udev (Ubuntu):
status: New → Fix Committed
status: Fix Committed → New
Changed in udev (Ubuntu):
status: New → Confirmed
Changed in turnkeylinux:
importance: Undecided → Medium
Jeremy Davis (jedmeister) wrote :

As TKL v12.0 is rebased on Debian (rather than Ubuntu) I'm going to mark this bug as 'Fix Released'.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers