My Laptop special buttons doesnt work

Bug #627890 reported by mahmut on 2010-09-01
52
This bug affects 12 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: acpi-support

Dear dv;

I have sony vaio Vgn-Fw21e , and acpi-support isnt true for me.

Special buttons(scroll lock buttons fn+numlk, av mode buttons, fn f9-f10 zoom option) ,foncontrol , vs.. isnt work.

I add my acpi-dsdt file.

Ps: my english isnt good enough , sorry.

Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: acpi-support 0.136.1
ProcVersionSignature: Ubuntu 2.6.32-24.42-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Sep 1 10:37:25 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=tr_TR.UTF-8
 SHELL=/bin/bash
SourcePackage: acpi-support

mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :

i install ubuntu 10.10 maveric.

Most of buttons work greats , but now brightness key doesnt work true.

Acpi_listen;

fn+f5 (brightness down)
sony/hotkey SNC 00000001 00000010
sony/hotkey SNC 00000001 0000003b

fn+f6 (brightness up)
sony/hotkey SNC 00000001 00000011
sony/hotkey SNC 00000001 0000003b

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this problem and help to improve Ubuntu.

These hotkeys are not handled by acpi-support; reassigning to the udev package instead.

Please see /usr/share/doc/udev/README.keymap.txt.gz for information about troubleshooting hotkey issues.

affects: acpi-support (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: New → Incomplete
mahmut (stratovarius-tt) wrote :

My english isnt good enough and i m not good enough on ubuntu but i try something about u said.

in input/event ' At keyboard ' it doesnt see not working special buttons. Only see working buttons.

Then i try 'module keyboard' now it sees not working key.

scan code: 0x00 key code: fn_f5(brightness down)
scan code: 0x10 key code: fn_f6(brightness up)
scan code: 0x11 key code: fn_f7(switchvideomode)
scan code: 0x12 key code: fn_f9(zoom out)
scan code: 0x14 key code: fn_f10(zoom in)
scan code: 0x15 key code: fn_f12(suspend)
scan code: 0x17 key code: prog1(media button , it is working but sensors detect it)
scan code: 0x20 key code: media(media button , it is working but sensors detect it)

Orig map.txt is empty by the module option.

i try change sony_module and input.h files with wrong keys but nothing change. Then i change the files again orjinal shape.

cat /sys/class/dmi/id/sys_vendor;
Sony Corporation

 cat /sys/class/dmi/id/product_name;
VGN-FW21E

İ add my orjinal udev-db.text.

mahmut (stratovarius-tt) on 2010-10-02
Changed in udev (Ubuntu):
assignee: nobody → mahmut (stratovarius-tt)
status: Incomplete → New
assignee: mahmut (stratovarius-tt) → nobody
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :
mahmut (stratovarius-tt) wrote :

New acpi-dsdt file. i take it on Maverick Meerkat (Ubuntu 10.10)

Martin Pitt (pitti) on 2010-10-10
Changed in udev (Ubuntu):
status: New → Triaged
status: Triaged → In Progress
assignee: nobody → Martin Pitt (pitti)
Mario (diraimondo) wrote :

I'm trying to use the procedure in README.keymap.txt.gz in order to fix the brightness keys (fn+f5 fn+f6) on my Sony Vaio Z21MN. They worked well in Lucid. Other special keys (mute, volume up, volume down,...) seem to work well.

$ /lib/udev/findkeyboards
AT keyboard: input/event2
module: input/event6

$ sudo /lib/udev/keymap input/eventX > /tmp/orig-map.txt

$ sudo /lib/udev/keymap -i input/event6
Press ESC to finish
scan code: 0x00 key code: fn_f5
scan code: 0x10 key code: fn_f6

$ cat /sys/class/dmi/id/sys_vendor
Sony Corporation
$ cat /sys/class/dmi/id/product_name
VGN-Z21MN_B

$ udevadm info --export-db > /tmp/udev-db.txt

I've also tryed to create a keymap:
$ cat /lib/udev/keymaps/module-sony-vaioz
0x00 brightnessdown # Fn+F5
0x10 brightnessup # Fn+F6
$ cat /lib/udev/rules.d/95-keymap.rules
......
LABEL="keyboard_modulecheck"

ENV{DMI_VENDOR}="$attr{[dmi/id]sys_vendor}"
ENV{DMI_VENDOR}=="", GOTO="keyboard_end"

# Sony Vaio Z attempted fix
ENV{DMI_VENDOR}=="Sony*", ATTR{[dmi/id]product_name}=="*VGN-Z21*", ATTRS{name}=="Sony Vaio Keys", RUN+="keymap $name module-sony-vaioz"

ENV{DMI_VENDOR}=="IBM*", KERNELS=="input*", ATTRS{name}=="ThinkPad Extra Buttons", RUN+="keymap $name module-ibm"
ENV{DMI_VENDOR}=="LENOVO*", KERNELS=="input*", ATTRS{name}=="ThinkPad Extra Buttons", RUN+="keymap $name module-lenovo"
ENV{DMI_VENDOR}=="LENOVO*", KERNELS=="input*", ATTRS{name}=="Lenovo ThinkPad SL Series extra buttons", RUN+="keymap $name 0x0E bluetooth"
ENV{DMI_VENDOR}=="ASUS*", KERNELS=="input*", ATTRS{name}=="Asus Extra Buttons", ATTR{[dmi/id]product_name}=="W3J", RUN+="keymap $name module-asus-w3j"
ENV{DMI_VENDOR}=="Sony*", KERNELS=="input*", ATTRS{name}=="Sony Vaio Keys", RUN+="keymap $name module-sony"

# Older Vaios have some different keys
ENV{DMI_VENDOR}=="Sony*", ATTR{[dmi/id]product_name}=="*PCG-C1*|*PCG-K25*|*PCG-F1*|*PCG-F2*|*PCG-F3*|*PCG-F4*|*PCG-F5*|*PCG-F6*|*PCG-FX*|*PCG-FRV*|*PCG-GR*|*PCG-TR*|*PCG-NV*|*PCG-Z*|*VGN-S360*", ATTRS{name}=="Sony Vaio Keys", RUN+="keymap $name module-sony-old"
...........

It seems that the new local keymap is not loaded: the output of 'sudo /lib/udev/keymap input/event6' is unchanged and the keys continue to not work.

I'm available to test experimental changes.

Mario (diraimondo) wrote :
mahmut (stratovarius-tt) wrote :

Thanks Martin Pitt.

Do you need any extra info or log ? i check the bug everyday.

Martin Pitt (pitti) wrote :

Fixed in upstream git, thank you!

Changed in udev (Ubuntu):
status: In Progress → Fix Committed
Tobias Baldauf (technopagan) wrote :

Will this commited fix reach Maverick?

Mario (diraimondo) wrote :

I think this kernel bug is related: https://bugzilla.kernel.org/show_bug.cgi?id=22722

Emil Pavlov (emil-p-pavlov) wrote :

Is there any trivial fix for this in Maverick, as this is really annoying.
I just checked Natty Alpha 1 and the bug was still there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 165-0ubuntu1

---------------
udev (165-0ubuntu1) natty; urgency=low

  * New upstream release. Switch to Ubuntu-ish version number to avoid
    confusing them with Debian's.
    - Allow local users ACL access to raw USB devices of mobile phones.
      (LP: #316215)
    - Allow local users ACL access to raw FFADO devices. (LP: #681755)
    - Keymap fixes. (LP: #625770, #627890, #686662)
  * debian/control, debian/gir1.2-gudev-1.0.install: Rename GIR package to
    gir1.2-* to match the repository version and the recent transition.
    Add conflicts/replaces to old gir1.0-gudev-1.0.
  * debian/udev.postinst: Call udevadm --convert-db when upgrading from a
    version earlier than 165, to update the running database.
 -- Martin Pitt <email address hidden> Sun, 19 Dec 2010 00:15:00 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
Akkana Peck (akkzilla) wrote :

Is the fix in natty now? I'm having trouble getting my brightness keys (Fn-F5 and F6) to be seen on a Vaio TX650. They worked great in lucid and before. Wondering if I should file a new bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.