[FFE] update udev to 161

Bug #620977 reported by Martin Pitt on 2010-08-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt
Maverick
Medium
Martin Pitt

Bug Description

Binary package hint: udev

We never updated udev in maverick, due to some lack of coordination. Scott mentioned that he tried a 157 version, but it failed to boot. I found one possible reason why that failed (the newer version dropped a rules file, and the initramfs hook needed to be updated due to that; it's possible that he missed that the initramfs wasn't rebuilt properly and thus it failed to boot).

We currently have version 151 in maverick, current upstream is 161 (which is also in Debian). Most commits to udev are bug fixes, and we accumulated tons of keymap and other hardware fixes, plus we also finally made DVD-RW detection work (bug 502143 and bug 581925).

Please see http://git.kernel.org/?p=linux/hotplug/udev.git;a=blob_plain;f=NEWS;hb=HEAD for a summary of the changes.

I went through the commits since version 151, and those are not just bug fixes:

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=6b32e8192934619f787c3b5b6f0fe40c32d7d94a

  Merely adds new symlinks, harmless.

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=4dd9b291354e76f34b0d6d7b5c3b28d03a624418

  modem-modeswitch is obsolete and not maintained upstream any more. We need to install usb-modeswitch by default. This needs to be approved/handled in conjunction with bug 521578.

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=1f084fe5811ce251d516a8022f8c7c27d0ef1f53
http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=a89d342dfb45b54e29381af9dbc495bbb2b057af

  We don't use the "all_partitions" and "ignore_remove" options anywhere, and it was a hack in the first place.

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=2d000ed9d85eb6dd8a535e5d5e8f7a5ef52bd794

  Supports kvm related (virtual) hardware for virtio. Just adds new symlinks, harmless.

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=3b529da42586aa430bb0d03800b19dd45552eae1

  New rule option, but a no-op for now since we don't use it.

There are also some commits introducing .system.in files for systemd, but since we use upstart, they don't affect us.

In the interest of keeping up with hardware support I really recommend the upgrade. I can commit to watching out for regressions and dealing with them, I'm one of the udev upstreams.

Martin Pitt (pitti) on 2010-08-20
Changed in udev (Ubuntu Maverick):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I prepared a test package in https://launchpad.net/~pitti/+archive/ppa, which is booting and working fine on my workstation.

Note that it's still very sloppy changelog-wise, and there's still tons of lintian warnings to fix (not due to the new upstream version, it's just the packaging is slightly out of date), I"ll fix that for the real upload.

Changed in udev (Ubuntu Maverick):
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

For the record, usb-modeswitch has been promoted and ack'ed for maverick, see bug 521578. So the new udev version now does not introduce known regressions.

StefanPotyra (sistpoty) wrote :

ACK, FFe approved. Please send an announcement on the mailing list and watch out for regressions.

Changed in udev (Ubuntu Maverick):
status: New → Confirmed
milestone: none → ubuntu-10.10-beta
StefanPotyra (sistpoty) wrote :

(also targetting for beta to get widespread testing, as discussed in the meeting today)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 161+git20100820-1

---------------
udev (161+git20100820-1) maverick; urgency=low

  * New upstream release 161, plus fixes from git head: (LP: #620977)
    - udevadm trigger now defaults to change instead of add.
    - modem modeswitch removed, use usb_modeswitch instead (see LP #521578)
    - NAME= now ignored
    - udevd creates device nodes itself on startup based on modules.udevname
    - default device permission is 0600
    - lots of bug fixes
    - updated keymaps (LP: #271706, #554066, #569815, #592371)
    - update udev(7) to point out naming of rules files (LP: #616108)
    - cdrom_id: fix media state detection of DVD-RW/DVD+RWs (LP: #581925)
    - cdrom_id: fix media state detection on older hardware (LP: #502143)
  * debian/libudev0.symbols: Add new symbols from upstream version.
  * debian/udev.initramfs-hook: Drop 64-device-mapper.rules, it was removed
    upstream.
  * debian/control: Drop obsolete (pre-lucid) Breaks and Conflicts.
  * debian/rules: Replace obsolete dh_clean -k with dh_prep.
  * debian/control: Slightly more generously version libselinux1-dev build
    dependency (thanks lintian).
  * debian/control: Replace obsolete ${Source-Version} with ${binary:Version}.
  * debian/control: Update Standards-Version to 3.9.1.
  * debian/control: Add Homepage field.
 -- Martin Pitt <email address hidden> Sat, 21 Aug 2010 10:07:44 +0200

Changed in udev (Ubuntu Maverick):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers