many laptop models need the same volume-key release quirk

Bug #565459 reported by Kamal Mostafa on 2010-04-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: udev

Many laptop models need the same volume-key release quirk. Currently, two models have identical force-release-maps/ keymap files (dell-studio-1557 and fujitsu-amilo-si1848) and two more need to be added (Mitac LP: #374884 and Coolbox QBook LP: #420473).

I propose replacing the identical force-release-maps/ files with one 'common-volume-keys' file to make adding new models easier.

Note: I do not see any obvious dmidecode commonality between the models needing the quirk (i.e. they do not all share the same BIOS), so I think that it will remain necessary to scan for each model separately in 95-keyboard-force-release.rules.

Changed in udev (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
Kamal Mostafa (kamalmostafa) wrote :

Attached patch to (udev 151-11) implements the force-release-maps/common-volume-keys scheme as described in the bug summary.

udev (151-12~kamal~volkeys0) lucid; urgency=low

  * common-volume-keys: Unite laptop models needing common volume-key release
    quirk; no functional changes. (LP: #565459):
    - add force-release-maps/common-volume-keys (correct up/down comments)
    - remove force-release-maps/dell-studio-1557 (Dell Studio 1557/1558)
    - remove force-release-maps/fujitsu-amilo-si1848 (Fujitsu Amilo 1848+u)

 -- Kamal Mostafa <email address hidden> Sat, 17 Apr 2010 10:05:52 -0700

Changed in udev (Ubuntu):
assignee: Kamal Mostafa (kamalmostafa) → nobody
Martin Pitt (pitti) wrote :
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 151-12

---------------
udev (151-12) lucid; urgency=low

  * Cherrypick keymap fixes from trunk:
    - Unite laptop models needing common volume-key release quirk. Many laptop
      models need the same volume-key release quirk. Currently, two models
      have identical force-release-maps/ keymap files (dell-studio-1557 and
      fujitsu-amilo-si1848) and two more need to be added (Mitac and Coolbox
      QBook). This replaces the identical force-release-maps files with one
      'common-volume-keys' file to make adding new models easier.
      (LP: #565459)
    - Add force-release quirk for Coolbox QBook 270-02 (LP: #420473)
    - Add force-release quirk for Mitac 8050QDA (LP: #374884)
 -- Martin Pitt <email address hidden> Mon, 19 Apr 2010 10:58:13 +0200

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
Paul BROWN (frozenzia) wrote :

Erm - hey, I seem to have a similar issue here with a Fujitsu-Siemens Amilo LI 1818 -- what's the best way of getting this fixed and/or added to this list? And/or I presumably should test this in some way to determine if it really is this problem? The issue is with the volume keys, and I *think* that's all. At least the brightness keys seem alright, and I haven't checked the others yet. All work-around tips are welcome as well, and please direct me to the proper place to rtfm if that's applicable. Thanks!

Changed in udev (Ubuntu):
assignee: Martin Pitt (pitti) → mrDoctorWho (mrdoctorwho)
Martin Pitt (pitti) on 2012-09-20
Changed in udev (Ubuntu):
assignee: mrDoctorWho (mrdoctorwho) → Martin Pitt (pitti)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers