[lucid] not all hotkeys run in asus eeepc 1001ha

Bug #558628 reported by Xan on 2010-04-08
This bug affects 7 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Nominated for Lucid by hubologista

Bug Description

I have an asus eeepc 1001ha. Some hotkeys work and other don't.

The hotkeys that don't run are:

* Fn + F3 (disable touchpad)
* Fn + F10 (no sound)
* Fn + F11 (low volume)
* Fn + F12 (increase volume)

I found this [https://bugs.launchpad.net/ubuntu/+source/udev-extras/+bug/383798] bug but I think it's a bit different because I use lucid beta in my system, so the kernel is different.

Linux gerret 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux

I include a lshw file output for debugging....

Thanks a lot,

Xan (dxpublica) wrote :
Xan (dxpublica) wrote :
tags: added: lucid
Monkey (monkey-libre) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in udev.
(With many applications, you can report a future bug directly on the appropriate package by opening the application's "Help" menu and choosing "Report a Problem". https://wiki.ubuntu.com/ReportingBugs)

affects: ubuntu → udev (Ubuntu)
Xan (dxpublica) wrote :

Thanks Monkey for doing the triaged of the package. I did not know what packages controls the hotkeys. It's a much technical than knowing that firefox is the package responsable of the crash of firefox ;-)

For the other hand, what is the output you want to fix this bug? Perhaps /var/log/udev? It seems that [https://wiki.ubuntu.com/DebuggingUdev] suggests that. But really I don't know.


Monkey (monkey-libre) wrote :

Please see the next link https://wiki.ubuntu.com/Hotkeys/Troubleshooting

Thank You for making Ubuntu better.

Changed in udev (Ubuntu):
status: New → Incomplete
Xan (dxpublica) wrote :

Thanks for the link. I tested Fn + F3, Fn + F10, Fn + F11 and Fn + F12. Some output:

1) With

xev | sed -n 's/^.*state \([0-9].*\), keycode *\([0-9]\+\) *\(.*\), .*$/keycode \2 = \3, state = \1/p'

no hotkeys is shown.

2) /lib/udev/findkeyboards
AT keyboard: input/event5

3) I will attach the output file of sudo /lib/udev/keymap input/event5 > /tmp/orig-map.txt
4) sudo /lib/udev/keymap -i input/event5 does not shown no one of these hotkeys (nothing appears)
5) cat /sys/class/dmi/id/sys_vendor
ASUSTeK Computer INC.
6) $ cat /sys/class/dmi/id/product_name
7) I will atatch the file udevadm info --export-db > /tmp/udev-db.txt

I hope this serves you.

Xan (dxpublica) wrote :
Xan (dxpublica) wrote :
Xan (dxpublica) wrote :
Xan (dxpublica) wrote :

And finally acpi_listen does displays NOTHING when I press this hotkeys.
So, according to https://wiki.ubuntu.com/Hotkeys/Troubleshooting, it seems this is a kernel bug.
B4t Fn+F7 works but acpi_listen displays nothing too.

So I don't know.


Monkey (monkey-libre) on 2010-04-11
Changed in udev (Ubuntu):
status: Incomplete → New
Xan (dxpublica) wrote :

Any more information for marking as confirmed?


Hi, I have the same hardware (Asus Eeepc 1001HA), and upgraded from karmic to UNR lucid lynx.
Same thing for me, Fn+F3/F10/F11/F12 do not work.

Moreover, Fn+F2 (enable/disable wifi) does not work either.

All these Fn combinations were working well with Karmic.


A bit more testing : Fn+F8 is not working either. It is supposed to switch between LCD/ext monitor.


Xan (dxpublica) wrote :

Thanks, Laurent. I could not test Fn+F8 because I had not any extra monitor. ;-)
What information is needed to mark this bug as confirmed?


hubologista (thanatospl) wrote :

Same thing for me , same 1001ha hardware ...

Xan (dxpublica) on 2010-05-05
Changed in udev (Ubuntu):
status: New → Confirmed

One more hotkey that is not working (but it was not working with karmic either) : the upper left key which is I guess supposed to disable/enable the touchpad.

Xan (dxpublica) wrote :

@Laurent: can you follow the guide https://wiki.ubuntu.com/Hotkeys/Troubleshooting and put the corresponding output of this key?


@Xan : no output for this key :-( even with acpi_listen.


Sam St. James (samsaintjames) wrote :

Maybe you want to check this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/505452/comments/41. This solution worked fine for me (I actually had no acpi support whatsoever after the dist-upgrade to lucid).

Oreste (angelo-benoit) wrote :

Yes Sam St. James , the solution worked on my eeepc :)

Thanks Sam, the solution also worked for me :-)
All reported hotkeys are now working well !

krul (krul) wrote :

Same problems for me with 10.04 and Asus 1001HA. Solution referred in post #19 works for me too.

Xan (dxpublica) wrote :

So, it seems that changing the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux"

to "/etc/default/grub"

seems to work. Can anyone fix this release for this information? It were beatiful to have a solution out-the-.box


Xan (dxpublica) wrote :

Sorry, but this solution does not work for me. The same results.

Xan (dxpublica) wrote :

Any progress on this bug? What can I do for it were triaged?


Asbjørn Thegler (ath88) wrote :

The fix worked on my girlfriends Asus Eee PC R101. Shes enjoying the UNE 10.4.

Xan (dxpublica) wrote :

Why this is a duplicate of bug #505452? What are the technical reasons?


To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers