[Lucid Alpha3][khk-004 testcase failed] Click on Internet hotkey opens Home folder on Acer Laptops

Bug #536914 reported by Sergio Zanchetta on 2010-03-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: udev

khk-004 testcase failed
http://testcases.qa.ubuntu.com/Plans/LaptopTesting

If I click on Internet hotkey it opens the Home folder.
It should open Firefox.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 10 21:13:14 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100308)
MachineType: Acer TravelMate 6593
Package: udev 151-5
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   product info: "O2Micro", "SmartCardBus Reader", "V1.0", ""
   manfid: 0xffff, 0x0001
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   5.0V 16-bit PC Card
   Subdevice 0 (function 0) [unbound]
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: udev
Uname: Linux 2.6.32-15-generic i686
dmi.bios.date: 08/14/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.04
dmi.board.name: FourPeaks
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.04:bd08/14/2008:svnAcer:pnTravelMate6593:pvr0100:rvnAcer:rnFourPeaks:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: TravelMate 6593
dmi.product.version: 0100
dmi.sys.vendor: Acer

Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :
Sergio Zanchetta (primes2h) wrote :

If I click on Internet key when firefox window is focused it opens the firefox homepage correctly.

If the focus is on the Desktop, it opens the Home folder.

Sergio Zanchetta (primes2h) wrote :

Obviously if I click it when Firefox is closed, it opens Home folder.

Simona Diatto (simona-diatto) wrote :

It also affects Acer Aspire 1640.

Laptop report: https://wiki.ubuntu.com/Testing/Laptop/Reports/AcerAspire1640

Changed in udev (Ubuntu):
importance: Undecided → Low
Changed in udev (Ubuntu):
status: New → Confirmed
summary: [khk-004 testcase failed] Click on Internet hotkey opens Home folder on
- Acer TM 6593G
+ Acer Laptops
summary: - [khk-004 testcase failed] Click on Internet hotkey opens Home folder on
- Acer Laptops
+ [Lucid Alpha3][khk-004 testcase failed] Click on Internet hotkey opens
+ Home folder on Acer Laptops
Sergio Zanchetta (primes2h) wrote :

sergio@sergio-desktop:~$ sudo /lib/udev/keymap -i input/event3
Press ESC to finish
scan code: 0xB2 key code: homepage

which is wrong, should be www.

Sergio Zanchetta (primes2h) wrote :

sergio@sergio-desktop:~$ xev | sed -n 's/^.*state \([0-9].*\), keycode *\([0-9]\+\) *\(.*\), .*$/keycode \2 = \3, state = \1/p'
keycode 180 = (keysym 0x1008ff18, XF86HomePage), state = 0x0
keycode 180 = (keysym 0x1008ff18, XF86HomePage), state = 0x0

P.S.:Another strange thing if that it printed it twice.

Sergio Zanchetta (primes2h) wrote :

keycode should be 158

sergigno@entropy:~$ xmodmap -pke | grep XF86WWW
keycode 158 = XF86WWW NoSymbol XF86WWW NoSymbol XF86WWW

Changed in udev (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

Please exercise the steps in /usr/share/doc/udev/README.keymap.txt.gz, "Fixing broken keys" and find out the scan code for that key. Thanks!

Changed in udev (Ubuntu):
importance: Low → Medium
status: Triaged → Incomplete
Sergio Zanchetta (primes2h) wrote :

In comment #9 I already find out the scan code:
scan code: 0xB2 key code: homepage

In attachment you have the current mapping too.

Sergio Zanchetta (primes2h) wrote :

From /usr/include/linux/input.h should be:

KEY_WWW 150 /* AL Internet Browser */

Sergio Zanchetta (primes2h) wrote :

In /lib/udev/keymaps/ there are some acer-related files:
acer
acer-aspire_5720
acer-aspire_5920g
acer-aspire_6920
acer-travelmate_c300

Is there a way to understand which I am using?

This bug affects both Acer TravelMate 6593G and Acer Aspire 1640

Sergio Zanchetta (primes2h) wrote :

Only acer-aspire_5920g contains 0xB2 code this way:

0xB2 www

Sergio Zanchetta (primes2h) wrote :

I read /usr/share/doc/udev/README.keymap.txt.gz

There is only a thing I can't understand.

scan codes are reported this way: 0xXX (e.g. 0xB2)

keymaps in
/usr/include/linux/input.h
are reported in (seems to be) decimal format. (e.g. #define KEY_WWW 150 /* AL Internet Browser */)

They seem to be unrelated, what's the link between them?

Sergio Zanchetta [2010-03-24 14:02 -0000]:
> In /lib/udev/keymaps/ there are some acer-related files:
> acer
> acer-aspire_5720
> acer-aspire_5920g
> acer-aspire_6920
> acer-travelmate_c300
>
> Is there a way to understand which I am using?

/lib/udev/rules.d/95-keymap.rules maps DMI information (vendor/product
names) to keymap names.

> This bug affects both Acer TravelMate 6593G and Acer Aspire 1640

Neither of those are in the udev rules, so we just need a new rule.

Can you please send the DMI information for the Aspire?

Thanks!
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Martin Pitt (pitti) wrote :

Sergio Zanchetta [2010-03-24 15:07 -0000]:
> scan codes are reported this way: 0xXX (e.g. 0xB2)
>
> keymaps in
> /usr/include/linux/input.h
> are reported in (seems to be) decimal format. (e.g. #define KEY_WWW 150 /* AL Internet Browser */)
>
> They seem to be unrelated, what's the link between them?

Indeed they have nothing to do with each other. scan codes are
hardware dependent and just enumerate the hardware keys. key codes
define a semantics for a particular key and provide an identifier for
them. The kernel and udev has to keep mappings from scan codes to key
codes on a per-machine basis.
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Martin Pitt (pitti) wrote :

Sergio Zanchetta [2010-03-24 14:02 -0000]:
> This bug affects both Acer TravelMate 6593G and Acer Aspire 1640

Well, all the other Acers have reasonable product IDs, so I just
assume "Aspire 1640" will be correct. Please yell if not.

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Martin Pitt (pitti) wrote :
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Incomplete → Fix Committed
Sergio Zanchetta (primes2h) wrote :

cat /sys/class/dmi/id/sys_vendor
Acer

cat /sys/class/dmi/id/product_name
TravelMate 6593

Simona, could you please run the two above and report the output here please?

@Martin.
I found out that other two keys are broken.

1) scan code: 0xEE key code: brightnessup

it's the lock screen key and it should be addressed to
#define KEY_COFFEE 152 /* AL Terminal Lock/Screensaver */

2) scan code: 0xF5 key code: presentation

#define KEY_PRESENTATION 0x1a9 /* AL Presentation App */

does nothing when clicked but it should open OpenOffice.org Presentation

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 151-6

---------------
udev (151-6) lucid; urgency=low

  * Merge some fixes from GIT HEAD:
    - key release quirk for Fujitsu Amilo 1848+u (LP: #530089)
    - key release quirk for Samsung Q210/P210 (LP: #530093)
    - key maps for Acer TravelMate 6593G and Acer Aspire 1640 (LP: #536914)
    - Decrease buffer size when advancing past NUL byte, to fix a buffer
      overflow the buffer if space is tight.
    - udev-acl: Correctly handle ENV{ACL_MANAGE}==0
    - input_id: Fix linking
    - firmware: fix possible segfault when firmware device goes away while
      loading
    - Fix switching Logitech bluetooth adapters into HCI mode. (LP: #444420)
    - cdrom_id: Open non-mounted optical media with O_EXCL. This should
      prevent confusing drives during CD burning sessions.
 -- Martin Pitt <email address hidden> Wed, 24 Mar 2010 18:47:51 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

1) scan code: 0xEE key code: brightnessup

it's the lock screen key and it should be addressed to
#define KEY_COFFEE 152 /* AL Terminal Lock/Screensaver */

Reopening for this, committed upstream: http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=43d0824

2) scan code: 0xF5 key code: presentation

#define KEY_PRESENTATION 0x1a9 /* AL Presentation App */

does nothing when clicked but it should open OpenOffice.org Presentation

That's known. X.org does not get along with key codes > 255 unfortunately, so you can only use these keys with non-X programs (e. g. LIRC).

Changed in udev (Ubuntu):
status: Fix Released → Fix Committed
Sergio Zanchetta (primes2h) wrote :

1) "Fn+F2" hotkey should open help but it doesn't.

scan code: 0xA5 key code: help

Should be addressed to:
#define KEY_HELP 138 /* AL Integrated Help Center */

2) There is a Sync key.
scan code: 0xF9 key code: f23

Where could it be addressed? Ubuntu One sync? Gnome-pilot?

3) In this keyboard there are also two specific keys (not hotkeys) for Euro and Dollar.

scan code: 0xB3 key code: euro

scan code: 0xB4 key code: dollar

They should be addressed to
#define KEY_EURO 0x1b3
#define KEY_DOLLAR 0x1b2

respectively, but they are > 255 so I think we can do nothing.

But I have a question about this.
In this keyboard there is another Euro symbol under the "E" letter. It works with "AltGr+E".
Why this can be correctly addressed? Is there anything we can do for the keys above (Euro and Dollar symbols)?

Martin Pitt (pitti) wrote :

Sergio,

all of those three (help, euro, dollar) are already correct on your system (http://launchpadlibrarian.net/41837474/orig-map.txt), so no need to change the udev rules further to get correct key codes. GNOME etc. would need to be fixed to actually react to those keys. You should be able to assign them to something useful in the keyboard shortcuts control-center applet.

Sergio Zanchetta (primes2h) wrote :

Martin, thanks for your explanation.
Do you have any hint about the package to address to have them assigned permanently?
In this way I can open a new bug about the issue,

That's all. I reported all I could. Simona told me his laptop is broken, so you can go on.

BTW: Any hint about 2) (sync) too? It's the same as help, euro, dollar?

Thank you very much.

Martin Pitt (pitti) wrote :

Sergio Zanchetta [2010-03-25 22:14 -0000]:
> Martin, thanks for your explanation.
> Do you have any hint about the package to address to have them assigned permanently?
> In this way I can open a new bug about the issue,

gnome-settings-daemon is a good general fallback. For some keys there
are specialized packages (like gnome-power-manager), but that can be
discussed in the bug.

> BTW: Any hint about 2) (sync) too? It's the same as help, euro, dollar?

It is assigned to "F23", so you can assign it to a custom launcher in
the keyboard prefs if you want. We won't do a default assignment of
this, though, since "F23" does not have a specific semantics.

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Sergio Zanchetta (primes2h) wrote :

Ok, thanks for the explanation.
I think it's ok now.

You can go through now.
Thanks again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 151-7

---------------
udev (151-7) lucid; urgency=low

  * Fix key map for Acer TravelMate 6593G and Acer Aspire 1640. (From GIT
    HEAD). (LP: #536914)
  * extras/cdrom_id/60-cdrom_id.rules: Probe hd[a-z] as well, to cover CD
    drives on platforms (like powerpc) which still use IDE driver, like
    ide-pmac. (LP: #534912)
 -- Martin Pitt <email address hidden> Mon, 29 Mar 2010 17:28:34 +0200

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers