Udev fails to load correct Xilinx firmware

Bug #492018 reported by Nils Ole Tippenhauer
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

This is a bug report including workaround/fix taken from the Ubuntu forums (http://ubuntuforums.org/showthread.php?t=1307574)

I use a Xilinx platform cable 2 to talk to an FPGA. Before updating to 9.10, this worked based on libusb and the other components. After updating, the cable did not respond to my commands any more. Notice that all directly related configuration files were unchanged, as well as the firmware images to be loaded initiated by Udev. As suggested in the forum post, the following solved this problem: In /etc/udev/rules.d/xusbdfwu.rules, change $TEMPNODE to $tempnode. After this change, the cable behaved correctly.

I can only assume that this change was necessary due tochanges in Udev, and might affect other devices as well. This is why I am filing this bug report.

ProblemType: Bug
Architecture: i386
CustomUdevRuleFiles: 45-libnjb5.rules xusbdfwu.rules.back z60_usrp.rules 10-vboxdrv.rules 10-usrp.rules libmtp.rules xusbdfwu.rules.~1~ aiptek.rules 45-libmtp7.rules 65-libmtp.rules 50-virtualbox-ose.rules xusbdfwu.rules
Date: Thu Dec 3 19:03:01 2009
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 2007ZE1
Package: udev 147~-6.1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=8c954170-b093-41aa-b649-b3737c43fccd ro quiet splash
ProcEnviron:
 LANGUAGE=de_CH.UTF-8
 PATH=(custom, user)
 LANG=de_CH.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: udev
Uname: Linux 2.6.31-15-generic i686
XsessionErrors:
 (evince:2317): EggSMClient-WARNING **: Could not load SM state file '/home/not/.config/session-state/evince-1258630024.desktop': No such file or directory
 (polkit-gnome-authentication-agent-1:2345): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 06/07/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 79ETD4WW (2.14 )
dmi.board.name: 2007ZE1
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr79ETD4WW(2.14):bd06/07/2007:svnLENOVO:pn2007ZE1:pvrThinkPadT60:rvnLENOVO:rn2007ZE1:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2007ZE1
dmi.product.version: ThinkPad T60
dmi.sys.vendor: LENOVO

Revision history for this message
Nils Ole Tippenhauer (noleti) wrote :
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

/etc/udev/rules.d/xusbdfwu.rules is listed as a custom rule file you have created, and as given in the Forums it is quite simply wrong.

Changed in udev (Ubuntu):
status: New → Invalid
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Without knowing more, it should probably look more like:

SUBSYSTEM=="usb", ACTION=="add", ATTR{idVendor}=="03fd", ATTR{idProduct}=="0007", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusbdfwu.hex -D %N"

Revision history for this message
Nils Ole Tippenhauer (noleti) wrote :

Thanks for the feedback Scott, I rtfm now and found it in the manpage as well. The reason why I asked was that (for me) it worked before with uppercase $TEMPNODE and after upgrading it does not any more. The original rule is provided by Xilinx, so I wanted to be sure it is their fault.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers