doesn't recognize cd audio (tracks)

Bug #490925 reported by david tourrel on 2009-12-01
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)

Bug Description

Binary package hint: devicekit-disks

~$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

!! (this is an upgraded version from 9.04 o 9.10) !!


~$ apt-cache policy devicekit-disks
  Installé : 007-2ubuntu3
  Candidat : 007-2ubuntu3
 Table de version :
 *** 007-2ubuntu3 0
        500 karmic/main Packages
        100 /var/lib/dpkg/status


I still have a problem with cdaudio recognition.
From a cdaudio drive only.
I have two devices, one is cd drive the other is a dvd(w) drive.
When i put a audio cd devicekit-disks doesn't show the number of track even if the dvd drive do.

So, maybe this is the problem of "gnome" recognition.

Any application which has migrated from hal to devicekit doesn't see any cdaudio.
The others (like banshee) do.

ProblemType: Bug
Architecture: i386
Date: Tue Dec 1 18:09:01 2009
DistroRelease: Ubuntu 9.10
MachineType: Micro-Star Inc. MS-6566E
Package: devicekit-disks 007-2ubuntu3
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-15-generic root=UUID=aa147dfa-8967-4e87-8b8e-ce6ae6d0b0b3 ro splash quiet
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: devicekit-disks
Uname: Linux 2.6.31-15-generic i686 04/02/01
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 07.00T MS-6566E
dmi.board.vendor: Micro-Star Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: 0123ABC
dmi.chassis.type: 3
dmi.chassis.vendor: Uknown Chassis Manufacture
dmi.chassis.version: Version 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr07.00T:bd04/02/01:svnMicro-StarInc.:pnMS-6566E:pvr1.0:rvnMicro-StarInc.:rnMS-6566E:rvr1.0:cvnUknownChassisManufacture:ct3:cvrVersion1.00: MS-6566E
dmi.product.version: 1.0
dmi.sys.vendor: Micro-Star Inc.

david tourrel (flx-foo) wrote :
sverris (kunstenaar) wrote :

I have apparently the same problem with Audio-CDs after the upgrade to Xubuntu-Karmic. Tried various players and CDs. CDs are not mounted anymore and cannot be read by VLC, gxine and videoplayer. Then, after reading this bugreport, I installed banshee, and banshee sees the CDs and plays them without problems...

Martin Pitt (pitti) wrote :

Works here, so I need more information from you.

Please insert an audio CD into the drive, and then copy&paste the output of

  gvfs-mount -li
  sudo /lib/udev/cdrom_id /dev/sr0

(This is for the Asus drive; if you use the Pioneer drive, use "sr1" instead)


affects: devicekit-disks (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: New → Incomplete
summary: - devicekit still doesn't recognize cd audio (tracks)
+ doesn't recognize cd audio (tracks)
Martin Pitt (pitti) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in udev (Ubuntu):
status: Incomplete → Invalid

I'm not shure if the Problem is the same. When I put an Audio-CD in AFTER I've ejected an Data-CD, it isn't recognized.

This is gvfs-mount -li after ejecting the Data Disk and putting the Audio-CD in:

gvfs-mount -li
Drive(0): CD/DVD-Laufwerk
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
   unix-device: '/dev/sr1'
  themed icons: [drive-optical] [drive]
  Volume(0): Audio-CD
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
     unix-device: '/dev/sr1'
    themed icons: [media-optical-audio] [media-optical] [media]
Drive(1): 320 GB Festplatte
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
   unix-device: '/dev/sdb'
  themed icons: [drive-harddisk-usb] [drive-harddisk] [drive]
  Volume(0): USB-HD
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
     uuid: '78ACBAD7ACBA8EDE'
     unix-device: '/dev/sdb5'
     label: 'USB-HD'
    themed icons: [drive-harddisk-usb] [drive-harddisk] [drive]
    Mount(0): USB-HD -> file:///media/USB-HD
      Type: GProxyMount (GProxyVolumeMonitorGdu)
      x_content_types: x-content/win32-software
Drive(2): CD/DVD-Laufwerk
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
   unix-device: '/dev/sr0'
  themed icons: [drive-optical] [drive]
Mount(1): Expansion -> file:///media/cdrom
  Type: GProxyMount (GProxyVolumeMonitorGdu)
  x_content_types: x-content/win32-software

As you can see, the Data-CD (Expansion) is still listed. It shows still on the desktop but it is definitly not in the Drive. I also noticed that there is an unreadable Folder with the Name "Expansion_" in /media.

sudo /lib/udev/cdrom_id /dev/sr1


And sorry, this is on Lucid.

Martin Pitt (pitti) wrote :

Thorsten, do you actually have two CD-ROM drives? Your debug data looks like the first drive (sr0) is empty and the second one (sr1) has an audio CD.

Martin Pitt (pitti) wrote :

Oh, and the actual drives are supposed to be shown in the Places menu and computer location in the file browser. You just shouldn't have an icon on the desktop any more. In this situation, can you please give the output of "mount"?

Ok, this is what I did now:

1. Put in "Diablo2 Expansion CD"
2. After automount, I've ejected it
3. Icon stays on the Desktop, is also shown under places
4. Put in Audio-CD


/dev/sda6 on / type ext4 (rw,noatime,nodiratime,data=writeback,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda7 on /home type ext4 (rw,noatime,nodiratime,data=writeback)
/dev/sda1 on /windows type vfat (rw,utf8,umask=007,gid=46)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/nordlicht/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=nordlicht)
/dev/sr1 on /media/cdrom type iso9660 (ro,noexec,nosuid,nodev,user=nordlicht)

You are right, I have to CD-ROM drives. One is internal (Notebook) and isn't used, the main drive is the external LG-USB-CD/DVD-ROM-Drive.

Sorry, of course I've meant "two" drives, not "to".

Hello Thorsten,

Thorsten Reinbold [2010-06-02 13:02 -0000]:
> 2. After automount, I've ejected it

Eject with the hardware button on the drive, or through the eject icon
in the file browser? Does it make a difference?

Can you please get back to this situation until the automount, then
open a terminal and copy&paste the following commands:

  udevadm monitor -e --udev > /tmp/udev.log 2>&1 &
  udisks --monitor-detail > /tmp/udisks.log 2>&1 &
  gvfs-mount -oi > /tmp/gvfs.log

Then eject the CD, wait a couple of seconds, and close the terminal
(this should kill those three monitors)

Then please attach /tmp/udev.log, /tmp/udisks.log, and /tmp/gvfs.log
here. Thanks!

I've mostly ejected the CD through the hardware button (easier) but you are right: it makes a difference. Using the eject-command, it works how it should.

I've attached the log-files.

Martin Pitt (pitti) wrote :

Hm, so this looks increasingly confusing. udev.log is empty, udisks.log doesn't have an event where the media gets removed (well, perhaps this is the bug..), and gvfs shows that the volume goes away, but not the mount. Even worse, it shows that the entire _drive_ gets disconnected, which shouldn't happen in this case (it's like pulling out an USB stick, or the cable from an USB CD-Drive).

Can you please attach /var/log/kern.log after this happens? Thanks!

Martin Pitt (pitti) wrote :

Also, at this point it makes sense to report a new bug against udisks, since this one is for something else, and closed already. Thanks!

Here it is. The last entries seeming to be interesting.

Martin Pitt (pitti) wrote :

Thorsten Reinbold [2010-06-02 14:18 -0000]:
> Here it is. The last entries seeming to be interesting.

Indeed! That explains why the devices suddenly disappear completely.
Can you please do "ubuntu-bug linux" and attach this kernel log to
that new bug?


Martin Pitt |
Ubuntu Developer ( | Debian Developer (

I will do this, but I guess it would be good Idea to use the original Lucid Kernel 2.6.32 for this? At the moment I'm running 2.6.34 due to problems with my Radeon-Card. But I definitly know that the behavior is the same. Will do this within the next hour. Thanks for your help! ;)

Martin Pitt (pitti) wrote :

Thorsten Reinbold [2010-06-02 14:59 -0000]:
> I will do this, but I guess it would be good Idea to use the original
> Lucid Kernel 2.6.32 for this? At the moment I'm running 2.6.34 due to
> problems with my Radeon-Card. But I definitly know that the behavior is
> the same. Will do this within the next hour. Thanks for your help! ;)

In fact, the kernel team appreciates a lot if you test stuff on newer
kernels, too.

Ok, good to know. Thanks!

Completly forgotten:

here is the new Bug:

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers