hotkey support for fujitsu siemens amilo m7400 laptop

Bug #48547 reported by Michael on 2006-06-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: hotkey-setup

Fujitsu Siemens Amilo M7400 laptops have hotkeys which can be enabled with the acerhk module.

The keyscodes of the keys:
0xe0 0x13 0xe0 0x93
0xe0 0x6c 0xe0 0xec
0xe0 0x32 0xe0 0xb2
0xe0 0x1f 0xe0 0x9f
0xe0 0x17 0xe0 0x97

What the keys are supposed to do:
The first is a switch for the wireless network card (i.e. it should trigger "modprobe fsam7400 radio=1" or "rmmod fsam7400", fsam7400 is the module one needs to switch on the wlan card). The second one starts your favourite mail application, the third your favourite webbrowser, and the last two keys are labeled "P1" and "P2". Something should pop up to let me configure what I want for those ;-)

How to identify the laptop:
Manufacturer is "FUJITSU SIEMENS", product name is "AMILO M", system version "-1".

Timothy Smith (tas50) wrote :

Can you test this on Dapper 6.06.1 or Edgy Beta 1 so we can see if the bug still exists?

Michael (gibbsnich) wrote :

I finally made the update to 6.10 but it still doesn't work.

Michael (gibbsnich) wrote :

Maybe I should add a link to the fsam7400 module:
http://linux.zwobbl.de/pub/fsam7400-0.5.1.tgz

Paul Sladen (sladen) wrote :

This module searches BIOS space for a 4-byte signature and then does a call to this address with:

  ax = 0x9610
  bl = 0x35
  bh = 0x00 (switch off), 0x01 (switch on), 0x02 (check if enabled in BIOS)

and states that it was produced from reverse engineering 'wbutton.sys' for a 'Fujitsu Siemens Amilo M 7400' laptop. Hopefully this BIOS call might actually be exposed through ACPI instead.

Paul Sladen (sladen) wrote :

#setkeycodes e013 $KEY_??? #Wireless
#setkeycodes e06c $KEY_MAIL (already mapped, will work out of box)
#setkeycodes e032 $KEY_WWW (already mapped, will work out of box)
setkeycodes e01f $KEY_PROG1
setkeycodes e017 $KEY_PROG2

FUJITSU SIEMENS*)
case "$name" in
    AMILO*M*)
    . /usr/share/hotkey-setup/fujitsu-siemens-amilo.hk
    ;;
esac
;;

Changed in hotkey-setup:
importance: Medium → Low
status: Unconfirmed → Confirmed
schnollk (schnollk) wrote :

some additional information:

Specs at fujitsu-siemens.co.uk with, among others, photos and keys explainations:

http://www.fujitsu-siemens.co.uk/rl/servicesupport/techsupport/lifebook/Amilo%20M/Amilo_M_x4.htm

ubuntuforums thread on this very laptop model:
http://ubuntuforums.org/showthread.php?t=189540

schnollk (schnollk) wrote :

Even after an upgrade to/fresh install of intrepid hotkeys other than the main ones, i.e. mute, suspend, volume, don't work. Even though amilo M 7400 is a fairly old notebook it's still very usable and smooth to use. It's a pitty to see this bug still persists. I'll add some additional info below with hope for someone with more insights has a few minutes to spare to implement this. I'm happily willing to test if needed!

Kernel driver reported to work but seamingly unmaintained: http://www.cakey.de/acerhk/ (package acerhk-source)

debianforum.de (in english) on Amilo M 7400, section "The multimedia buttons", with keycodes http://wiki.debianforum.de/DebianGNULinuxOnFujitsuSiemensAmiloM7400. The only thing, it seams, I don't know how to do, yet, is what to do with package acerhk-source to be able to use hotkey-setup. Thus thankfull for hints so I can test and report back!

legolas558 (legolas558) wrote :

I have just installed Intrepid and I can report that all composite keys do work, but multimedia keys are not working.

I have had them working in the past, except the wireless button (1st multimedia key).

I would like the wireless button to work, possibly by loading the fsam7400 module directly

Steve Langasek (vorlon) wrote :

From what I can see, this is simply a question of mapping the remaining keys in udev-extras.

affects: hotkey-setup (Ubuntu) → udev-extras (Ubuntu)
Changed in udev-extras (Ubuntu):
importance: Low → Medium
status: Confirmed → Triaged
Martin Pitt (pitti) on 2009-07-18
affects: udev-extras (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Fixed upstream in commit 6e40a05.

Changed in udev (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 146-1

---------------
udev (146-1) karmic; urgency=low

  * New upstream release:
    - udevadm trigger "--retry-failed" replaced by "--type=failed"
    - RUN "ignore_error" option replaced by "fail_event_on_error"
    - Added HP Presario 2100 keymap. LP: #20223.
    - Added more keymap coverage for Compaq Evo models. LP: #35382.
    - Added Fujitsu Amilo M keymap. LP: #48547.
    - Added Compal Hel80i keymap. LP: #198530.
    - Added Zepto ZNote keymap. LP: #400252.
    - Added Everex Stepnote XT5000T keymap. LP: #400921.
    - Added rules to switch mode of Huawei E1550 GSM modem. LP: #401655.
    - Various other keymap and modem updates.

  [ Martin Pitt ]
  * debian/control: Add missing Breaks: casper (<< 1.174) to avoid breaking
    upgrades from jaunty in wubi installations. (LP: #400138)

 -- Scott James Remnant <email address hidden> Tue, 25 Aug 2009 13:45:17 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
Changed in udev (Ubuntu):
status: Fix Released → New
status: New → Fix Released
admod (admod2010) wrote :

hi.
im new to ubuntu,
i have a fujitsu siemen amilo m7400.
and since im here you can probably guess that im having trouble enabling the wifi switch.
which is a pain, as i can only get on line while connected via network cable at the moment.
i see many people have had this same problem before me, but i still cant seem to work it out.
any help would be greatly appricated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers