Ubuntu

kernel boot broken: init: udevtrigger mainprocess (1283) terminated with status 1

Reported by Angel Guzman Maeso on 2009-09-21
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

With the last updates when I reboot the next following messages appear:

init: udevtrigger mainprocess (1283) terminated with status 1
init: udevtrigger post-stop porcess (1283) terminated with status 1
init: udevmonitor main process (1282) killed by TERM signal.

Then nothing happens. I cant init any kernel of ubuntu, I have to use ...windows...for post this bug.

I need repair/fix this for work with ubuntu. Do you know some tricky command?

For me this bug is critical or high, I cant init my ubuntu pc.

Jeff M. Hubbard (jeffmhubbard) wrote :

I'm experiencing this issue as well. Trying to boot either 2.6.31-10-generic or 2.6.30-8-generic, with same results.

Angel Guzman Maeso (shakaran) wrote :

I find a solution:

1. - Download/grab a live cd.

2. - Start live cd and when it loads the desktop open a gnome-terminal.

3. - Create this dirs:

sudo mkdir /media/karmic

sudo mkdir /media/karmic/proc /media/karmic/dev /media/karmic/etc

4. - Mount your linux partition (for me sda6):

sudo mount /dev/sda6 /media/karmic

5. - Bind the dirs:

sudo mount -o bind /proc /media/karmic/proc

sudo mount -o bind /dev /media/karmic/dev/

sudo mount -o bind /dev/pts /media/karmic/dev/pts

6. - Copy this file

sudo cp /etc/resolv.conf /media/karmic/etc/resolv.conf

7. - Update your real linux partition with chroot:

sudo chroot /media/karmic apt-get update

8. - Upgrade your real linux partition with chroot:

sudo chroot /media/karmic apt-get dist-upgrade

9. - If you have some broken package:

sudo chroot /media/karmic apt-get -f install

10. - Reboot and voilá! Fixed for me.

I think that the lastest udev update fix the problem.

Jeff M. Hubbard (jeffmhubbard) wrote :

That fixed it for me also. Thanks!

 status fixreleased

Great to hear that updating fixes it.

Scott
--
Scott James Remnant
<email address hidden>

Changed in udev (Ubuntu):
status: New → Fix Released
Evall (samstan0) wrote :

I'm sorry if I'm breaking any rules by posting on this, not quite sure how old it is, but I came across it in a google search. I have this same problem except for a couple things:

In "init: udevtrigger mainprocess (1283) terminated with status 1 init: udevtrigger post-stop porcess (1283) terminated with status 1 init: udevmonitor main process (1282) killed by TERM signal." the numbers in () (< Temporary brain malfunction) are in the 400s not the 1200s, and if I try to boot with a live disk it doesn't work. It continues with the normal boot, and freezes. I really need help with this please.

Thanks in advance,
Evall

Evall (samstan0) wrote :

Still hoping I'm not breaking any rules, when I said freezes above, I meant the error message pops up, not stops working.

Changed in udev (Ubuntu):
assignee: nobody → Evall (samstan0)
assignee: Evall (samstan0) → nobody
status: Fix Released → Incomplete
Matt Burkhardt (matthewboh) wrote :

I updated my 10.04 release and this just happened to me last week

Mallik Soupati (mallixhere) wrote :

I tried to upgrade Kubuntu 10.04 to Kubuntu 10.10; It asked a reboot after the installation; once I reboot I only see a blank screen, and the messages listed in the "comment #5" in this bug, upon 'ALT + F7'.

I read somewhere that it could be problem with graphics card thus am providing my chipset info as per my motherboard specifications:

Motherboard details : AUS A8N-VM-UAYGZ, nVidia GeForce6100 + nForce410.

Appreciate any help to address this issue, since I am stuck using my PC which has been on Ubuntu since 9.10; lot of data, and installed applications. Installing OS a fresh is going to be cumbersome for me; though I can do it.

Mallik Soupati (mallixhere) wrote :

I tried Live CD; it could not either boot my machine. After the "Kubunut" flash scree, I see scattered pixels and white strips of horizontal bars appeared on my screen. I see it could not render the desk top UI (panels etc).

Launchpad Janitor (janitor) wrote :

[Expired for udev (Ubuntu) because there has been no activity for 60 days.]

Changed in udev (Ubuntu):
status: Incomplete → Expired
EricDHH (ericdhh) wrote :

Cause this happens again in 11.04, i linked my new bug to this one.

Changed in udev (Ubuntu):
status: Expired → Confirmed
EricDHH (ericdhh) wrote :

Got a new kernel

ii linux-image-2. 2.6.38-10.46

so i purged and reinstalled fglrx completely to exclude it for this problem.

ii fglrx 2:8.861-0ubunt

Result

Jul 3 12:48:42 agamemnon NetworkManager[968]: <info> Activation (eth1) Stage 5
of 5 (IP Configure Commit) complete.
Jul 3 12:48:50 agamemnon ntpdate[1287]: adjust time server 91.189.94.4 offset -
0.214215 sec
Jul 3 12:48:51 agamemnon kernel: [ 16.870012] eth1: no IPv6 routers present

What happens here?

Jul 3 12:51:37 agamemnon init: udevtrigger post-stop process (410) terminated w
ith status 1
Jul 3 12:51:37 agamemnon kernel: [ 183.407984] vesafb: framebuffer at 0xd00000
00, mapped to 0xffffc90011c80000, using 1920k, total 1920k
Jul 3 12:51:37 agamemnon kernel: [ 183.407995] vesafb: mode is 800x600x32, lin
elength=3200, pages=0
Jul 3 12:51:37 agamemnon kernel: [ 183.408000] vesafb: scrolling: redraw
Jul 3 12:51:37 agamemnon kernel: [ 183.408007] vesafb: Truecolor: size=0:8:8:8
, shift=0:16:8:0
Jul 3 12:51:37 agamemnon kernel: [ 183.408285] Console: switching to colour fr
ame buffer device 100x37

Alberto Jovito (thedemon007) wrote :

I update of 10.10 to 11.04

init: udevtrigger main process (421) terminated with status 1
init: udevtrigger pots-stop process (424) terminated with status 1
init: udevmonitor main process (418) Killed by TERM sisnal.
La unida de disco de / no esta listo o presente continue esperando, O pulse S para omitir o M para recuperar manualmente.

Alberto Jovito (thedemon007) wrote :

Solve the problem by following these steps:

1. Booting from a live cd, I use live natty server boot via USB and choose the options:

2. Rescue a broken system;

3. Choose the device to use as root file system (typically the first entry);

4. Choose "Execute a shell in /dev/..." as rescue operation.

then run the commands

# mount -o remount,rw /
# dpkg --configure -a
# mount -o remount,ro /
# sync
# reboot

Spring Zhang (qzhang) wrote :

@Alberto
Your solution is quit good! I met it when I interrupt a 'apt-get upgrade', then it dropped me to no login.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions