gnome doesn't 'see' cdroms/dvds

Bug #431055 reported by Maxim Levitsky on 2009-09-16
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
udev
Fix Released
Undecided
Martin Pitt
udev (Ubuntu)
High
Martin Pitt
Karmic
High
Martin Pitt

Bug Description

When I insert a cdrom, it doesn't appear anywhere in gnome.
in computer:// cdrom drive actually disappears after I insert cdrom
no icon in places, and for sure no automounting.

Nether brasero 'sees' the new cdrom

Bug happened just few days ago.

Fully updated 9.10

Noel J. Bergman (noeljb) wrote :

From inserting a disc into the drive:

-----------------------------------------------------
$ udevadm monitor --env
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[1253140850.009687] change /devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0 (scsi)
UDEV_LOG=3
ACTION=change
DEVPATH=/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0
SUBSYSTEM=scsi
SDEV_MEDIA_CHANGE=1
DEVTYPE=scsi_device
DRIVER=sr
MODALIAS=scsi:t-0x05
SEQNUM=1880

KERNEL[1253140850.010090] change /devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0 (block)
UDEV_LOG=3
ACTION=change
DEVPATH=/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0
SUBSYSTEM=block
DEVNAME=sr0
DEVTYPE=disk
SEQNUM=1881
MAJOR=11
MINOR=0

UDEV [1253140850.010200] change /devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0 (scsi)
UDEV_LOG=3
ACTION=change
DEVPATH=/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0
SUBSYSTEM=scsi
SDEV_MEDIA_CHANGE=1
DEVTYPE=scsi_device
DRIVER=sr
MODALIAS=scsi:t-0x05
SEQNUM=1880

UDEV [1253140853.304321] change /devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0 (block)
UDEV_LOG=3
ACTION=change
DEVPATH=/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0
SUBSYSTEM=block
DEVNAME=/dev/sr0
DEVTYPE=disk
SEQNUM=1881
ID_CDROM=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RW=1
ID_CDROM_DVD_RAM=1
ID_CDROM_DVD_PLUS_R=1
ID_CDROM_DVD_PLUS_RW=1
ID_CDROM_DVD_PLUS_R_DL=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_DVD_PLUS_R_DL=1
ID_CDROM_MEDIA_STATE=complete
ID_CDROM_MEDIA_SESSION_COUNT=1
ID_CDROM_MEDIA_TRACK_COUNT=1
ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
ID_VENDOR=MATSHITA
ID_VENDOR_ENC=MATSHITA
ID_MODEL=DVD-RAM_UJ-852
ID_MODEL_ENC=DVD-RAM\x20UJ-852\x20\x20
ID_REVISION=RB02
ID_TYPE=cd
ID_BUS=scsi
ID_PATH=pci-0000:00:1f.1-scsi-0:0:0:0
ACL_MANAGE=1
GENERATED=1
DKD_MEDIA_AVAILABLE=1
DKD_PARTITION_TABLE=1
DKD_PARTITION_TABLE_SCHEME=apm
DKD_PRESENTATION_NOPOLICY=0
MAJOR=11
MINOR=0
DEVLINKS=/dev/scd0 /dev/disk/by-path/pci-0000:00:1f.1-scsi-0:0:0:0 /dev/cdrom /dev/cdrw /dev/dvd /dev/dvdrw
-----------------------------------------------------

Nothing shows up in My Computer or elsewhere in Nautilus. Manual mounting is necessary.

Changed in ubuntu:
status: New → Confirmed
Michalxo (michalxo) wrote :

Same problem here. amd64 here.

Noel J. Bergman (noeljb) wrote :

Confirming that brasero doesn't see the drive at all.

Same problem, karmic alpha 5 amd64 up-to-date as of today 19:30 GMT.

Manual mounting is required, but the drive still doesn't appear in Brasero.

Though which package does this? udev, hal, or something in GNOME?

Maxim Levitsky (maximlevitsky) wrote :

The application that is responsible for removing/adding volumes from varios places in gnome is the

/usr/lib/gvfs/gvfs-gdu-volume-monitor

It sends via dbus all noticications, it removes CDROM from computer:// after I insert it
just launch the dbus-monitor, and you see

This thing also appears to mount the devices (at least it tells everybody it did)

This application probably talks to devicekit-disks (stopping it disabled all disk hotplug features)
So hal is already heavily deprecated

Maxim Levitsky (maximlevitsky) wrote :

Its very likely a bug in gvfs or devicekit-disks

affects: ubuntu → gvfs (Ubuntu)

tentatively adding udev-ubuntu and hal-ubuntu to affected packages

(... or not, I should really learn to refresh pages before I post comments)

alex (1alex) wrote :

confirmed, had to mount manually

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you run "devkit-disks --dump" and "gvfs-mount -li" and copy the logs to the bug?

Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

could be due to the recent devicekit-disks changes

Changed in gvfs (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Martin Pitt (pitti)
assignee: Martin Pitt (pitti) → nobody
status: Incomplete → New
assignee: nobody → Martin Pitt (pitti)
assignee: Martin Pitt (pitti) → nobody
assignee: nobody → Martin Pitt (pitti)
Sebastien Bacher (seb128) wrote :

Changing to confirmed since several users have the bug

Changed in gvfs (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

shrug launchpad having some issues

Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
assignee: Martin Pitt (pitti) → nobody
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Do you also get this after a clean boot, or just after devicekit-disks package gets upgraded? Since yesterday evening, the devicekit-disks upgrade kills the old daemon, which kills the cd-rom polling process along with it. I suppose this has something to do with it.

Martin Pitt (pitti) wrote :

Ah, I bet it is because gdu-volume-monitor crashes for CD-ROM drives, most probably this is bug 376145.

I can reproduce it here. dk-disks sees the CD-ROM, but gvfs doesn't.

Changed in gvfs (Ubuntu):
status: Confirmed → Triaged
Noel J. Bergman (noeljb) wrote :

gvfs-mount -li shows only my hard drive and media reader (SDHC is inserted); devkit-disks --dump shows:

Showing information for /org/freedesktop/DeviceKit/Disks/devices/sr0
  native-path: /sys/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0
  device: 11:0
  device-file: /dev/sr0
    by-path: /dev/disk/by-path/pci-0000:00:1f.1-scsi-0:0:0:0
  detected at: Wed 16 Sep 2009 06:39:31 PM EDT
  system internal: 0
  removable: 1
  has media: 1 (detected at Wed 16 Sep 2009 06:40:53 PM EDT)
    detects change: 1
    detection by polling: 1
    detection inhibitable: 1
    detection inhibited: 0
  is read only: 0
  is mounted: 1
  mount paths: /tmp/cdrom
  mounted by uid: 0
  presentation hide: 0
  presentation nopolicy: 0
  presentation name:
  presentation icon:
  size: 5552111616
  block size: 2048
  job underway: no
  usage:
  type:
  version:
  uuid:
  label:
  partition table:
    scheme: apm
    count: 0
  optical disc:
    blank: 0
    appendable: 0
    closed: 1
    num tracks: 1
    num audio tracks: 0
    num sessions: 1
  drive:
    vendor: MATSHITA
    model: DVD-RAM UJ-852
    revision: RB02
    serial:
    detachable: 0
    can spindown: 0
    rotational media: 1
    ejectable: 1
    media: optical_dvd_plus_r_dl
      compat: optical_cd optical_cd_r optical_cd_rw optical_dvd optical_dvd_plus_r optical_dvd_plus_r_dl optical_dvd_plus_rw optical_dvd_r optical_dvd_ram optical_dvd_rw optical_mrw optical_mrw_w
    interface: scsi
    if speed: (unknown)
    ATA SMART: not available

attaching output from devkit-disks (gvfs-mount follows)

Maxim Levitsky (maximlevitsky) wrote :

========================================================================
Showing information for /org/freedesktop/DeviceKit/Disks/devices/sr0
  native-path: /sys/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0
  device: 11:0
  device-file: /dev/sr0
    by-path: /dev/disk/by-path/pci-0000:00:1f.1-scsi-0:0:0:0
  detected at: Fri 18 Sep 2009 12:02:33 AM IDT
  system internal: 0
  removable: 1
  has media: 0
    detects change: 1
    detection by polling: 1
    detection inhibitable: 1
    detection inhibited: 0
  is read only: 0
  is mounted: 0
  mount paths:
  mounted by uid: 0
  presentation hide: 0
  presentation nopolicy: 0
  presentation name:
  presentation icon:
  size: 0
  block size: 0
  job underway: no
  usage:
  type:
  version:
  uuid:
  label:
  drive:
    vendor: HL-DT-ST
    model: DVDRAM GSA-T20N
    revision: WP03
    serial:
    detachable: 0
    can spindown: 0
    rotational media: 1
    ejectable: 1
    media:
      compat: optical_cd optical_cd_r optical_cd_rw optical_dvd optical_dvd_r optical_dvd_ram optical_mrw optical_mrw_w
    interface: scsi
    if speed: (unknown)
    ATA SMART: not available

========================================================================

Maxim Levitsky (maximlevitsky) wrote :

The above is output of devkit-disks --dump (cdrom part) without a disk

This is output of gvfs-mount -li (without disk):

maxim@maxim-laptop:~$ gvfs-mount -li
Drive(0): CD/DVD Drive
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  ids:
   unix-device: '/dev/sr0'
  themed icons: [drive-optical] [drive]
  is_media_removable=1
  has_media=0
  is_media_check_automatic=1
  can_poll_for_media=1
  can_eject=1
  can_start=0
  can_stop=0
  start_stop_type=unknown

Maxim Levitsky (maximlevitsky) wrote :

This is with ubuntu 9.10 cd in (on cdrw):

========================================================================
Showing information for /org/freedesktop/DeviceKit/Disks/devices/sr0
  native-path: /sys/devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0/block/sr0
  device: 11:0
  device-file: /dev/sr0
    by-path: /dev/disk/by-path/pci-0000:00:1f.1-scsi-0:0:0:0
  detected at: Fri 18 Sep 2009 12:02:33 AM IDT
  system internal: 0
  removable: 1
  has media: 1 (detected at Fri 18 Sep 2009 01:10:37 AM IDT)
    detects change: 1
    detection by polling: 1
    detection inhibitable: 1
    detection inhibited: 0
  is read only: 0
  is mounted: 0
  mount paths:
  mounted by uid: 0
  presentation hide: 0
  presentation nopolicy: 0
  presentation name:
  presentation icon:
  size: 730554368
  block size: 2048
  job underway: no
  usage:
  type:
  version:
  uuid:
  label:
  optical disc:
    blank: 0
    appendable: 0
    closed: 1
    num tracks: 1
    num audio tracks: 0
    num sessions: 1
  drive:
    vendor: HL-DT-ST
    model: DVDRAM GSA-T20N
    revision: WP03
    serial:
    detachable: 0
    can spindown: 0
    rotational media: 1
    ejectable: 1
    media: optical_cd_rw
      compat: optical_cd optical_cd_r optical_cd_rw optical_dvd optical_dvd_plus_r optical_dvd_plus_r_dl optical_dvd_plus_rw optical_dvd_r optical_dvd_ram optical_dvd_rw optical_mrw optical_mrw_w
    interface: scsi
    if speed: (unknown)
    ATA SMART: not available

========================================================================

 gvfs-mount -li shows nothing

Maxim Levitsky (maximlevitsky) wrote :

dbus-monitor confirms this behavior

Maxim Levitsky (maximlevitsky) wrote :

Now I know where this bug is

affects: gvfs (Ubuntu) → devicekit-disks (Ubuntu)
Maxim Levitsky (maximlevitsky) wrote :

The problem is that, blkid is never called on cdroms

adding line

IMPORT{program}="/sbin/blkid -o udev -p $tempnode"

just below

IMPORT{program}="devkit-disks-part-id $tempnode"

Fixes that issue.
But this program might be called by udev too, thus this might be udev bug after all...

95-devkit-disks.rules

Maxim Levitsky (maximlevitsky) wrote :

Here is the answer:

# probe filesystem metadata of disks
KERNEL!="sr*", IMPORT{program}="/sbin/blkid -o udev -p $tempnode"

in 60-persistent-storage.rules

beautiful isn't it?

Maxim Levitsky [2009-09-18 1:19 -0000]:
> Here is the answer:
>
>
> # probe filesystem metadata of disks
> KERNEL!="sr*", IMPORT{program}="/sbin/blkid -o udev -p $tempnode"
>
> in 60-persistent-storage.rules

What's the problem here? CD-ROMs are probed in the rule right above:

KERNEL=="sr*", ENV{ID_CDROM_MEDIA}=="?*", IMPORT{program}="/sbin/blkid -o udev -p -u noraid -O $env{ID_CDROM_MEDIA_SESSION_LAST_OFFSET} $tempnode"

This is to avoid the "automatically closes after eject" effect.

I think devkit-disks is fine here, it sees the CD-ROM and has all the
file system information.

However, as I said, I can reproduce the bug, so don't actually need
more log files or program outputs.

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Maxim Levitsky (maximlevitsky) wrote :

indeed its not a fault of devicekit-disks ether

Changed in devicekit-disks (Ubuntu):
status: Triaged → Invalid
Maxim Levitsky (maximlevitsky) wrote :

Indeed, I didn't notice this line.
However, the problem is that
ID_CDROM_MEDIA_SESSION_LAST_OFFSET
isn't set, thus blkid fails.

I suppose this is a bug in cdrom_id then, since it appears that it should set this variable.
I did test many disks, many disk types. They all behave the same

KERNEL=="sr*", ENV{ID_CDROM_MEDIA}=="?*", IMPORT{program}="/sbin/blkid -o udev -p -u noraid -O $env{ID_CDROM_MEDIA_SESSION_LAST_OFFSET} $tempnode"

This is a true bug chase.... it started with gvfs-gdu-volume-monitor and now it appears to be fault of udev

Maxim Levitsky (maximlevitsky) wrote :

I have sent a mail to udev mailing list about that.
basicly it is very simple, ID_CDROM_MEDIA_SESSION_LAST_OFFSET isn't set by udev helper, cdrom_id, if there is just one session on disk (common case), and thus above rule fails.

For now, just edit this rule to

KERNEL=="sr*", ENV{ID_CDROM_MEDIA}=="?*", IMPORT{program}="/sbin/blkid -o udev -p -u noraid $tempnode

Martin Pitt (pitti) wrote :

Thanks for the investigations!

affects: devicekit-disks (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
status: Invalid → Confirmed
Martin Pitt (pitti) on 2009-09-20
Changed in udev (Ubuntu):
importance: Low → High
tags: added: regression-potential
Martin Pitt (pitti) wrote :

I committed the fix to upstream trunk:

http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=ce09670

Thanks Maxim!

Changed in udev:
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Released
Changed in udev (Ubuntu Karmic):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 147~-2

---------------
udev (147~-2) karmic; urgency=low

  * rules/rules.d/60-persistent-storage.rules: Fix blkid invocation for
    CD-ROMs, thanks to Maxim Levitsky for tracking this down! Fix committed to
    GIT HEAD, and cherrypicked. (LP: #431055)

 -- Martin Pitt <email address hidden> Sun, 20 Sep 2009 19:17:39 +0200

Changed in udev (Ubuntu Karmic):
status: Fix Committed → Fix Released
Daniel Ellis (danellisuk) wrote :

I did not test this issue before this fixed was released. However, my system has udev 147~-5 and I am experiencing this issue. I have checked 60-persistent-storage.rules, and the fix included by 147~-2 is in the file:-

---------------------------------------
# probe filesystem metadata of optical drives which have a media inserted
KERNEL=="sr*", ENV{ID_CDROM_MEDIA}=="?*", ENV{ID_CDROM_MEDIA_SESSION_LAST_OFFSET}=="?*", IMPORT{program}="/sbin/blkid -o udev -p -u noraid -O $env{ID_CDROM_MEDIA_SESSION_LAST_OFFSET} $tempnode"
# single-session CDs do not have ID_CDROM_MEDIA_SESSION_LAST_OFFSET
KERNEL=="sr*", ENV{ID_CDROM_MEDIA}=="?*", ENV{ID_CDROM_MEDIA_SESSION_LAST_OFFSET}=="", IMPORT{program}="/sbin/blkid -o udev -p -u noraid $tempnode"

# probe filesystem metadata of disks
KERNEL!="sr*", IMPORT{program}="/sbin/blkid -o udev -p $tempnode"
---------------------------------------

The CDROMs cannot be ejected via the hardware switch. But 'eject cdrom1' will eject the disks. This issue happens across reboots. My hardware does not have this problem on my 9.04 partition.

Maxim Levitsky (maximlevitsky) wrote :

@Daniel Ellis

I didn't understand you.
Do you mean that you don't see the cdrom in gnome places, when you insert it?

Or that you can't eject the cdrom?

If you can't eject it, this is bug I partially solved this, look at
https://bugs.launchpad.net/ubuntu/+source/devicekit-disks/+bug/397734

Daniel Ellis (danellisuk) wrote :

Actually it is both, but the primary issue I am reporting here is gnome not seeing the disk. I only noted the eject issue in-case the symptoms helped to understand the issue. If I leave 'computer:///' open I can see both 'CD/DVD Drives', when I insert a CD, one drive disappears. If I then insert a CD in the other drive, they both disappear.

I have subscribed to bug #397734 and will be monitoring these issues side-by-side.

Maxim Levitsky (maximlevitsky) wrote :

Then try to follow the path I did:

Post output of these tools (it would be best, if you cold somehow disable one of cdroms, if it is external disconnect it?)

This will tell what devkit thinks about the devices on your system:
devkit-disks --dump

This will tell what gnome vfs thinks (probably redundant, as you already told that cdrom disapperars)
gvfs-mount -li

This will tell us, what udev posts when disk is inserted to rest of system:
Eject disk, then run following command, then insert it again, wait till everything settles up, then note the output

udevadm monitor --property

And finally (probably redundant, but anyway)
Post output of following (with the CD in of course):

blkid /dev/sr0
/lib/udev/cdrom_id /dev/sr0

(If you use both cdroms, then somehow figure out the one that contatins the disk)
It will be ether sr0 or sr1

Daniel Ellis (danellisuk) wrote :

Okay, I disconnected the IDE cable to my second cdrom drive. However, there is now a second (phantom) cdrom0 shown in Nautilus. I checked the bios and that shows nothing detected on IDE 2).

The result from 'devkit-disks --dump' is attached (with hard disks and partitions removed).

The result 'from gvfs-mount -li' shows only the phantom cdrom0. I have also attached the result from gcfs-mount without the media in the drive.

'blkid /dev/sr0' returns nothing.

'/lib/udev/cdrom_id /dev/sr0' returns:-
-----------------------
ID_CDROM=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RW=1
ID_CDROM_DVD_PLUS_R=1
ID_CDROM_DVD_PLUS_RW=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_DVD=1
ID_CDROM_MEDIA_STATE=complete
ID_CDROM_MEDIA_SESSION_COUNT=1
ID_CDROM_MEDIA_TRACK_COUNT=1
ID_CDROM_MEDIA_TRACK_COUNT_DATA=1
-----------------------

Daniel Ellis (danellisuk) wrote :
Daniel Ellis (danellisuk) wrote :
Daniel Ellis (danellisuk) wrote :
Daniel Ellis (danellisuk) wrote :

I have also noticed the following output of dmesg which I do not get when inserting a cd on my 9.04 partition:-

[ 188.454599] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.454665] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.454675] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.454786] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.454802] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.454854] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.455038] sr 4:0:0:0: [sr0] unaligned transfer
[ 188.455134] sr 4:0:0:0: [sr0] unaligned transfer

Maxim Levitsky (maximlevitsky) wrote :

@Daniel Ellis

I have seen such messages myself.
It smells like kernel bug, but here a reboot, will make the disk readable again.
So, did you try to reboot?

Does this happens with all disks.
From now on, pay carefull attention to dmesg, and to
blkid /dev/sr0

The fact that blkid returns nothing means that it can't detect valid FS on the disk, which can be caused ether by kernel bug/bad device/bad media.

So test with few disks, of several types if possible.

Daniel Ellis (danellisuk) wrote :

I performed many more tests. At first I thought I was going mad because everything was working fine today. However, then I tried again after rebooting and it failed again. The difference, is that the first time I booted with a CD in the drive, the second time I did not. I then performed both tests again to confirm this was the case.

Here were my results:-

(Results after booting with CD left in the drive)
  Detected | Hardware eject | Software eject
Audio CD: Yes | No | Yes
DVD Video: Yes | No | Yes
PC CDROM: Yes | No | Yes
DVD ROM: Yes | No | Yes

(Results after booting with no CD in the drive)
  Detected | Hardware eject | software eject
Audio CD: Yes | No | Yes
DVD Video: No | No | Yes
PC CDROM: No | No | Yes
DVD ROM: No | No | Yes

I have attached the dmesg output for the tests that worked. When the tests fail, dmesg just shows a list of 'unaligned transfer' messages as per my previous comments.

Maxim Levitsky (maximlevitsky) wrote :

And I guess same disks did work once, and once didn't right?

This is very likely a kernel problem.
I will report it to linux kernel mailing list.

Everything else is unrelated I guess.

Now just try few times to boot with and without the CD and see if this is related. Use same disk (probably a data disk)

I have seen such things here myself, but rare.

Norbert (asterix52) wrote :

I have the same Problem, but it works before alpha 6 came out with the new upstart system.

muncrief (rmuncrief) wrote :

I have the same problem, and the workaround Daniel Ellis described (booting with a DVD or CD in the drive) works for me also. If I don't boot with media in the drive my DVD/CD drive is basically dead in the water. Even though I can manually mount it, I can't burn anything to it because Brasero doesn't recognize it. The eject button also doesn't work. Curiously though, K3B does work for mounting, burning, and ejecting.

However if I boot with media in the drive everything works fine. The media is automounted, I can eject it with the button or via Nautilus, and continue to insert, use, and remove media normally.

I'm running Karmic Alpha 6 x86_64 and update every few hours, so as of this moment everything is up to date.

Martin Pitt (pitti) wrote :

Please note that the original bug is fixed and this report is closed. If you still have problems with CD-ROMs, please file a new bug report. This rather sounds like a kernel bug, not an udev one (I can't be sure, though, might also be related to coldplugging)

muncrief (rmuncrief) wrote :

I don't understand. No one has reported that the attempted fixes have worked, and they don't. I just checked again.

But I tried to file a new bug report anyway as requested, but after trying for almost an hour launchpad simply won't let me. In fact when I attempted to associate my login with OpenID an error occurred and I was actually referred to something like a "MoinMoin" bug report page or something like that, and I believe it was a bug report page for the bug reporting system itself. Now that's a circular firing squad ! :)

In any case, if the devs want to pretend this bug is fixed, OK. But it isn't. It remains exactly as initially reported. If anyone has the capability of reporting the bug again please do so. As I said I've tried my best but launchpad simply will not let me no matter what I do. I will monitor this thread and add my own system debug information if someone can reopen or file a new bug report for this.

muncrief (rmuncrief) wrote :

OK, after half a day of effort I was finally able to get past all the GPG nonsense for a normal user to file a bug report. I have opened bug #439137 in an attempt to assure that Ubuntu doesn't release a beta that can't mount or use DVD/CD media.

Sheesh.

It would have been much easier if the devs had taken this high priority bug seriously and not closed it before it was resolved.

Martin Pitt (pitti) wrote :

muncrief, GPG nonsense? You just need to do "ubuntu-bug linux" (as the file bug page also describes), and there you go. No GPG involved.

We don't pretend that this bug is fixed, it _is_ fixed. Maxim reported the bug, we tracked it down (I could reproduce it myself), and fixed it. Maxim never complained that it still is broken for him.

In comment 34, Daniel reported an unrelated issue (eject button not working) which is tracked in bug 397734.

You report that CDs _are_ recognized when you boot with a CD in the drive. They wouldn't have been recognized with this original bug still in place. So as I said, you have different symptoms.

Thanks for the new report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers