Ubuntu

Does not handle microphone mute button (KEY_MICMUTE)

Reported by Christopher Snapp on 2009-08-04
484
This bug affects 92 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
James M. Leddy
Raring
Medium
James M. Leddy
xkeyboard-config
Fix Released
Medium
gnome-settings-daemon (Ubuntu)
Medium
Unassigned
Declined for Natty by Michael Casadevall
Declined for Quantal by Michael Casadevall
Nominated for Saucy by James M. Leddy
Precise
Undecided
Unassigned
Raring
Medium
Unassigned
libx11 (Ubuntu)
Undecided
Unassigned
Declined for Natty by Michael Casadevall
Declined for Quantal by Michael Casadevall
Nominated for Saucy by James M. Leddy
Precise
Undecided
Unassigned
Raring
Undecided
Unassigned
udev (Ubuntu)
Medium
Martin Pitt
Declined for Natty by Michael Casadevall
Declined for Quantal by Michael Casadevall
Nominated for Saucy by James M. Leddy
Precise
Undecided
Unassigned
Raring
Medium
Unassigned
x11proto-core (Ubuntu)
Undecided
Unassigned
Declined for Natty by Michael Casadevall
Declined for Quantal by Michael Casadevall
Nominated for Saucy by James M. Leddy
Precise
Medium
Unassigned
Raring
Undecided
Unassigned
xkeyboard-config (Ubuntu)
Undecided
Unassigned
Declined for Natty by Michael Casadevall
Declined for Quantal by Michael Casadevall
Nominated for Saucy by James M. Leddy
Precise
Undecided
Unassigned
Raring
Undecided
Unassigned
xserver-xorg-input-evdev (Ubuntu)
Medium
Unassigned
Declined for Natty by Michael Casadevall
Declined for Quantal by Michael Casadevall
Nominated for Saucy by James M. Leddy
Precise
Undecided
Unassigned
Raring
Medium
Unassigned

Bug Description

[Impact]
 * People buying thinkpad hardware are not able to use a mic mute key, that comes with
   their machine

[Test Case]

 * Press mic mute key
 * Observe that nothing happens

[Regression Potential]

 * Very low. This is very isolated code. All it does is add functionality. In fact there
   are very few deletions in the diffs.

 * There is an existing acpi solution, that's already been mentioned in this bug. I'm
   not sure how these users would be affected once the upgrade hits, but it was never
   released as an official fix.

[Original Report]

Pressing the new microphone mute button does not do anything. It should toggle the mute on the current capture device and toggle an led that is part of the button.

acpi_listen output:

ibm/hotkey HKEY 00000080 0000101b

xev output:

MappingNotify event, serial 34, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 248

MappingNotify event, serial 34, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 247

KeyPress event, serial 34, synthetic NO, window 0x3400001,
    root 0x118, subw 0x0, time 10334714, (317,-162), root:(322,207),
    state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 34, synthetic NO, window 0x3400001,
    root 0x118, subw 0x0, time 10334714, (317,-162), root:(322,207),
    state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Jerone Young (jerone) wrote :

What does adding to the kernel command line "acpi_osi=Linux" do ?

Jerone Young (jerone) wrote :

This is something I plan to look into for next release. The microphone mute key is not a standard key. It will not even work under windows without a special driver from Lenovo.

Though let me know what happens if you put acpi_osi=Linux on the command line.

Changed in ubuntu:
status: New → Incomplete
Christopher Snapp (snappca) wrote :

I did not see any difference when I added "acpi_osi=Linux" to the kernel args. Thanks for looking into it.

Patrick (94bc1052) wrote :

I have the same issue, but with the rather new Thinkpad T410. Volume up/down and mute work right out of the box, microphone mute does not, as described above.

Tom Gelinas (tomgelinas) wrote :

The T510 is obviously affected, too.

acpi_listen output:

 ibm/hotkey HKEY 00000080 0000101b

XEV Output:

MappingNotify event, serial 38, synthetic NO, window 0x0,
    request MappingKeyboard, first_keycode 8, count 248

KeyPress event, serial 38, synthetic NO, window 0x5000001,
    root 0x15d, subw 0x0, time 3725773, (19,-15), root:(1310,37),
    state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 38, synthetic NO, window 0x5000001,
    root 0x15d, subw 0x0, time 3725773, (19,-15), root:(1310,37),
    state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Same problem on Lucid with a T410

Changed in ubuntu:
status: Incomplete → Confirmed
Jerone Young (jerone) wrote :

There is work going on on the thinkpad-acpi mailing list. To get a support for the button & LED.

Initial support to support the T410s is here:

http://sourceforge.net/mailarchive/forum.php?thread_name=20100420210327.GA1003%40ranger.taprogge.wh&forum_name=ibm-acpi-devel

summary: - thinkpad t400s microphone mute button does not work
+ Thinkpad T400s, T410s, T410, & T510 microphone mute button does not work

@Christopher, please could you check if this issue is still affecting you under latest release included in Ubuntu Lucid? Additionally, maybe your issue is related to https://bugzilla.novell.com/show_bug.cgi?id=594363. Thanks!

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

To be clear the microphone itself works fine, it is only the thinkpad mute
button that is not functional. On the newer thinkpad keyboards there are
two mute buttons one for speakers and one for microphone, each with an led
that should light up when they are activated. The speaker mute button is
functional but its led does not light up, whereas the microphone mute button
does not work at all.

This is still the case in Kubuntu 10.04 with the latest updates.

On Thu, Jul 8, 2010 at 3:44 PM, Kamus <email address hidden> wrote:

> @Christopher, please could you check if this issue is still affecting
> you under latest release included in Ubuntu Lucid? Additionally, maybe
> your issue is related to
> https://bugzilla.novell.com/show_bug.cgi?id=594363. Thanks!
>
> ** Bug watch added: Novell/SUSE Bugzilla #594363
> https://bugzilla.novell.com/show_bug.cgi?id=594363
>
> ** Package changed: ubuntu => linux (Ubuntu)
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Thinkpad T400s, T410s, T410, & T510 microphone mute button does not work
> https://bugs.launchpad.net/bugs/408903
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Incomplete
>
> Bug description:
> Ubuntu 9.04
>
> Pressing the new microphone mute button does not do anything. It should
> toggle the mute on the current capture device and toggle an led that is part
> of the button.
>
> acpi_listen output:
>
> ibm/hotkey HKEY 00000080 0000101b
>
>
> xev output:
>
> MappingNotify event, serial 34, synthetic NO, window 0x0,
> request MappingKeyboard, first_keycode 8, count 248
>
> MappingNotify event, serial 34, synthetic NO, window 0x0,
> request MappingKeyboard, first_keycode 8, count 247
>
> KeyPress event, serial 34, synthetic NO, window 0x3400001,
> root 0x118, subw 0x0, time 10334714, (317,-162), root:(322,207),
> state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
> XLookupString gives 0 bytes:
> XmbLookupString gives 0 bytes:
> XFilterEvent returns: False
>
> KeyRelease event, serial 34, synthetic NO, window 0x3400001,
> root 0x118, subw 0x0, time 10334714, (317,-162), root:(322,207),
> state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
> XLookupString gives 0 bytes:
> XFilterEvent returns: False
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/408903/+subscribe
>

--
Chris

This is still an issue in Ubuntu 10.04.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Pete Graner (pgraner) wrote :

Can everyone restest this with Maverick, I am not seeing this with our T410 reference model.

3 comments hidden view all 155 comments
Lorenzo (lorped) wrote :

Led is *not* working on T410 with Maverick (right now at Release Candidate version )

vyncere (vyncere) wrote :

On my Thinkpad T410 with Ubuntu 10.10 RC, mute recording button does not work at all :
- Led is always off (default)
- Microphone is not never mute (default)

System :
Description: Ubuntu maverick (development branch), Release: 10.10
Linux ubuntu 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux
Ubuntu 2.6.35-22.33-generic 2.6.35.4

dmesg :
[ 2917.343368] keyboard: can't emulate rawmode for keycode 240
[ 2917.343393] keyboard: can't emulate rawmode for keycode 240

xev:
KeyPress event, serial 37, synthetic NO, window 0x4200001,
    root 0xb4, subw 0x0, time 3000330, (18,-17), root:(1277,678),
    state 0x0, keycode 248 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

acpi_listen :
ibm/hotkey HKEY 00000080 0000101b

Peter Andreus (peter-andreus) wrote :

On 10.10 Ubuntu with Lenovo l512 same issue microphone mute button doesnt work, LEDs in sound and microphone mute button doesnt work.

But i found funny thing. After reboot from W7 where i mute sound LED in button still lights even in Ubuntu, but now i cant turn that LED off.

andypiper (andypiperuk) wrote :

Confirmed still an issue on T510 with Ubuntu 10.10. Mic mute button does not work, speaker mute button does.

nameiner (nameiner) wrote :

I can confirm the same behavior on the W510 with 10.10.

dm (jan-rauberg) wrote :

Oh, I see, I'm not alone with that kind of problem. I own a T400s with maverick currently installed. The mute and micro buttons don't work in the right manner. I don't need the micro button so I've informed the makers of the thinkpad kernel module about the problem. They answered that without an T400s it is difficult to analyze this behavior. But for the mute button I think it worked some versions before. As far as I know in 9.10 it worked like in Windows 7. In 10.10 and also 10.04 the mute button toggles off the sound but not the system beeps. This is the really annoying thing and therefore the buttons LED doesn't switched on. Only if the LED is on the sound is really muted (also system beeps) and this is what I want. I have colleague who owns a T510 and I've seen that at least the mute LED does work on his laptop in opposite to some posters before. Both laptops (T400s and T510) are using the same keyboard layout. I can't see a reason why the behavior is so different.

Jan

sxe.funky (sxe-funky) wrote :

On my T410i with Ubuntu 10.04.1:
 + Sound mute works with its led.
 - Mic mute doesn't works

Barry Carroll (baz8080) wrote :

T410i.

The mic mute button does not mute the mic as confirmed with sound preferences.

Bausparfuchs (bausparfuchs) wrote :

Issue exists in Natty on my New Lenovo Thinkpad x220i

Steve Langasek (vorlon) on 2011-05-23
Changed in acpi-support (Ubuntu):
status: New → Invalid
Changed in gnome-control-center (Ubuntu):
status: New → Invalid
Zygmunt Krynicki (zkrynicki) wrote :

Steve, why is this not valid for acpi-support? AFAIR this is an ACPI-related issue. You need some support to actually trigger the LED on that button to change when pressed.

Steve Langasek (vorlon) wrote :

Hey Zyga,

> why is this not valid for acpi-support?

Because acpi-support is a deprecated package which is being phased out - new features should not be added there.

> You need some support to actually trigger the LED on that
> button to change when pressed.

I think this should probably be implemented in the kernel itself (as suggested by the already-open 'linux' task); we don't want that handling to be dependent on a desktop component (like gnome-settings-daemon), and as acpi-support should go away, that leaves the kernel as the preferred place to implement this. (And that would definitely be consistent with other LED handling.)

Daniël van Eeden (dveeden) wrote :

The microphone mute button needs:
- Support in linux
- Support in high level tools (There is no key binding in GNOME for microphone mute a.t.m.)

The microphone mute button also has a LED(-like) indicator which also needs support.

The LED(-like) indicator for the 'normal' mute button can easily get out of sync with the indicator-sound-service one.

Zygmunt Krynicki (zkrynicki) wrote :

The LED(-like) indicator for the 'normal' mute button can easily get out of sync with the indicator-sound-service one.

I think this is a separate and valid bug. The LED indicator should be controlled by alsa when sound is becomes mute.

Daniël van Eeden (dveeden) wrote :

I've created Bug #788540 for the seperate issue about the mute button indicator getting out of sync.

Thomas Hood (jdthood) wrote :

The microphone mute key is not currently supported in Ubuntu but the fix is fairly straightforward.

First, udev needs to map the micmute key's scancode to a keyname which corresponds to an X key event. This has been fixed[0] in udev upstream. It is possible to make the same change locally, as described here[1].

Second, the key event needs to mute the microphone. This can be accomplished with a small script as described here[1].

[0]http://git.kernel.org/?p=linux/hotplug/udev.git;a=commitdiff;h=6e3b1694a4dea049591af1f089adce327bf6a542
[1]http://www.thinkwiki.org/wiki/Installing_Ubuntu_11.04_(Natty_Narwhal)_on_a_ThinkPad_X220#Fix_for_hotkey_shortcomings

O Gopal (jswami) wrote :

Issue exists with Natty on my T420s.

Simon Hirscher (codethief) wrote :

I can confirm this for my W510 (can we add it to the bug title?).

summary: - Thinkpad T400s, T410s, T410, & T510 microphone mute button does not work
+ Thinkpad T400s, T410s, T410, T510 & W510 microphone mute button does not
+ work
mitakas (mitakas) wrote :

I can also confirm this issue on 11.10 and Thinkpad T420.

Grigory Rechistov (atakua) wrote :

I confirm this issue on Lenovo Thinkpad X220i with Oneiric x86_64.

matze (matzex) wrote :

On Thinkpad X220 with Oneric (64bit) i can confirm this issue, too!

Norbert Varga (nonoo) wrote :

Issue confirmed on a T520.

Martin Pitt (pitti) wrote :

Since linux 3.0 we actually have a KEY_MICMUTE, so I'll update the udev keymaps accordingly.

Changed in linux (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
affects: linux (Ubuntu) → udev (Ubuntu)
Martin Pitt (pitti) wrote :

The module-lenovo keymap actually already is updated to "micmute" upstream and in precise already. So that part is done, if it still doesn't work in precise it's a gnome-settings-daemon bug.

Changed in udev (Ubuntu):
status: In Progress → Fix Released
Simon Hirscher (codethief) wrote :

Still doesn't work for me, so it must be gnome-settings-daemon.

Martin Pitt (pitti) on 2011-12-15
affects: acpi-support (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: nobody → Canonical X.org (canonical-x)
importance: Undecided → Low
status: Invalid → Triaged
summary: - Thinkpad T400s, T410s, T410, T510 & W510 microphone mute button does not
- work
+ Does not handle microphone mute button (KEY_MICMUTE)
affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
tags: added: blocks-hwcert-enablement
tags: added: rls-q-incoming
tags: added: rls-q-notfixing
removed: rls-q-incoming
Bryce Harrington (bryce) on 2012-10-17
Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: Canonical X.org (canonical-x) → nobody
Changed in udev (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Medium
Changed in xserver-xorg-input-evdev (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-settings-daemon (Ubuntu Raring):
importance: Undecided → Medium
status: New → Triaged
tags: added: rls-r-incoming
Bryce Harrington (bryce) on 2013-03-07
tags: added: raring
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
importance: Undecided → Medium
status: New → Triaged
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xkeyboard-config:
status: Confirmed → Fix Released
Martin Pitt (pitti) on 2013-05-21
Changed in udev (Ubuntu):
status: Triaged → Invalid
Changed in udev (Ubuntu Raring):
status: Triaged → Invalid
Martin Pitt (pitti) on 2013-05-21
Changed in udev (Ubuntu):
status: Invalid → Fix Released
Changed in udev (Ubuntu Raring):
status: Invalid → Triaged
description: updated
Changed in x11proto-core (Ubuntu Precise):
importance: Undecided → Medium
status: New → In Progress
status: In Progress → Fix Committed
tags: added: verification-needed
75 comments hidden view all 155 comments
James M. Leddy (jm-leddy) wrote :

Rebuilds were successful!

tags: added: verification-done
removed: verification-needed
Thomas Hood (jdthood) wrote :

I was about to test the new versions of the various packages but then I noticed that x11proto-core isn't currently installed on my Ubuntu Desktop 13.04 system. So clearly I am failing to understand something. Exactly which package versions should I install on Ubuntu Desktop 13.04 in order to test the newly added support for the ThinkPad microphone mute button?

James M. Leddy (jm-leddy) wrote :

It's x11proto-core-dev, if you get stuck with that again, you can figure it out by following the link in the call to test the proposed package:

https://launchpad.net/ubuntu/+source/x11proto-core/7.0.22-1ubuntu0.1

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-core - 7.0.22-1ubuntu0.1

---------------
x11proto-core (7.0.22-1ubuntu0.1) precise-proposed; urgency=low

  * Add 0001-Add-XF86XK_AudioMicMute.patch:
    - Backport commit f1b8b4dd from upstream. This adds a key that
      is used on some thinkpad keyboards. Fixes (LP: #408903)
 -- James M Leddy <email address hidden> Thu, 30 May 2013 20:11:37 -0400

Changed in x11proto-core (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

James M. Leddy (jm-leddy) wrote :

Per comment #109, I've added libx11 as a component. Additionally, I'm re-subbing -sponsors so that they will see this request. All we need is a rebuild of the package with the latest x11proto-core.

Changed in libx11 (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

Uploaded a no-change rebuild of libx11 to precise, thanks

James M. Leddy (jm-leddy) wrote :

Thanks Ian,

Waiting for it to hit -proposed to test.

James M. Leddy (jm-leddy) wrote :

We don't any changes to xserver-xorg-input-evdev in order to fix this problem. Marking as Won't Fix.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: Triaged → Won't Fix
Changed in xserver-xorg-input-evdev (Ubuntu Precise):
status: New → Won't Fix
Changed in xserver-xorg-input-evdev (Ubuntu Raring):
status: Triaged → Won't Fix
Changed in libx11 (Ubuntu Precise):
status: New → In Progress
Dimitri John Ledkov (xnox) wrote :

libx11 is in precise unapproved queue. Unsubscribing ubuntu-sponsors for now. If more uploads needed, please re-subscribe the team, when ready.

Ara Pulido (apulido) wrote :

Adding the SRU team, to get it approved in the queue

Sebastien Bacher (seb128) wrote :

> Adding the SRU team, to get it approved in the queue

Thanks Ara, I don't think it's necessary though, the SRU team tends to work the other way around: they check the queue and come back to the bugs from the changelog. I guess the message/subscribe can help as a gently review nudge though ;-)

Hello Christopher, or anyone else affected,

Accepted libx11 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libx11/2:1.4.99.1-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libx11 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed

I installed libx11-6 from precise-proposed but can't verify the included bugfix. Apart from that, is there any other relevant package that has to be updated? I have the following (latest) versions installed:

 gnome-settings-daemon: 3.4.2-0ubuntu0.6.2
 libx11-6: 2:1.4.99.1-0ubuntu2.2
 udev: 175-0ubuntu9.4
 xkb-data: 2.5-1ubuntu1.3
 xkb-data-i18n: 2.5-1ubuntu1.3

Of course the affected Precise system is up to date as of today.

Sebastien Bacher (seb128) wrote :

James, Ara, can you help verifying that one?

James M. Leddy (jm-leddy) wrote :

I have verified by compile testing a version of g-s-d that uses XF86AudioMicMute.

tags: added: verification-done
removed: verification-needed
James M. Leddy (jm-leddy) wrote :

Sebastien,

Thanks for flipping the tag. As noted in comment #108 , we still need backports of udev, gnome-settings-daemon, and xkeyboard-config to close this bug out. Additionally, this requires a revert of xkeyboard-config that we have in -proposed. I'm not sure how to work that because this is my first verification-failed bug, but I assume I can just revert it.

https://code.launchpad.net/~jm-leddy/ubuntu/precise/xkeyboard-config/micmute

We have two vendors in addition to Lenovo that have added micmute keys since this bug has been opened, and we're shipping 12.04 as the standard for all oem builds. So this bug has a higher priority now.

Sebastien Bacher (seb128) wrote :

@James:

right, we still need to change other components, I've tagged the verification-done because the only piece up for verification at the moment is libx11 and you verified that one, getting it in updates would put us one step closer from fixing the issue right?

> Additionally, this requires a revert of xkeyboard-config that we have in -proposed. I'm not sure how to work that because this is my first verification-failed bug, but I assume I can just revert it.

Do you need revert or extra changes? in any case the update is in precise-updates so you can't verification-failed it anymore (that's just used to get things dropped from proposed/not copied to updates), you need another upload on top of the current version

James M. Leddy (jm-leddy) wrote :

> right, we still need to change other components, I've tagged the verification-done because the only piece up for verification at the moment is libx11 and you verified that one, getting it in updates would put us one step closer from fixing the issue right?

This is exactly right.

>> Additionally, this requires a revert of xkeyboard-config that we have in -proposed. I'm not sure how to work that because this is my first verification-failed bug, but I assume I can just revert it.
>
> Do you need revert or extra changes? in any case the update is in precise-updates so you can't verification-failed it anymore (that's just used to get things dropped from proposed/not copied to updates), you need another upload on top of the current version

This is in relation to bug #937822. Since that bug is verification-failed, we pulled the update of xkeyboard-config from the -proposed archive. But it's still living out in the launchpad bzr code archive. So specifically, my question is whether I should branch from the -updates lp archive or the -proposed lp archive (and pull the patch, as I have have done). I've ran into this situation before in bug 1011073 but cyphermox solved it for me. Sorry if this is too much minutia.

https://code.launchpad.net/~ubuntu-branches/ubuntu/precise/xkeyboard-config/precise-updates
https://code.launchpad.net/~ubuntu-branches/ubuntu/precise/xkeyboard-config/precise-proposed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libx11 - 2:1.4.99.1-0ubuntu2.2

---------------
libx11 (2:1.4.99.1-0ubuntu2.2) precise; urgency=low

  * Rebuild against SRUed x11-proto-core (LP: #408903)
 -- Iain Lane <email address hidden> Mon, 22 Jul 2013 11:09:59 +0100

Changed in libx11 (Ubuntu Precise):
status: Fix Committed → Fix Released
James M. Leddy (jm-leddy) wrote :

Fixed released as in bug 1193147.

Changed in udev (Ubuntu Precise):
status: New → Fix Released
James M. Leddy (jm-leddy) wrote :

Subscribed sponsors and submitted the remaining packages for merge requests.

Thomas Hood (jdthood) wrote :

I see that a lot of work has been done to get this change into precise, but it is not clear to me what the status of this change is for raring and saucy.

James M. Leddy (jm-leddy) wrote :

I've confirmed that these two branches work on a machine with the micmute button.

Stéphane Graber (stgraber) wrote :

Hello Christopher, or anyone else affected,

Accepted gnome-settings-daemon into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-settings-daemon/3.4.2-0ubuntu0.6.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-settings-daemon (Ubuntu Precise):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Changed in xkeyboard-config (Ubuntu Precise):
status: New → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Christopher, or anyone else affected,

Accepted xkeyboard-config into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xkeyboard-config/2.5-1ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sebastien Bacher (seb128) wrote :

Bug #1248368 was reported as new issue due to the g-s-d change (osd feedback on sound keys not working after update), setting the bug as verification-failed

tags: added: verification-failed
removed: verification-needed
Tormod Volden (tormodvolden) wrote :

Verified on a T410 with Ubuntu 12.04.3: After installing gnome-settings-daemon 3.4.2-0ubuntu0.6.5 and xkb-data 2.5-1ubuntu1.5 from precise-proposed the Mic Mute button actually toggles mic mute. However, the LED still does not light up.

Dudytz (dudytz) wrote :

The same problem in the ThinkPad L530 with Ubuntu 13.10.

Ray Chen (ray.chen) wrote :

Verified on Lenovo E431 and E531, can not reproduce this issue.

ii gnome-settings-daemon 3.4.2-0ubuntu0.6.5 daemon handling the GNOME session settings
ii xkb-data 2.5-1ubuntu1.5 X Keyboard Extension (XKB) configuration data

tags: added: verification-done
removed: verification-failed
Brian Murray (brian-murray) wrote :

The verification for this bug should still be failed due to the regression introduced and documented in bug 1248368.

tags: added: verification-failed
removed: verification-done
Brian Murray (brian-murray) wrote :

The reporter of bug 1248368 indicates they are no longer having the regression they reported, so I'm setting this back to verification-done.

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu0.6.5

---------------
gnome-settings-daemon (3.4.2-0ubuntu0.6.5) precise; urgency=low

  * debian/patches/64_micmute.patch:
    - put the mic mute key used on thinkpad laptops to good use
      (lp: #408903)
 -- James M Leddy <email address hidden> Sat, 01 Jun 2013 10:01:49 -0400

Changed in gnome-settings-daemon (Ubuntu Precise):
status: Fix Committed → Fix Released
Ilya G. Ryabinkin (ileyka) wrote :

I didn't get what this update is doing. My mic.mute still doesn't work -- when I'm pressing it nothing happening, even the button LED does not lit up.

Lenovo x220 4286CTO

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu1.5

---------------
xkeyboard-config (2.5-1ubuntu1.5) precise-proposed; urgency=low

  * Revert last commit due to a SRU verification failure.
  * Add patch 115_add_XF86AudioMicMute.patch. This maps F20 to the new
    XF86AudioMicMute keysym. Cherrypick from upstream. (LP: #408903)
 -- James M Leddy <email address hidden> Fri, 31 May 2013 15:39:35 -0400

Changed in xkeyboard-config (Ubuntu Precise):
status: Fix Committed → Fix Released
Ilya G. Ryabinkin (ileyka) wrote :

After today's update and rebooting a microphone mute button is now working for me! Thanks.

I just installed Ubuntu 14.04 Beta 1 and the microphone mute button stopped working. Just to make sure I ran Manjaro Live and it works there.

Marius Gedminas (mgedmin) wrote :

Trusty has gnome-settings-daemon 3.8.6. Support for XF86AudioMicMute was added in gnome-settings-daemon 3.9.2:
https://github.com/GNOME/gnome-settings-daemon/commit/3a8beaaf380a483ce33363031d8d276c371d7af1

I believe gnome-settings-daemon (and unity-settings-daemon) need to backport that patch for XF86AudioMicMute support.

Ara Pulido (apulido) on 2014-04-04
Changed in oem-priority:
status: Triaged → Won't Fix
Marius Gedminas (mgedmin) wrote :

This was fixed in unity-settings-daemon 14.04.0+14.04.20140402-0ubuntu1.

It remains unfixed in gnome-settings-daemon.

Displaying first 40 and last 40 comments. View all 155 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.