udevd-event failure: unable to create db file: File name too long

Bug #377121 reported by fibreraid on 2009-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: udev

Booting my stock Jaunty 9.04 x64 server edition from bootable USB flash. The Intel server I am running have 36 hard drives on it, connected via an LSI 3801E SAS controller. I am using the stock LSI mptsas drivers (no special driver). The 36 drives are connected to the LSI controller via SAS JBOD enclosures.

There are at least a few dozen such udevd error messages at boot complaining that the file name is too long. See attached screenshot of my console screen during boot. udev version is 141-1.1.

Changed in udev (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 147~-1

---------------
udev (147~-1) karmic; urgency=low

  FFE LP: #427356.

  * Update to GIT HEAD (pre 147 release):
    - worker signal mask corrected. LP: #407428.
    - database format change to avoid path length issues. LP: #377121.
    - multiple devices may not claim the same /dev names, except with
      symlinks
    - NAME="%k" produces a warning
    - symlinks to udevadm no longer resolve to the original command
    - rules updates. LP: #281335, LP: #407940, #420015, #426647.

  * Build-depend on gawk, since build fails with mawk.

  * Replace init scripts with Upstart jobs.
  * debian/control:
    - Add missing ${misc:Depends}
    - Bump build-dependency on debhelper for Upstart-aware dh_installinit

 -- Scott James Remnant <email address hidden> Tue, 15 Sep 2009 03:22:11 +0100

Changed in udev (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers