Some keyboard keys/hotkeys on Compaq N150 not recognised

Bug #35382 reported by Duncan Lithgow on 2006-03-17
32
Affects Status Importance Assigned to Milestone
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

Updated June 3rd 2007 for Ubuntu 7.04 (Feisty Fawn)

Output of 'dmidecode -s':
manufacturer = Compaq
system-name = COMPAQ N150
model = 0F02

These hotkeys don't work (from left to right on the keyboard, see also: (see also: https://wiki.ubuntu.com/LaptopTestingTeam/CompaqEvoN150):
hotkey 0xa3 = 'help' fails, image is of a large serif font letter 'i'
hotkey 0x9f = 'home' fails, image if of a house
hotkey 0x9a = 'search' fails, image is of a magnifying glass
hotkey 0x9e = 'email' fails, image is of a closed envelope

I dropped to a terminal with FN+F1 and typed 'sudo showkey -u'. All the keys I tried gave something, but the hotkeys got no response with this command (just the first '0x9c' which is always there, even if I don't press anything)

They are physically separate keys, you can see them on this image as small round silver keys at the top of the keyboard, directly under the screen in the middle: http://www005.upp.so-net.ne.jp/crank-in/DSCN15051.JPG

The dmesg output for those keys (comment 20) is:
Help:
[4294816.661000] atkbd.c: Unknown key pressed (translated set 2, code 0xa3 on isa0060/serio0).
[4294816.661000] atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.
[4294816.914000] atkbd.c: Unknown key released (translated set 2, code 0xa3 on isa0060/serio0).
[4294816.914000] atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.

Home:
[4294817.403000] atkbd.c: Unknown key pressed (translated set 2, code 0x9f on isa0060/serio0).
[4294817.403000] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.
[4294817.691000] atkbd.c: Unknown key released (translated set 2, code 0x9f on isa0060/serio0).
[4294817.691000] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.

Search:
[4294818.205000] atkbd.c: Unknown key pressed (translated set 2, code 0x9a on isa0060/serio0).
[4294818.205000] atkbd.c: Use 'setkeycodes e01a <keycode>' to make it known.
[4294818.434000] atkbd.c: Unknown key released (translated set 2, code 0x9a on isa0060/serio0).
[4294818.434000] atkbd.c: Use 'setkeycodes e01a <keycode>' to make it known.

Email:
[4294818.886000] atkbd.c: Unknown key pressed (translated set 2, code 0x9e on isa0060/serio0).
[4294818.886000] atkbd.c: Use 'setkeycodes e01e <keycode>' to make it known.
[4294819.109000] atkbd.c: Unknown key released (translated set 2, code 0x9e on isa0060/serio0).
[4294819.109000]

These Function key combinations don't work (pasted from https://wiki.ubuntu.com/LaptopTestingTeam/CompaqEvoN150):
|| '''Item''' || '''Operation''' || '''Keycode''' || 5.10 || 6.06 || 7.04 || '''Bug #''' ||
|| Fn+Space || page down || 0x39 0xb9 || Untested || Yes || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+Esc || N/A || || || || || ||
|| Fn+F3 ||minimize/maximise? || no response || Untested || No || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+F4 ||sleep || no response || Untested || No || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+m || 0 || 0x52 0xd2 || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+j || 1 || 0x4f 0xcf || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+k || 2 || 0x50 0xd0 || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+l || 3 || 0x51 0xd1 || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+u || 4 || 0x4b 0xcb || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+i || 5 || 0x4c 0xcc || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+o || 6 || 0x4d 0xcd || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+0 || * (multiply) || 0x37 0xb7 || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+p || - (subtract) || 0x4a 0xca || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+æ || + (add) || 0x4e 0xce || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+. || , (decimal separator/ comma) || 0x53 0xd3 || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||
|| Fn+- || / (divide) || 0xe0 0x35 0xe0 0xb5 || Untested || Untested || No || https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382 ||

Comment 9 KarlGoetz reports the same hotkey problem on his Compaq Armada E500. https://wiki.ubuntu.com/LaptopTestingTeam/CompaqArmadaE500
Comment 11 Dean Sas reports same hotkey problem on his N410C
Comment 14 Dean Sas gives dmesg output: https://bugs.launchpad.net/ubuntu/+source/hotkey-setup/+bug/35382/comments/14

Sebastien Estienne (sebest) wrote :

hello,
i think that you don't need to open one bug per key that doesn't work you could summarize it in one bug report as the issue may be the same for all keys.

to sum up:
hotkey 0x9e = 'email' fails
hotkey 0x9a = 'search' fails
hotkey 0x9f = 'home' fails
hotkey 0xa3 = 'help'

Duncan Lithgow (duncan-lithgow) wrote :

I wondered about that too, well, thanks for tying them together.

Duncan

Paul Sladen (sladen) wrote :

Please can you include the 'dmidecode' and 'showkey -u' information requested from:

  https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch

Many thanks (yes, since these are all on the same laptop, it's easiest to answer them in the same bug report).

description: updated

Please can you post each part of the 'dmidecode' output an a separate line, along with what it is (eg. manufacturer, system-name, model).

Duncan Lithgow (duncan-lithgow) wrote :

I'm not a complete moron you know, I have written it...

"According to 'dmidecode -s' I have a Compaq N150 0F02"

But here you go...

manufacturer = Compaq
system-name = COMPAQ N150
model = 0F02

Paul Sladen (sladen) wrote :

Good thing I asked, as the 'system-name' also starts with "COMPAQ_" :)

Paul Sladen (sladen) wrote :

Could you please drop to a console (see the wiki page above) and include the output from:

  sudo showkeycodes -u

and describe which line corresponds with which of email/search/...

Changed in hotkey-setup:
assignee: nobody → sladen
status: Unconfirmed → Needs Info
Duncan Lithgow (duncan-lithgow) wrote :

As is suggested in my original bug report, I get no response from the hotkeys (other keys seem to work fine)
$ sudo showkey -u

Duncan

KarlGoetz (kgoetz) wrote :

I have problems with these same keys on a Compaq Armada E500 [1].
They hotkeys have the same key codes.
hotkey 0x9e = 'email' fails
hotkey 0x9a = 'search' fails
hotkey 0x9f = 'home' fails
hotkey 0xa3 = 'help' fails

Manufacturer: Compaq
Product Name: Armada E500

[1] https://wiki.ubuntu.com/LaptopTestingTeam/CompaqArmadaE500

Paul Sladen (sladen) wrote :

Are these physically separate keys on the keyboard (eg. "special keys"), or are they activated with a Fn+something key combination?

Dean Sas (dsas) wrote :

Physically seperate keys on my N410C.

Dean Sas (dsas) wrote :

I've left the requested information a while ago but not changed status. Physically seperate keys it is.

Changed in hotkey-setup:
status: Needs Info → Confirmed
Matthew Garrett (mjg59) wrote :

Is there any kernel output when you press the keys? (Check with the dmesg command in a terminal)

Dean Sas (dsas) wrote :

Help:
[4417519.297000] atkbd.c: Unknown key pressed (translated set 2, code 0xa3 on isa0060/serio0).
[4417519.297000] atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.
[4417519.539000] atkbd.c: Unknown key released (translated set 2, code 0xa3 on isa0060/serio0).
[4417519.539000] atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.

Home
[4417520.189000] atkbd.c: Unknown key pressed (translated set 2, code 0x9f on isa0060/serio0).
[4417520.189000] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.
[4417520.407000] atkbd.c: Unknown key released (translated set 2, code 0x9f on isa0060/serio0).
[4417520.407000] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.

Search:
[4417520.888000] atkbd.c: Unknown key pressed (translated set 2, code 0x9a on isa0060/serio0).
[4417520.888000] atkbd.c: Use 'setkeycodes e01a <keycode>' to make it known.
[4417521.090000] atkbd.c: Unknown key released (translated set 2, code 0x9a on isa0060/serio0).

Email:
[4417521.090000] atkbd.c: Use 'setkeycodes e01a <keycode>' to make it known.
[4417521.543000] atkbd.c: Unknown key pressed (translated set 2, code 0x9e on isa0060/serio0).
[4417521.543000] atkbd.c: Use 'setkeycodes e01e <keycode>' to make it known.
[4417521.713000] atkbd.c: Unknown key released (translated set 2, code 0x9e on isa0060/serio0).
[4417521.713000] atkbd.c: Use 'setkeycodes e01e <keycode>' to make it known.

Dean Sas (dsas) wrote :

Ooops, that first line after email belongs to 'search'

Great to see some movement on this, yes the keys are separate on the N150, cute little silver things at the top of the keyboard inline with status lights and such.

Matthew Garrett (mjg59) wrote :

Duncan, is the kernel output the same for your system?

KarlGoetz (kgoetz) wrote :

The keys are physicaly seperate on the Compaq Armada E500 as well. I have a Compaq Evo N620c here as well - i'll test the keys on there and see what they produce.
kk

Dean Sas (dsas) wrote :

Duncan/Karl, could you check whether or not you get the same kernel output?

Mine looks the same to me:

Help:
[4294816.661000] atkbd.c: Unknown key pressed (translated set 2, code 0xa3 on isa0060/serio0).
[4294816.661000] atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.
[4294816.914000] atkbd.c: Unknown key released (translated set 2, code 0xa3 on isa0060/serio0).
[4294816.914000] atkbd.c: Use 'setkeycodes e023 <keycode>' to make it known.

Home:
[4294817.403000] atkbd.c: Unknown key pressed (translated set 2, code 0x9f on isa0060/serio0).
[4294817.403000] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.
[4294817.691000] atkbd.c: Unknown key released (translated set 2, code 0x9f on isa0060/serio0).
[4294817.691000] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.

Search:
[4294818.205000] atkbd.c: Unknown key pressed (translated set 2, code 0x9a on isa0060/serio0).
[4294818.205000] atkbd.c: Use 'setkeycodes e01a <keycode>' to make it known.
[4294818.434000] atkbd.c: Unknown key released (translated set 2, code 0x9a on isa0060/serio0).
[4294818.434000] atkbd.c: Use 'setkeycodes e01a <keycode>' to make it known.

Email:
[4294818.886000] atkbd.c: Unknown key pressed (translated set 2, code 0x9e on isa0060/serio0).
[4294818.886000] atkbd.c: Use 'setkeycodes e01e <keycode>' to make it known.
[4294819.109000] atkbd.c: Unknown key released (translated set 2, code 0x9e on isa0060/serio0).
[4294819.109000]

Dean Sas (dsas) wrote :

My dmidecode output is:
system-manufacturer: Compaq
system-product-name: Evo N410c
system-version: Not Specified

Is there anything else we need to do?

Paul Sladen (sladen) on 2007-03-22
Changed in hotkey-setup:
assignee: sladen → nobody

Just thought I'd mention that this bug still exists in Ubuntu 7.04 (Feisty Fawn)
https://wiki.ubuntu.com/LaptopTestingTeam/CompaqEvoN150

description: updated
description: updated
description: updated

I've updated the description with the comments and output since first reported. I didn't find anything new with google.

Sorry, another update, I've added some function keys that don't work. Dean and Karl, do you have the same issues with those function keys?

description: updated
description: updated
Andrew Pam (xanni) wrote :

Still doesn't work on Hardy with a Compaq Evo N410c

Steve Langasek (vorlon) wrote :

These keys are all listed in /lib/udev/keymaps/compaq-e_evo in udev-extras for karmic; it looks like we just need to add a couple more DMI system names to the list of matches.

affects: hotkey-setup (Ubuntu) → udev-extras (Ubuntu)
Changed in udev-extras (Ubuntu):
status: Confirmed → Triaged
Martin Pitt (pitti) on 2009-07-18
affects: udev-extras (Ubuntu) → udev (Ubuntu)
Changed in udev (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Fixed upstream in commit 1d11776. I now have the rule match to all "Evo N*" models.

Changed in udev (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 146-1

---------------
udev (146-1) karmic; urgency=low

  * New upstream release:
    - udevadm trigger "--retry-failed" replaced by "--type=failed"
    - RUN "ignore_error" option replaced by "fail_event_on_error"
    - Added HP Presario 2100 keymap. LP: #20223.
    - Added more keymap coverage for Compaq Evo models. LP: #35382.
    - Added Fujitsu Amilo M keymap. LP: #48547.
    - Added Compal Hel80i keymap. LP: #198530.
    - Added Zepto ZNote keymap. LP: #400252.
    - Added Everex Stepnote XT5000T keymap. LP: #400921.
    - Added rules to switch mode of Huawei E1550 GSM modem. LP: #401655.
    - Various other keymap and modem updates.

  [ Martin Pitt ]
  * debian/control: Add missing Breaks: casper (<< 1.174) to avoid breaking
    upgrades from jaunty in wubi installations. (LP: #400138)

 -- Scott James Remnant <email address hidden> Tue, 25 Aug 2009 13:45:17 +0100

Changed in udev (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers