Regression: Multimedia keys on LX710 stopped working

Bug #321740 reported by Fabián Rodríguez on 2009-01-27
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
udev (Ubuntu)
Medium
Martin Pitt

Bug Description

I am using a Logitech LX710 keyboard and mouse with an RF transmitter.

In Hardy this keyboard worked with multimedia keys enabled.

In Jaunty alpha 3 Mute, Sound up and Sound Down don' t work anymore.

This is similar to Bug #281993.

lsusb entry for this device is:
Bus 003 Device 004: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser

description: updated
description: updated
Smurphy (smurphy-linux) wrote :
Download full text (8.0 KiB)

I can confirm this Bug. Having the same issue with a Cordless Desktop MX700.
The Mouse is working OK, but almost all Multimedia Keys are working only after I unplug and Replug the Cordless Receiver.
I attached the xorg.0.log file, with the content of informations during the unplugging and replugging.
Here is what the dmesg-output looks like when unplugging and replugging this device.

[ 129.856059] usb 3-1: USB disconnect, address 4
[ 133.885041] usb 3-1: new low speed USB device using uhci_hcd and address 5
[ 134.063559] usb 3-1: configuration #1 chosen from 1 choice
[ 134.088412] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.2/usb3/3-1/3-1:1.0/input/input9
[ 134.136210] input,hidraw0: USB HID v1.10 Keyboard [Logitech USB Receiver] on usb-0000:00:1d.2-1
[ 134.172670] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.2/usb3/3-1/3-1:1.1/input/input10
[ 134.256194] input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.2-1

Here the output of "sudo lsusb -v" - Limiting the output to the Logitech receiver only:
Bus 003 Device 005: ID 046d:c50b Logitech, Inc. Cordless Desktop Optical
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x046d Logitech, Inc.
  idProduct 0xc50b Cordless Desktop Optical
  bcdDevice 21.00
  iManufacturer 1 Logitech
  iProduct 2 USB Receiver
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 59
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 98mA
    Interface Descriptor:
      bLength 9
...

Read more...

Chris Coulson (chrisccoulson) wrote :

Hi,

Could you please do the following in a terminal:

1) Run "killall gnome-settings-daemon"
2) Run "xev"
3) Press your non-functioning multimedia keys and then post any output that appears from xev in to this bug report.

Thanks

Changed in linux:
status: New → Incomplete
Smurphy (smurphy-linux) wrote :

You want this to be done before or after replugging the Cordless Receiver ?
I'll do it before replugging - as that's where it doesn't work. also - I use kubuntu - anything I should killt here before doing it ?
gnome-settings-daemon is not used here.

With xev - all Multimedia keys, _ALL_ are not working. This includes:
Go, Back, User, F-Lock, E-Mail, Messenger-MSN, Webcam, Previous/Next Track, Media Key, Volume Up/Down, PLay/Pause, Stop, iTouch, Search, Shopping, Favorites and MyHome.

On the Mouse - Buttons 4, 5, 6 are not working.

So - it's a total loss of any non keyboard specific functionality. IMHO the driver goes into fallback defaults mode.

Fabián Rodríguez (magicfab) wrote :

Smurphy would you open a separate bug for that ? Please don't hijack bugs about different hardware.

Chris, using xev there no output at all from any of the multimedia keys.

I tried all the extra keys on this keyboard and only FN-F1 provokes an (unrelated) notification message:
"Power Information - Computer is running on AC Power"
See attached FN-F1-notification.png

I' ve also attached a picture of the keyboard highlighting all the extra keys that don't work.

Fabián Rodríguez (magicfab) wrote :

All buttons on the mouse are working as expected BTW.

Fabián Rodríguez (magicfab) wrote :

Similar bugs were reported and fixed in Hardy. See:
 * Bug #182704
 * Bug #182165

Smurphy (smurphy-linux) wrote :

IT is IMHO the same bug which affects both keyboards, as the same functionality is affected.
I could of course open a new Bug - but I don't think it is different.

Smurphy (smurphy-linux) wrote :

These 2 Bugs are not similar (Bug #182704 and Bug #182165) as they are using the old Drivers, kdb/Corepointer etc. and not evdev. If I configure my System to use the old Drivers - everything works as expected. The Bug however here is directly related to evdev - as it does not recognize the real capabilities of the attache keyboard/mouse. And I´d like to not having to fiddle with the configuration everytime I install a system with a Cordless Desktop like keyboard. hence the Bugfix request.

To the mouse - your mouse has 5 Buttons - with the extra buttons most probably being shortcuts to Mouse-Wheel up/down. These do work also on my Mouse. However - the other 3 Keys I have - Forward/Backward and Page Down - are not working. Again - Extra keys/functions on the Keyboard and the Mouse do not work.

And that - IMHO is exactly the same behavior as you describe on yours.

Smurphy (smurphy-linux) wrote :

Just saw the following on the pages of http://keytouch.sourceforge.net/ :
  When your keyboard is connected via USB you may have noticed that some extra function keys don't work. Note that most keyboard files in keyTouch are for a PS/2 connection and if a keyboard file is for a USB connection the name of the keyboard file will contain "(USB)". But still even if you are using the right keyboard file, some keys may not work. This is because the current USB input driver in the Linux kernel does not allow us to get these keys working. Currently I am modifying this driver so that we can get all keys working. This modification will be applied to the Linux kernel.
  So at the moment I recommend you to connect your keyboard via PS/2 and wait for a new version of the USB input driver. I will also write a new version of keyTouch that will work perfectly together with the new driver.

So yes - it's a Bug - and hopefully a new kernel version will fix it, and some new keytouch keyboard files mainly done for USB.

Fabián Rodríguez (magicfab) wrote :

Smurphy this bug is only about the LX710.

Your issue is different, in my case re-plugging the radio emitter doesn't change anything.

Bug #281993 deals with multimedia keys not working in general, but specific fixes may be needed for different hardware.

Chris Coulson (chrisccoulson) wrote :

Fabián - if the keys producde no output in xev when gnome-settings-daemon is running, could you please switch to a terminal (CTRL+ALT+F1) and try the following:

1) Run "sudo showkey -k" and press the keys that don't work. Could you note any keycodes, and which keys they belong too (if you see any).
2) Could you also do the same, but with "sudo showkey -s", and note any scancodes.

I appreciate that might be a bit of a pain with the scancodes

Smurphy - for now, it would be better to report your problem in a separate report. We can always dupe them later if there is enough evidence to suggest the problems are related. However, looking after what might be 2 separate problems in one report will just confuse things later on :)

Chris Coulson (chrisccoulson) wrote :

Incidentally, I've noticed none of the media keys work on my Logitech keyboard too, although I'm running Jaunty in a virtual machine. I haven't looked at it in any depth yet though

Fabián Rodríguez (magicfab) wrote :

Hi Chris,

I have scancodes for each and every key when using sudo showkey (which is the same as -k) and -s too.

I am gathering the codes now. Ugh :(

Fabián Rodríguez (magicfab) wrote :

Ouput for sudo showkey -k:

Left side, from bottom:
420: 100%
418: Zoom Out
419: Zoom In
371: Rotate picture right (combine with CTRL to rotate left)
392: Favorite picture application (F-spot)

236: Microsoft Word
421: Microsoft Excel
423: Calendar application
140: Calculator application (gacalctool)
131: Editor application (Gedit)
182: File manager (Nautilus)
210: Print
234: Save

114: Volume down
113: Mute
115: Volume Up
217: Internet Search
155: Email application (Evolution)
430: VoIP application

148: Programmable key " a "
149: Programmable key " b "
202: Programmable key " c "
203: Programmable key " d "

127: Menu key (see http://en.wikipedia.org/wiki/Menu_key )
70: Scroll lock (see http://logitech-en-amr.custhelp.com/cgi-bin/logitech_en_amr.cfg/php/enduser/std_adp.php?p_faqid=9116 )

171: Favorite media application (Rhythmbox)
410: Music shuffle
163: Skip Forward
165: Skip Backward
164: Play/Pause

Chris Coulson (chrisccoulson) wrote :

Thanks. It seems like the kernel is producing valid keycodes for all these keys, so I'll assign to xkeyboard-config for now

Fabián Rodríguez (magicfab) wrote :

There have been a few updates to X, hal and other keyboard related stuff, however the problem persists.

I can' t use System > Prefs > Keyboard shortcuts either.

Fabián Rodríguez (magicfab) wrote :

I see this is still marked as incomplete. What other information can I provide ?

Seems Fabian has provided the request information. Flipping status from Incomplete to Confirmed so this does not get overlooked. Thanks.

Changed in xkeyboard-config:
status: Incomplete → Confirmed
Changed in linux:
status: New → Invalid
Fabián Rodríguez (magicfab) wrote :

Bug #281993 has a fix now, apparently, it may be worth checking if the same logic would help fix this one.

Bryce Harrington (bryce) wrote :

Chris and Leann, xkeyboard-config no longer really handles hotkey stuff any longer (it provides the evdev keymap but that's about it). hal-info is probably a better next stopping point for hotkey bugs once the kernel is found to be doing stuff properly.

Changed in xkeyboard-config:
status: Confirmed → New
Id2ndR (id2ndr) wrote :

Same with Logitech Cordless Internet Pro

Id2ndR (id2ndr) wrote :

Ouput for sudo showkey -k for the Logitech Cordless Internet Pro:

113: Mute
114: Volume down
115: Volume Up
155: Email application (Evolution)
156: Favoris
172: www
171: Favorite media application (Rhythmbox)
164: Play/Pause

Id2ndR (id2ndr) wrote :

Fix for me this the fix of bug #318261 (package xorg-server 2:1.5.99.902-0ubuntu7)

Martin Pitt (pitti) wrote :

Thanks Fabian. Can you please attach the output of "lshal", too?

Changed in hal-info:
status: New → Incomplete
assignee: nobody → pitti
Fabián Rodríguez (magicfab) wrote :

lshal.txt attached.

Id2ndR, this is about the LX710, please open another bug for your keyboard.

The following keys are now working, not sure since when (showing output of sudo showkey -k as used above), only those with (*) or (**) are working, key action as reported by Keyboard Shortcuts app is indicated after each working key:

(*) Working as expected
(**) Reports a key that can be mapped with Keyboard Shortcuts, but is wrongly assigned

Left side, from bottom:
420: 100%-> Nothing
418: Zoom Out-> Nothing
419: Zoom In-> Nothing
371: Rotate picture right (combine with CTRL to rotate left)-> Nothing
392: Favorite picture application (F-spot)-> Nothing

(**) 236: Microsoft Word -> XF86Battery
421: Microsoft Excel -> Nothing
423: Calendar application -> Nothing
(*) 140: Calculator application (gacalctool) -> XF86Calculator
(**) 131: Editor application (Gedit) ->Undo
182: File manager (Nautilus) -> Redo
(*) 210: Print -> Print
(*) 234: Save -> XF86Save

(*) 114: Volume down
(*) 113: Mute
(*) 115: Volume Up
(**) 217: Internet Search -> XF86Search
(*) 155: Email application (Evolution) -> XF86Mail
430: VoIP application

(*) 148: Programmable key " a " -> XF86Launch1
(*) 149: Programmable key " b " -> XF86Launch2
(*) 202: Programmable key " c " -> XF86Launch3
(*) 203: Programmable key " d " -> XF86Launch4

(*) 127: Menu key (see http://en.wikipedia.org/wiki/Menu_key ) -> Menu
(*) 70: Scroll lock (see http://logitech-en-amr.custhelp.com/cgi-bin/logitech_en_amr.cfg/php/enduser/std_adp.php?p_faqid=9116 ) -> Scroll Lock

(**) 171: Favorite media application (Rhythmbox) -> XF86Tools
410: Music shuffle
(*) 163: Skip Forward -> XF86AudioNext
(*) 165: Skip Backward -> XF86AudioPrev
(*) 164: Play/Pause-> XF86AudioPlay

How can I contribute a keyboard model layout with corrected mappings so it shows up in System > Preferences > Keyboard > Layouts > Keyboard model ? Of course some keys would be missing but all multimedia related keys would work.

Fabián Rodríguez (magicfab) wrote :
Martin Pitt (pitti) on 2009-03-10
Changed in hal-info:
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

I'm afraid the keymap handling changed quite a bit in karmic. Can you please attach /var/log/udev? (From Jaunty will do). Thanks!

affects: hal-info (Ubuntu) → udev-extras (Ubuntu)
Changed in udev-extras (Ubuntu):
status: Triaged → Incomplete

Here it is from Jaunty amd64.

Martin Pitt (pitti) wrote :

So, the following keys

  420: 100%-> Nothing
  418: Zoom Out-> Nothing
  419: Zoom In-> Nothing
  371: Rotate picture right (combine with CTRL to rotate left)-> Nothing
  392: Favorite picture application (F-spot)-> Nothing

cannot be used under X.org; X.org can only use key symbols up to 255 (see bug 313514).

From the remaining ones, it seems that only these two are wrong:

  236: Microsoft Word -> XF86Battery
  131: Editor application (Gedit) ->Undo

For those I need the current scan codes as shown by "showkey -s".

Martin Pitt (pitti) on 2009-06-29
affects: udev-extras (Ubuntu) → udev (Ubuntu)
bortol88 (danieleb88) wrote :

Hello.
I have the same problem with this keyboard.
The upgrades of ubuntu don't resolve my problem.
Who can help me?
Thank's.

Fabián Rodríguez (magicfab) wrote :

Most keys work as expected for me now. I lack the time to describe those few that don't (VoiP etc) so I'll provide the requested info now, get to the rest later.

sudo showkey -s returns the following:

Microsoft Word key: 0xe0 0x71
Editor application (Gedit) key: 0xe0 0x07 when pressed, 0xe0 0x87 right after

I thought I'd check the other keys in case # 313514 gets fixed. Unfortunately this is the result:
100%: nothing
Zoom Out: nothing
Zoom In: nothing
Rotate picture right: nothing
Rotate picture left (same as above key but combined with CTRL): nothing
Favorite picture application (F-spot): nothing

@bortol88, you need to be using Ubuntu 9.04 with all latest updates. I've tested this on different systems with the same keyboard. If you're still having trouble, please file a question here, mentioning this bug report (#321740) and your problem:
https://answers.launchpad.net/ubuntu/+source/udev/+addquestion

Changed in udev (Ubuntu):
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

OK, I have a tentative fix for this. In current Karmic (daily live system) or Jaunty with my PPA's udev-extras (see http://martinpitt.wordpress.com/2009/05/08/devicekit-update-future-handling-of-fn-key-maps/), please apply the attached patch with

  sudo patch /lib/udev/rules.d/95-keymap.rules keymap-logitech-usb.patch

and drop the other attachment (usb-logitech) into /lib/udev/keymaps/. Then reboot, and check if the editor/word keys are working then. I assigned them to "prog1" and "prog2" (XF86Launch1/XF86Launch2) for now. Linux also knows "wordprocessor" and "edit", but unfortunately they are outside of the range which X.org can handle.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

Any chance to test this patch?

2009/8/25 Martin Pitt <email address hidden>

> Any chance to test this patch?
>
> --
> Regression: Multimedia keys on LX710 stopped working
> https://bugs.launchpad.net/bugs/321740
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Invalid
> Status in “udev” package in Ubuntu: Incomplete
>
> Bug description:
> I am using a Logitech LX710 keyboard and mouse with an RF transmitter.
>
> In Hardy this keyboard worked with multimedia keys enabled.
>
> In Jaunty alpha 3 Mute, Sound up and Sound Down don' t work anymore.
>
> This is similar to Bug #281993.
>
> lsusb entry for this device is:
> Bus 003 Device 004: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop
> Laser
>
> I solved this when i try to compile kernel 2.6.30-4.
Thank you very much.
If i will have any other problems, i post it.
Regards

Martin Pitt (pitti) wrote :

Closing as per reporter's feedback. Thanks!

Changed in udev (Ubuntu):
status: Incomplete → Fix Released
Fabián Rodríguez (magicfab) wrote :

Setting back to incomplete, I haven't reported this as tested or fixed yet. As I say in #32, som ekeys still don't work. I'll try and test the proposed fix this week.

Changed in udev (Ubuntu):
status: Fix Released → Incomplete
Martin Pitt (pitti) wrote :

Ping?

Smurphy (smurphy-linux) wrote :

Using KUbuntu 9.10 - functionality came back with my Cordless Desktop MX700 (Keyboard and Mouse).

Martin Pitt (pitti) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in udev (Ubuntu):
status: Incomplete → Invalid
Fabián Rodríguez (magicfab) wrote :

I've gotten around to testing this on UBuntu 11.10 and 12.04 LTS and the keys work as expected. Marked as fix-released.

Changed in linux (Ubuntu):
status: Invalid → Fix Released
Changed in udev (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers