/etc/udev/rules.d not a directory on boot

Bug #315780 reported by Arenlor on 2009-01-10
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
udev
Fix Released
Undecided
Unassigned
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: udev

Since the recent update of udev which changed rules.d on boot it's complained about it not being a directory and that it can't open it.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: udev 136-2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SourcePackage: udev
Uname: Linux 2.6.28-4-generic x86_64

Arenlor (arenlor) wrote :

upstream dropped the message from an error to informational for /etc

Changed in udev:
status: New → Fix Committed
Tom Badran (tom-badran) wrote :

Just installed jaunty alpha 3 and can confirm this. Causes my laptop to beep like crazy for 4 or 5 seconds after printing this message.

Changed in udev:
status: New → Confirmed
Changed in udev:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 137-1

---------------
udev (137-1) jaunty; urgency=low

  * New upstream release:
    - udevadm test no longer has force option.
    - udevd has --resolve-names=early|late|never option.
    - Group of IDE CD-ROM drives fixed. LP: #315997.
    - Group of DRI subsystem fixed. LP: #317430.
    - /etc/udev/rules.d not existing is not an error. LP: #315780.
    - Bug where device nodes would be replaced by symlinks on rename has been
      fixed. LP: #315979.

  * Use --resolve-names=never in the installer and initramfs, since we don't
    have a useful name service. LP: #319199.
  * Since we don't have to worry about group lookup, we may as well copy the
    default rules into the initramfs as well. This actually double-solves
    LP: #315979.
  * Make sure the root filesystem is writable before attempting to copy
    generated rules across. LP: #224870.
  * Remove /dev/MAKEDEV symlink; the FHS no longer requires it when /dev
    is automatically managed.

  * It is not permitted to call udevadm trigger or settle during an upgrade
    without depending on udev. Attempting this will fail.
  * Change /etc/init.d/udev restart to actually restart the daemon, with a
    bit of detection to print a warning if we missed events while the
    daemon was down.
  * Refreshing /dev is now /etc/init.d/udev refresh-devices
  * Restart udev daemon after upgrade. LP: #317944.

 -- Scott James Remnant <email address hidden> Fri, 23 Jan 2009 15:15:07 +0000

Changed in udev:
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-04-16
Changed in udev:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers